summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-04 02:08:03 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-04 02:08:03 +0000
commit70b34162fc958cde6d70637abb4ad800f9fc3195 (patch)
tree119729fce07c73974e80a90b4850768c6adf38e5 /sys-apps/pcsc-lite
parenthppa stable to shut morfic up #120840 (diff)
downloadgentoo-2-70b34162fc958cde6d70637abb4ad800f9fc3195.tar.gz
gentoo-2-70b34162fc958cde6d70637abb4ad800f9fc3195.tar.bz2
gentoo-2-70b34162fc958cde6d70637abb4ad800f9fc3195.zip
Version bump #124867 by Alon Bar-Lev.
(Portage version: 2.1_pre5-r2)
Diffstat (limited to 'sys-apps/pcsc-lite')
-rw-r--r--sys-apps/pcsc-lite/ChangeLog7
-rw-r--r--sys-apps/pcsc-lite/files/digest-pcsc-lite-1.3.03
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.3.0.ebuild48
3 files changed, 57 insertions, 1 deletions
diff --git a/sys-apps/pcsc-lite/ChangeLog b/sys-apps/pcsc-lite/ChangeLog
index 905ee2e6e849..32eaa7d5c2b8 100644
--- a/sys-apps/pcsc-lite/ChangeLog
+++ b/sys-apps/pcsc-lite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/pcsc-lite
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.17 2006/02/10 02:05:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.18 2006/03/04 02:08:03 vapier Exp $
+
+*pcsc-lite-1.3.0 (04 Mar 2006)
+
+ 04 Mar 2006; Mike Frysinger <vapier@gentoo.org> +pcsc-lite-1.3.0.ebuild:
+ Version bump #124867 by Alon Bar-Lev.
*pcsc-lite-1.2.9_beta10 (10 Feb 2006)
diff --git a/sys-apps/pcsc-lite/files/digest-pcsc-lite-1.3.0 b/sys-apps/pcsc-lite/files/digest-pcsc-lite-1.3.0
new file mode 100644
index 000000000000..44696451f4a8
--- /dev/null
+++ b/sys-apps/pcsc-lite/files/digest-pcsc-lite-1.3.0
@@ -0,0 +1,3 @@
+MD5 ccbb595be0e1d47c9f9f449f183bea6c pcsc-lite-1.3.0.tar.gz 836866
+RMD160 788cce5f30c514b3e743500116aeb97e085c5471 pcsc-lite-1.3.0.tar.gz 836866
+SHA256 64c505f214dd178a506fb6870b1675b8a2739546a6e6da9cd1900722047b8d42 pcsc-lite-1.3.0.tar.gz 836866
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.3.0.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.3.0.ebuild
new file mode 100644
index 000000000000..f3d1833a92d1
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/pcsc-lite-1.3.0.ebuild,v 1.1 2006/03/04 02:08:03 vapier Exp $
+
+STUPID_NUM=1472
+MY_P="${PN}-${PV/_/-}"
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="http://www.linuxnet.com/middle.html"
+SRC_URI="http://alioth.debian.org/download.php/${STUPID_NUM}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="static debug"
+
+RDEPEND="!static? ( dev-libs/libusb )"
+DEPEND="dev-libs/libusb
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ econf \
+ --enable-extendedapdu \
+ --enable-usbdropdir=/usr/lib/readers/usb \
+ --enable-muscledropdir=/usr/share/pcsc/services \
+ $(use_enable debug) \
+ $(use_enable static) \
+ || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog DRIVERS HELP INSTALL NEWS README SECURITY
+ dodoc doc/*.pdf doc/README.DAEMON
+ docinto sample
+ dodoc src/utils/README src/utils/sample.*
+ rm -r "${D}"/usr/doc
+
+ newinitd "${FILESDIR}"/pcscd-init pcscd
+ newconfd "${FILESDIR}"/pcscd-confd pcscd
+}
+
+pkg_postinst() {
+ ewarn "You should run 'revdep-rebuild --soname libpcsclite.so.0'"
+}