summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2008-08-30 06:54:13 +0000
committerDaniel Black <dragonheart@gentoo.org>2008-08-30 06:54:13 +0000
commita066a1ad7f3a63f6c93906c5df41edf4d1968f91 (patch)
treeecfb8cd9d7f371aa90ef08dbf7d4ddb5ccb7d891 /sys-apps/pcsc-lite
parentversion bump as per bug #231853 thanks to Francisco. dependency change as per... (diff)
downloadgentoo-2-a066a1ad7f3a63f6c93906c5df41edf4d1968f91.tar.gz
gentoo-2-a066a1ad7f3a63f6c93906c5df41edf4d1968f91.tar.bz2
gentoo-2-a066a1ad7f3a63f6c93906c5df41edf4d1968f91.zip
version bump as per bug #231856 thanks to Francisco and Alon.
(Portage version: 2.2_rc8/cvs/Linux 2.6.22-vs2.2.0.7-gentoo x86_64)
Diffstat (limited to 'sys-apps/pcsc-lite')
-rw-r--r--sys-apps/pcsc-lite/ChangeLog8
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.4.102.ebuild65
2 files changed, 72 insertions, 1 deletions
diff --git a/sys-apps/pcsc-lite/ChangeLog b/sys-apps/pcsc-lite/ChangeLog
index 8fe76b36798b..f0b76673b056 100644
--- a/sys-apps/pcsc-lite/ChangeLog
+++ b/sys-apps/pcsc-lite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/pcsc-lite
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.57 2008/01/09 13:26:54 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.58 2008/08/30 06:54:13 dragonheart Exp $
+
+*pcsc-lite-1.4.102 (30 Aug 2008)
+
+ 30 Aug 2008; Daniel Black <dragonheart@gentoo.org>
+ +pcsc-lite-1.4.102.ebuild:
+ version bump as per bug #231856 thanks to Francisco and Alon.
*pcsc-lite-1.4.99 (09 Jan 2008)
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.4.102.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.4.102.ebuild
new file mode 100644
index 000000000000..f7db60f0ec74
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.4.102.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/pcsc-lite-1.4.102.ebuild,v 1.1 2008/08/30 06:54:13 dragonheart Exp $
+
+inherit multilib
+
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="http://www.linuxnet.com/middle.html"
+
+if [[ "${PV}" = "9999" ]]; then
+ inherit subversion autotools
+ ESVN_REPO_URI="svn://svn.debian.org/pcsclite/trunk"
+ S="${WORKDIR}/trunk"
+else
+ STUPID_NUM="2479"
+ MY_P="${PN}-${PV/_/-}"
+ SRC_URI="http://alioth.debian.org/download.php/${STUPID_NUM}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="static debug usb hal"
+
+RDEPEND="usb? ( dev-libs/libusb )
+ hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ if [ "${PV}" != "9999" ]; then
+ unpack ${A}
+ cd "${S}"
+ else
+ subversion_src_unpack
+ S="${WORKDIR}/trunk/PCSC"
+ cd "${S}"
+ AT_M4DIR="m4" eautoreconf
+ fi
+}
+
+src_compile() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --enable-usbdropdir="/usr/$(get_libdir)/readers/usb" \
+ --enable-muscledropdir="/usr/share/pcsc/services" \
+ --enable-runpid="/var/run/pcscd.pid" \
+ $(use_enable hal libhal) \
+ $(use_enable usb libusb) \
+ $(use_enable debug) \
+ $(use_enable static) \
+ || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ prepalldocs
+
+ dodoc AUTHORS DRIVERS HELP README SECURITY ChangeLog
+
+ newinitd "${FILESDIR}/pcscd-init" pcscd
+ newconfd "${FILESDIR}/pcscd-confd" pcscd
+}