summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-01-31 12:30:08 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-01-31 12:30:08 +0000
commit341283ae5bce3172bb8880b1d327149d72e36e4d (patch)
treee8fbd0e5bc1b9f95298f80cbcb796c8e76930352 /sys-apps/pkgcore
parentRe-add addwrite on /opt/intel, needed for a first install (diff)
downloadgentoo-2-341283ae5bce3172bb8880b1d327149d72e36e4d.tar.gz
gentoo-2-341283ae5bce3172bb8880b1d327149d72e36e4d.tar.bz2
gentoo-2-341283ae5bce3172bb8880b1d327149d72e36e4d.zip
Fixing test failure, patch by Brian Harring. Fixes #216942
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/pkgcore')
-rw-r--r--sys-apps/pkgcore/ChangeLog8
-rw-r--r--sys-apps/pkgcore/files/pkgcore-sandbox.patch22
-rw-r--r--sys-apps/pkgcore/pkgcore-0.4.7.14.ebuild4
-rw-r--r--sys-apps/pkgcore/pkgcore-0.4.7.15-r1.ebuild75
4 files changed, 106 insertions, 3 deletions
diff --git a/sys-apps/pkgcore/ChangeLog b/sys-apps/pkgcore/ChangeLog
index f6f6db0527f0..7c1d76cd4b62 100644
--- a/sys-apps/pkgcore/ChangeLog
+++ b/sys-apps/pkgcore/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/pkgcore
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pkgcore/ChangeLog,v 1.75 2009/01/30 04:31:18 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pkgcore/ChangeLog,v 1.76 2009/01/31 12:30:07 patrick Exp $
+
+*pkgcore-0.4.7.15-r1 (31 Jan 2009)
+
+ 31 Jan 2009; Patrick Lauer <patrick@gentoo.org>
+ +files/pkgcore-sandbox.patch, +pkgcore-0.4.7.15-r1.ebuild:
+ Fixing test failure, patch by Brian Harring. Fixes #216942
30 Jan 2009; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
-pkgcore-0.4.7.13.ebuild:
diff --git a/sys-apps/pkgcore/files/pkgcore-sandbox.patch b/sys-apps/pkgcore/files/pkgcore-sandbox.patch
new file mode 100644
index 000000000000..f40e8570719d
--- /dev/null
+++ b/sys-apps/pkgcore/files/pkgcore-sandbox.patch
@@ -0,0 +1,22 @@
+=== modified file 'pkgcore/test/test_spawn.py'
+--- pkgcore/test/test_spawn.py 2008-08-12 23:39:01 +0000
++++ pkgcore/test/test_spawn.py 2009-01-31 03:16:51 +0000
+@@ -78,7 +78,7 @@
+ self.assertTrue(ret[1], msg="no output; exit code was %s; script "
+ "location %s" % (ret[0], fp))
+ self.assertIn("libsandbox.so", [os.path.basename(x.strip()) for x in
+- ret[1][0].split(":")])
++ ret[1][0].split()])
+ os.unlink(fp)
+
+
+@@ -102,7 +102,7 @@
+ os.rmdir(dpath)
+ self.assertIn("libsandbox.so", [os.path.basename(x.strip()) for x in
+ spawn.spawn_get_output(
+- fp, spawn_type=spawn.spawn_sandbox, chdir='/')[1][0].split(":")])
++ fp, spawn_type=spawn.spawn_sandbox, chdir='/')[1][0].split()])
+ os.unlink(fp)
+ finally:
+ if cwd is not None:
+
diff --git a/sys-apps/pkgcore/pkgcore-0.4.7.14.ebuild b/sys-apps/pkgcore/pkgcore-0.4.7.14.ebuild
index e4d55a1cc20c..f0b9f6061ed5 100644
--- a/sys-apps/pkgcore/pkgcore-0.4.7.14.ebuild
+++ b/sys-apps/pkgcore/pkgcore-0.4.7.14.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pkgcore/pkgcore-0.4.7.14.ebuild,v 1.1 2008/12/20 01:36:01 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pkgcore/pkgcore-0.4.7.14.ebuild,v 1.2 2009/01/31 12:30:07 patrick Exp $
inherit distutils eutils
diff --git a/sys-apps/pkgcore/pkgcore-0.4.7.15-r1.ebuild b/sys-apps/pkgcore/pkgcore-0.4.7.15-r1.ebuild
new file mode 100644
index 000000000000..c7f797cb92c1
--- /dev/null
+++ b/sys-apps/pkgcore/pkgcore-0.4.7.15-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pkgcore/pkgcore-0.4.7.15-r1.ebuild,v 1.1 2009/01/31 12:30:07 patrick Exp $
+
+inherit distutils eutils base
+
+DESCRIPTION="pkgcore package manager"
+HOMEPAGE="http://www.pkgcore.org"
+SRC_URI="http://www.pkgcore.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/python-2.4
+ >=dev-python/snakeoil-0.2
+ >=app-shells/bash-3.0
+ || ( >=dev-lang/python-2.5 dev-python/pycrypto )"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/docutils-0.4 )"
+
+DOCS="AUTHORS NEWS"
+
+PATCHES=( "${FILESDIR}/pkgcore-sandbox.patch" )
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ ./build_docs.py || die "doc building failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r doc dev-notes
+ doman man/*.1
+ fi
+
+ dodoc doc/*.rst man/*.rst
+ docinto dev-notes
+ dodoc dev-notes/*.rst
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ pplugincache
+
+ if [[ -d "${ROOT}etc/pkgcore/plugins" ]]; then
+ elog "You still have an /etc/pkgcore/plugins from pkgcore 0.1."
+ elog "It is unused by pkgcore >= 0.2, remove it now."
+ die "remove /etc/pkgcore/plugins from pkgcore 0.1"
+ fi
+
+ # This is left behind by pkgcore 0.2.
+ rm -f "${ROOT}"usr/$(get_libdir)/python${PYVER}/site-packages/pkgcore/plugins/plugincache
+}
+
+pkg_postrm() {
+ python_version
+ # Careful not to remove this on up/downgrades.
+ local sitep="${ROOT}"usr/$(get_libdir)/python${PYVER}/site-packages
+ if [[ -e "${sitep}/pkgcore/plugins/plugincache2" ]] &&
+ ! [[ -e "${sitep}/pkgcore/plugin.py" ]]; then
+ rm "${sitep}/pkgcore/plugins/plugincache2"
+ fi
+ distutils_pkg_postrm
+}
+
+src_test() {
+ "${python}" setup.py test || die "testing returned non zero"
+}