summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-04-18 11:26:43 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-04-18 11:26:43 +0000
commit6b010c73ea9e8260fa262b1e1fad64080e13fda0 (patch)
tree509a2eb52cbe9a9e1254036eaab0a9d0fc906fe4 /sys-apps/pmount
parentbackport r1523 and r1524 to fix compile on FreeBSD and still provide the syst... (diff)
downloadgentoo-2-6b010c73ea9e8260fa262b1e1fad64080e13fda0.tar.gz
gentoo-2-6b010c73ea9e8260fa262b1e1fad64080e13fda0.tar.bz2
gentoo-2-6b010c73ea9e8260fa262b1e1fad64080e13fda0.zip
Bump to 0.9.19 with ext4 support patch, bug #265453.
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/pmount')
-rw-r--r--sys-apps/pmount/ChangeLog8
-rw-r--r--sys-apps/pmount/files/pmount-0.9.19-ext4-support.patch15
-rw-r--r--sys-apps/pmount/pmount-0.9.19.ebuild59
3 files changed, 81 insertions, 1 deletions
diff --git a/sys-apps/pmount/ChangeLog b/sys-apps/pmount/ChangeLog
index 872261a4cbef..784bfe5ceee7 100644
--- a/sys-apps/pmount/ChangeLog
+++ b/sys-apps/pmount/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/pmount
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/ChangeLog,v 1.62 2009/02/01 01:09:23 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/ChangeLog,v 1.63 2009/04/18 11:26:43 eva Exp $
+
+*pmount-0.9.19 (18 Apr 2009)
+
+ 18 Apr 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/pmount-0.9.19-ext4-support.patch, +pmount-0.9.19.ebuild:
+ Bump to 0.9.19 with ext4 support patch, bug #265453.
*pmount-0.9.18 (01 Feb 2009)
diff --git a/sys-apps/pmount/files/pmount-0.9.19-ext4-support.patch b/sys-apps/pmount/files/pmount-0.9.19-ext4-support.patch
new file mode 100644
index 000000000000..34a170d5710c
--- /dev/null
+++ b/sys-apps/pmount/files/pmount-0.9.19-ext4-support.patch
@@ -0,0 +1,15 @@
+---
+ Allows mounting of ext4 filesystems.
+
+ Gentoo: https://bugs.gentoo.org/show_bug.cgi?id=265453
+
+--- a/src/fs.c 2009-02-12 23:45:40.000000000 +0100
++++ b/src/fs.c 2009-04-08 16:12:09.000000000 +0200
+@@ -26,6 +26,7 @@
+ { "hfsplus", "nosuid,nodev,user", 1, NULL, 0 },
+ { "hfs", "nosuid,nodev,user", 1, "077", NULL,
+ ",file_umask=%04o,dir_umask=%04o"},
++ { "ext4", "nodev,noauto,nosuid,user,errors=continue", 0, NULL, 0 },
+ { "ext3", "nodev,noauto,nosuid,user,errors=continue", 0, NULL, 0 },
+ { "ext2", "nodev,noauto,nosuid,user,errors=continue", 0, NULL, 0 },
+ { "reiserfs", "nodev,noauto,nosuid,user", 0, NULL, 0 },
diff --git a/sys-apps/pmount/pmount-0.9.19.ebuild b/sys-apps/pmount/pmount-0.9.19.ebuild
new file mode 100644
index 000000000000..791ce9dda66b
--- /dev/null
+++ b/sys-apps/pmount/pmount-0.9.19.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/pmount-0.9.19.ebuild,v 1.1 2009/04/18 11:26:43 eva Exp $
+
+EAPI="2"
+
+inherit base eutils
+
+DESCRIPTION="Policy based mounter that gives the ability to mount removable devices as a user"
+HOMEPAGE="http://pmount.alioth.debian.org/"
+SRC_URI="http://alioth.debian.org/frs/download.php/2867/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="crypt hal"
+
+RDEPEND="hal? ( >=sys-apps/dbus-0.33 >=sys-apps/hal-0.5.2 )
+ >=sys-fs/sysfsutils-1.3.0
+ crypt? ( >=sys-fs/cryptsetup-1.0.5 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40"
+
+# FIXME: Testsuite fails.
+RESTRICT="test"
+
+PATCHES=("${FILESDIR}/${P}-ext4-support.patch")
+
+pkg_setup() {
+ enewgroup plugdev
+}
+
+src_configure() {
+ econf $(use_enable hal)
+}
+
+src_install () {
+ # Must be run SETUID+SETGID, bug #250106
+ exeinto /usr/bin
+ exeopts -m 6710 -g plugdev
+ doexe src/pmount src/pumount src/pmount-hal || die "doexe failed"
+
+ dodoc AUTHORS ChangeLog TODO || die "dodoc failed"
+ doman man/pmount.1 man/pumount.1 man/pmount-hal.1 || die "doman failed"
+
+ insinto /etc
+ doins etc/pmount.allow || die "doins failed"
+}
+
+pkg_postinst() {
+ elog
+ elog "This package has been installed setuid and setgid."
+
+ elog "The permissions are as such that only users that belong to the plugdev"
+ elog "group are allowed to run this. But if a script run by root mounts a"
+ elog "device, members of the plugdev group will have access to it."
+ elog
+ elog "Please add your user to the plugdev group to be able to mount USB drives"
+}