summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2014-01-08 13:55:02 +0000
committerChristian Birchinger <joker@gentoo.org>2014-01-08 13:55:02 +0000
commitc04641c8b83f2b60065892822061ce94397dfef0 (patch)
treec0eb37546697df7e7340fc9717e4b893d5c8a445 /sys-apps/razercfg
parentAdd 0.3.1 release, improve python-related code. Thanks to 0xd34df00d. (diff)
downloadgentoo-2-c04641c8b83f2b60065892822061ce94397dfef0.tar.gz
gentoo-2-c04641c8b83f2b60065892822061ce94397dfef0.tar.bz2
gentoo-2-c04641c8b83f2b60065892822061ce94397dfef0.zip
Force Python 2.x because the included scripts don't support Python 3.x
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x0151863A67652900!)
Diffstat (limited to 'sys-apps/razercfg')
-rw-r--r--sys-apps/razercfg/ChangeLog8
-rw-r--r--sys-apps/razercfg/razercfg-0.22-r1.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/sys-apps/razercfg/ChangeLog b/sys-apps/razercfg/ChangeLog
index 3c11560937f4..566ecbeaa01f 100644
--- a/sys-apps/razercfg/ChangeLog
+++ b/sys-apps/razercfg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/razercfg
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/razercfg/ChangeLog,v 1.18 2014/01/03 19:14:35 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/razercfg/ChangeLog,v 1.19 2014/01/08 13:55:02 joker Exp $
+
+*razercfg-0.22-r1 (08 Jan 2014)
+
+ 08 Jan 2014; Christian Birchinger <joker@gentoo.org>
+ +razercfg-0.22-r1.ebuild:
+ Force Python 2.x because the included scripts don't support Python 3.x
*razercfg-0.22 (03 Jan 2014)
diff --git a/sys-apps/razercfg/razercfg-0.22-r1.ebuild b/sys-apps/razercfg/razercfg-0.22-r1.ebuild
new file mode 100644
index 000000000000..36e6d2fec870
--- /dev/null
+++ b/sys-apps/razercfg/razercfg-0.22-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/razercfg/razercfg-0.22-r1.ebuild,v 1.1 2014/01/08 13:55:02 joker Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit cmake-utils multilib eutils udev python-single-r1
+
+DESCRIPTION="Utility for advanced configuration of Razer mice (DeathAdder, Krait, Lachesis)"
+
+HOMEPAGE="http://bues.ch/cms/hacking/razercfg.html"
+SRC_URI="http://bues.ch/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+pm-utils qt4"
+
+RDEPEND="${DEPEND}
+ pm-utils? ( sys-power/pm-utils )
+ qt4? ( dev-python/PyQt4 )"
+
+DEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e '/ldconfig/{N;d}' \
+ -e '/udevadm control/{N;d}' \
+ -e "s:/etc/udev/rules.d/:$(get_udevdir)/rules.d/:" \
+ -e 's:01-razer-udev.rules:40-razercfg.rules:' \
+ -e "s:/etc/pm/sleep.d:/usr/$(get_libdir)/pm-utils/sleep.d/:" \
+ -e 's:50-razer:80razer:' \
+ librazer/CMakeLists.txt \
+ || die "sed failed"
+}
+
+src_install() {
+ cmake-utils_src_install
+ newinitd "${FILESDIR}"/razerd.init.d-r1 razerd
+ dodoc README razer.conf
+
+ if ! use qt4; then
+ rm "${D}"/usr/bin/qrazercfg
+ else
+ make_desktop_entry qrazercfg "Razer Mouse Settings" mouse "Qt;Settings"
+ fi
+
+ use pm-utils || rm "${D}"/usr/$(get_libdir)/pm-utils/sleep.d/80razer
+
+ python_fix_shebang "${ED}"usr/bin
+}
+
+pkg_postinst() {
+ udevadm control --reload-rules && udevadm trigger --subsystem-match=usb
+}