summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-18 10:31:26 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-18 10:31:26 +0000
commit9b1204f82eb277413026647fcd559a27e786bd1c (patch)
treec1c3e167ab05d570ef85cd0a84f680a511b0b055 /sys-apps/sed
parentAdd ~alpha to keywords. (Manifest recommit) (diff)
downloadgentoo-2-9b1204f82eb277413026647fcd559a27e786bd1c.tar.gz
gentoo-2-9b1204f82eb277413026647fcd559a27e786bd1c.tar.bz2
gentoo-2-9b1204f82eb277413026647fcd559a27e786bd1c.zip
tidy the macos stuff
Diffstat (limited to 'sys-apps/sed')
-rw-r--r--sys-apps/sed/ChangeLog5
-rw-r--r--sys-apps/sed/sed-4.0.9.ebuild29
2 files changed, 24 insertions, 10 deletions
diff --git a/sys-apps/sed/ChangeLog b/sys-apps/sed/ChangeLog
index 3951b32307e5..381482e06b70 100644
--- a/sys-apps/sed/ChangeLog
+++ b/sys-apps/sed/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/sed
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/ChangeLog,v 1.56 2004/09/16 13:48:16 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/ChangeLog,v 1.57 2004/09/18 10:31:26 mr_bones_ Exp $
+
+ 18 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org> sed-4.0.9.ebuild:
+ tidy the macos stuff
16 Sep 2004; Mamoru KOMACHI <usata@gentoo.org> sed-4.0.9.ebuild:
Fixed use invocation; bug #64260.
diff --git a/sys-apps/sed/sed-4.0.9.ebuild b/sys-apps/sed/sed-4.0.9.ebuild
index 8623b4382540..e45c18196eeb 100644
--- a/sys-apps/sed/sed-4.0.9.ebuild
+++ b/sys-apps/sed/sed-4.0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.0.9.ebuild,v 1.19 2004/09/16 13:48:16 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.0.9.ebuild,v 1.20 2004/09/18 10:31:26 mr_bones_ Exp $
inherit gnuconfig
@@ -21,9 +21,10 @@ src_compile() {
# Needed for mips and probably others
gnuconfig_update
- use macos && EXTRA_ECONF="--program-prefix=g"
- use ppc-macos && EXTRA_ECONF="--program-prefix=g"
- econf `use_enable nls` || die "Configure failed"
+ if use macos || use ppc-macos ; then
+ EXTRA_ECONF="--program-prefix=g"
+ fi
+ econf $(use_enable nls) || die "Configure failed"
if use static ; then
emake LDFLAGS=-static || die "Static build failed"
else
@@ -32,19 +33,29 @@ src_compile() {
}
src_install() {
+ local x
+
into /
dobin sed/sed
if ! use build
then
einstall || die "Install failed"
- dodoc COPYING NEWS README* THANKS AUTHORS BUGS ChangeLog
+ dodoc NEWS README* THANKS AUTHORS BUGS ChangeLog
docinto examples
- dodoc ${FILESDIR}/dos2unix ${FILESDIR}/unix2dos
+ dodoc "${FILESDIR}/dos2unix" "${FILESDIR}/unix2dos"
else
dodir /usr/bin
fi
- rm -f ${D}/usr/bin/sed
- ( use macos || use ppc-macos ) && cd ${D} && for x in `find . -name 'sed*' -print`; do mv "$x" "${x//sed/gsed}"; done && cd ${WORKDIR}/${P}
- ( use macos || use ppc-macos ) && dosym ../../bin/gsed /usr/bin/gsed || dosym ../../bin/sed /usr/bin/sed
+ rm -f "${D}/usr/bin/sed"
+ if use macos || use ppc-macos ; then
+ cd "${D}"
+ for x in $(find . -name 'sed*' -print);
+ do
+ mv "$x" "${x//sed/gsed}"
+ done
+ dosym ../../bin/gsed /usr/bin/gsed
+ else
+ dosym ../../bin/sed /usr/bin/sed
+ fi
}