summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-12-25 02:55:35 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-12-25 02:55:35 +0000
commit26e44e3373ca668f332663e0f7f6cb0e361f99be (patch)
tree37c7856bb10559784b33c0b5ba930a51a702a24f /sys-apps/shadow
parentfix segfault in kfontinst when using fontconfig enabled Xft (diff)
downloadgentoo-2-26e44e3373ca668f332663e0f7f6cb0e361f99be.tar.gz
gentoo-2-26e44e3373ca668f332663e0f7f6cb0e361f99be.tar.bz2
gentoo-2-26e44e3373ca668f332663e0f7f6cb0e361f99be.zip
add /etc/default/useradd with default shell of /bin/bash
Diffstat (limited to 'sys-apps/shadow')
-rw-r--r--sys-apps/shadow/ChangeLog12
-rw-r--r--sys-apps/shadow/files/default/useradd7
-rw-r--r--sys-apps/shadow/files/digest-shadow-4.0.3-r31
-rw-r--r--sys-apps/shadow/shadow-4.0.3-r3.ebuild168
4 files changed, 186 insertions, 2 deletions
diff --git a/sys-apps/shadow/ChangeLog b/sys-apps/shadow/ChangeLog
index 7035cf6d531a..c5b8d7ab0400 100644
--- a/sys-apps/shadow/ChangeLog
+++ b/sys-apps/shadow/ChangeLog
@@ -1,8 +1,16 @@
# ChangeLog for sys-apps/shadow
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/ChangeLog,v 1.21 2002/12/13 11:00:33 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/ChangeLog,v 1.22 2002/12/25 02:55:35 azarah Exp $
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+*shadow-4.0.3-r3 (25 Dec 2002)
+
+ 25 Dec 2002; Martin Schlemmer <azarah@gentoo.org> shadow-4.0.3-r3.ebuild :
+
+ Added /etc/default/useradd with default shell of /bin/bash, closing bug #5629.
+
+ 06 Dec 2002; Rodney Rees <manson@gentoo.org> :
+
+ Changed sparc ~sparc keywords.
03 Dec 2002; Martin Schlemmer <azarah@gentoo.org> shadow-4.0.3-r2.ebuild :
diff --git a/sys-apps/shadow/files/default/useradd b/sys-apps/shadow/files/default/useradd
new file mode 100644
index 000000000000..ae81dbb3a02b
--- /dev/null
+++ b/sys-apps/shadow/files/default/useradd
@@ -0,0 +1,7 @@
+# useradd defaults file
+GROUP=100
+HOME=/home
+INACTIVE=-1
+EXPIRE=
+SHELL=/bin/bash
+SKEL=/etc/skel
diff --git a/sys-apps/shadow/files/digest-shadow-4.0.3-r3 b/sys-apps/shadow/files/digest-shadow-4.0.3-r3
new file mode 100644
index 000000000000..aee0733f80f7
--- /dev/null
+++ b/sys-apps/shadow/files/digest-shadow-4.0.3-r3
@@ -0,0 +1 @@
+MD5 873e49fcde0d665e916414722ecb0d72 shadow-4.0.3.tar.gz 1055089
diff --git a/sys-apps/shadow/shadow-4.0.3-r3.ebuild b/sys-apps/shadow/shadow-4.0.3-r3.ebuild
new file mode 100644
index 000000000000..bc21d633dd9e
--- /dev/null
+++ b/sys-apps/shadow/shadow-4.0.3-r3.ebuild
@@ -0,0 +1,168 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.0.3-r3.ebuild,v 1.1 2002/12/25 02:55:35 azarah Exp $
+
+IUSE=""
+
+inherit libtool
+
+FORCE_SYSTEMAUTH_UPDATE="no"
+
+S="${WORKDIR}/${P}"
+HOMEPAGE="http://shadow.pld.org.pl/"
+DESCRIPTION="Utilities to deal with user accounts"
+SRC_URI="ftp://ftp.pld.org.pl/software/shadow/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86 ppc sparc alpha"
+
+DEPEND=">=sys-libs/pam-0.75-r4
+ >=sys-libs/cracklib-2.7-r3
+ sys-devel/gettext"
+
+RDEPEND=">=sys-libs/pam-0.75-r4
+ >=sys-libs/cracklib-2.7-r3"
+
+
+pkg_preinst() {
+ rm -f ${ROOT}/etc/pam.d/system-auth.new
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # Get su to call pam_open_session(), and also set DISPLAY and XAUTHORITY,
+ # else the session entries in /etc/pam.d/su never get executed, and
+ # pam_xauth for one, is then never used. This should close bug #8831.
+ #
+ # <azarah@gentoo.org> (19 Oct 2002)
+ cd ${S}; patch -p1 < ${FILESDIR}/${P}-su-pam_open_session.patch-v2 || die
+}
+
+src_compile() {
+ elibtoolize
+
+ local myconf=""
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./configure --disable-desrpc \
+ --with-libcrypt \
+ --with-libcrack \
+ --with-libpam \
+ --enable-shared=no \
+ --enable-static=yes \
+ --host=${CHOST} \
+ ${myconf} || die "bad configure"
+
+ # Parallel make fails sometimes
+ make || die "compile problem"
+}
+
+src_install() {
+ dodir /etc/default /etc/skel
+
+ make prefix=${D}/usr \
+ exec_prefix=${D} \
+ mandir=${D}/usr/share/man \
+ install || die "install problem"
+
+ # Do not install this login, but rather the one from
+ # pam-login, as this one have a serious root exploit
+ # with pam_limits in use.
+ rm ${D}/bin/login
+
+ mv ${D}/lib ${D}/usr
+ dosed "s:/lib':/usr/lib':g" /usr/lib/libshadow.la
+ dosed "s:/lib/:/usr/lib/:g" /usr/lib/libshadow.la
+ dosed "s:/lib':/usr/lib':g" /usr/lib/libmisc.la
+ dosed "s:/lib/:/usr/lib/:g" /usr/lib/libmisc.la
+ dosym /usr/bin/newgrp /usr/bin/sg
+ dosym /usr/sbin/useradd /usr/sbin/adduser
+ dosym /usr/sbin/vipw /usr/sbin/vigr
+ # Remove dead links
+ rm -f ${D}/bin/{sg,vipw}
+
+ insinto /etc
+ # Using a securetty with devfs device names added
+ # (compat names kept for non-devfs compatibility)
+ insopts -m0600 ; doins ${FILESDIR}/securetty
+ insopts -m0600 ; doins ${S}/etc/login.access
+ insopts -m0644 ; doins ${S}/etc/limits
+
+ # needed for 'adduser -D'
+ insinto /etc/default
+ insopts -m0600
+ doins ${FILESDIR}/default/useradd
+
+# From sys-apps/pam-login now
+# insopts -m0644 ; doins ${FILESDIR}/login.defs
+ insinto /etc/pam.d ; insopts -m0644
+ cd ${FILESDIR}/pam.d
+ for x in *
+ do
+ [ -f ${x} ] && doins ${x}
+ done
+ newins system-auth system-auth.new
+ newins shadow chage
+ newins shadow chsh
+ newins shadow chfn
+ newins shadow useradd
+ newins shadow groupadd
+ cd ${S}
+
+ # The manpage install is beyond my comprehension, and
+ # also broken. Just do it over.
+ rm -rf ${D}/usr/share/man/*
+ for x in man/*.[0-9]
+ do
+ [ -f ${x} ] || continue
+ local dir="${D}/usr/share/man/man${x##*.}"
+ mkdir -p ${dir}
+ cp ${x} ${dir}
+ done
+
+ # Dont install the manpage, since we dont use
+ # login with shadow
+ rm -f ${D}/usr/share/man/man1/login.*
+ # We use pam, so this is not applicable.
+ rm -f ${D}/usr/share/man/man5/suauth.*
+
+ cd ${S}/doc
+ dodoc ANNOUNCE INSTALL LICENSE README WISHLIST
+ docinto txt
+ dodoc HOWTO LSM README.* *.txt
+
+ # Fix sparc serial console
+ if [ "${ARCH}" = "sparc" -o "${ARCH}" = "" ]
+ then
+ # ttyS0 and its devfsd counterpart (Sparc serial port "A")
+ dosed 's:\(vc/1\)$:tts/0\n\1:' /etc/securetty
+ dosed 's:\(tty1\)$:ttyS0\n\1:' /etc/securetty
+ fi
+}
+
+pkg_postinst() {
+
+ local CHECK1="$(md5sum ${ROOT}/etc/pam.d/system-auth | cut -d ' ' -f 1)"
+ local CHECK2="$(md5sum ${ROOT}/etc/pam.d/system-auth.new | cut -d ' ' -f 1)"
+
+ if [ "${CHECK1}" != "${CHECK2}" -a "${FORCE_SYSTEMAUTH_UPDATE}" = "yes" ]
+ then
+ ewarn "Due to a security issue, ${ROOT}etc/pam.d/system-auth "
+ ewarn "is being updated automatically. Your old "
+ ewarn "system-auth will be backed up as:"
+ ewarn
+ ewarn " ${ROOT}etc/pam.d/system-auth.bak"
+ echo
+
+ cp -a ${ROOT}/etc/pam.d/system-auth \
+ ${ROOT}/etc/pam.d/system-auth.bak;
+ mv -f ${ROOT}/etc/pam.d/system-auth.new \
+ ${ROOT}/etc/pam.d/system-auth
+ rm -f ${ROOT}/etc/pam.d/._cfg????_system-auth
+ else
+ rm -f ${ROOT}/etc/pam.d/system-auth.new
+ fi
+}
+