summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-18 02:39:33 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-18 02:39:33 +0000
commitf9dff1d7332579982440339e4c506e170d7a1875 (patch)
treecbbd486e48d616bdd0309e7776393cec4e695a4a /sys-apps/sharutils
parentclarify postinst message; close #1153. (diff)
downloadgentoo-2-f9dff1d7332579982440339e4c506e170d7a1875.tar.gz
gentoo-2-f9dff1d7332579982440339e4c506e170d7a1875.tar.bz2
gentoo-2-f9dff1d7332579982440339e4c506e170d7a1875.zip
Added USE dependent nls compilation
Diffstat (limited to 'sys-apps/sharutils')
-rw-r--r--sys-apps/sharutils/ChangeLog8
-rw-r--r--sys-apps/sharutils/files/sharutils-4.2.1-r5-gentoo.diff43
-rw-r--r--sys-apps/sharutils/sharutils-4.2.1-r5.ebuild55
3 files changed, 105 insertions, 1 deletions
diff --git a/sys-apps/sharutils/ChangeLog b/sys-apps/sharutils/ChangeLog
index cccb62ed4036..c45a19413c10 100644
--- a/sys-apps/sharutils/ChangeLog
+++ b/sys-apps/sharutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/sharutils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sharutils/ChangeLog,v 1.1 2002/02/01 21:53:37 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sharutils/ChangeLog,v 1.2 2002/03/18 02:39:33 seemant Exp $
+
+*sharutils-4.2.1-r5 (17 Mar 2002)
+
+ 17 Mar 2002; Seemant Kulleen <seemant@gentoo.org> sharutils-4.2.1-r5 :
+
+ Added USE dependent nls compilation.
*sharutils-4.2.1-r4 (1 Feb 2002)
diff --git a/sys-apps/sharutils/files/sharutils-4.2.1-r5-gentoo.diff b/sys-apps/sharutils/files/sharutils-4.2.1-r5-gentoo.diff
new file mode 100644
index 000000000000..8b504f587015
--- /dev/null
+++ b/sys-apps/sharutils/files/sharutils-4.2.1-r5-gentoo.diff
@@ -0,0 +1,43 @@
+diff -r -C2 sharutils-4.2.1.orig/doc/remsync.texi sharutils-4.2.1/doc/remsync.texi
+*** sharutils-4.2.1.orig/doc/remsync.texi Thu Nov 30 18:15:37 1995
+--- sharutils-4.2.1/doc/remsync.texi Fri Aug 3 18:57:02 2001
+***************
+*** 8,11 ****
+--- 8,15 ----
+
+ @ifinfo
++
++ @direntry
++ * remsync: (remsync). Synchronize remote files (sharutils).
++ @end direntry
+ This file documents the @code{remsync} command and friends, which have
+ the purpose of synchronizing remote directory trees using email.
+diff -r -C2 sharutils-4.2.1.orig/doc/sharutils.texi sharutils-4.2.1/doc/sharutils.texi
+*** sharutils-4.2.1.orig/doc/sharutils.texi Fri Nov 24 21:42:52 1995
+--- sharutils-4.2.1/doc/sharutils.texi Fri Aug 3 18:29:43 2001
+***************
+*** 16,31 ****
+
+ @ifinfo
+! @format
+! START-INFO-DIR-ENTRY
+ * Shar utilities: (sharutils). GNU shar utilities.
+! * mail-files: (sharutils)mail-files invocation. Send files to remote site.
+! * mailshar: (sharutils)mailshar invocation. Make and send a shell archive.
+! * remsync: (sharutils)remsync invocation. Synchronize remote files.
+! * shar: (sharutils)shar invocation. Make a shell archive.
+! * unshar: (sharutils)unshar invocation. Explode a shell archive.
+! * uudecode: (sharutils)uudecode invocation. Restore file from 7-bits.
+! * uuencode: (sharutils)uuencode invocation. Force binary file to 7-bits.
+! END-INFO-DIR-ENTRY
+! @end format
+ @end ifinfo
+
+--- 16,22 ----
+
+ @ifinfo
+! @direntry
+ * Shar utilities: (sharutils). GNU shar utilities.
+! @end direntry
+ @end ifinfo
+
diff --git a/sys-apps/sharutils/sharutils-4.2.1-r5.ebuild b/sys-apps/sharutils/sharutils-4.2.1-r5.ebuild
new file mode 100644
index 000000000000..fb78a69bbe81
--- /dev/null
+++ b/sys-apps/sharutils/sharutils-4.2.1-r5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sharutils/sharutils-4.2.1-r5.ebuild,v 1.1 2002/03/18 02:39:33 seemant Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Tools to deal with shar archives"
+SRC_URI="ftp://prep.ai.mit.edu/gnu/sharutils/${A}"
+
+DEPEND="virtual/glibc sys-apps/texinfo
+ nls? ( >=sys-devel/gettext-0.10.35 )"
+RDEPEND="virtual/glibc"
+
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+ cd ${S}/po
+ mv nl.po nl.po.orig
+ sed -e 's/aangemaakt/aangemaakt\\n/' nl.po.orig > nl.po
+ mv pt.po pt.po.orig
+ sed -e 's/de %dk/de %dk\\n/' pt.po.orig > pt.po
+
+}
+
+src_compile() {
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./configure --host=${CHOST} --prefix=/usr ${myconf} || die
+ make ${MAKEOPTS} localedir=/usr/share/locale || die
+}
+
+src_install() {
+
+ try make prefix=${D}/usr localedir=${D}/usr/share/locale infodir=${D}/usr/share/info install
+
+ doman doc/*.[15]
+ #Remove some strange locals
+ cd ${D}/usr/share/locale
+ for i in *.
+ do
+ rm -rf ${i}
+ done
+ rm -rf ${D}/usr/lib
+
+ cd ${S}
+ dodoc AUTHORS BACKLOG COPYING ChangeLog ChangeLog.OLD \
+ NEWS README README.OLD THANKS TODO
+}
+
+