summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-06-13 22:30:39 +0000
committerJeroen Roovers <jer@gentoo.org>2011-06-13 22:30:39 +0000
commit1afbe2478f7d25266770c895d6ac45fb5020dfbd (patch)
tree7f1d2816cfeeb208321226fbf915687a24256f51 /sys-apps/smartmontools
parentDepend on unzip, closing bug #371513 (diff)
downloadgentoo-2-1afbe2478f7d25266770c895d6ac45fb5020dfbd.tar.gz
gentoo-2-1afbe2478f7d25266770c895d6ac45fb5020dfbd.tar.bz2
gentoo-2-1afbe2478f7d25266770c895d6ac45fb5020dfbd.zip
Version bump by Opportunist (bug #371367).
(Portage version: 2.2.0_alpha40/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/smartmontools')
-rw-r--r--sys-apps/smartmontools/ChangeLog7
-rw-r--r--sys-apps/smartmontools/smartmontools-5.41.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/sys-apps/smartmontools/ChangeLog b/sys-apps/smartmontools/ChangeLog
index 1c87a5b5ddfa..b973d9ea02fe 100644
--- a/sys-apps/smartmontools/ChangeLog
+++ b/sys-apps/smartmontools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/smartmontools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.100 2011/02/08 18:49:05 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.101 2011/06/13 22:30:39 jer Exp $
+
+*smartmontools-5.41 (13 Jun 2011)
+
+ 13 Jun 2011; Jeroen Roovers <jer@gentoo.org> +smartmontools-5.41.ebuild:
+ Version bump by Opportunist (bug #371367).
08 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
smartmontools-5.40.ebuild:
diff --git a/sys-apps/smartmontools/smartmontools-5.41.ebuild b/sys-apps/smartmontools/smartmontools-5.41.ebuild
new file mode 100644
index 000000000000..18ebb9148305
--- /dev/null
+++ b/sys-apps/smartmontools/smartmontools-5.41.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-5.41.ebuild,v 1.1 2011/06/13 22:30:39 jer Exp $
+
+EAPI="2"
+
+inherit flag-o-matic
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="https://smartmontools.svn.sourceforge.net/svnroot/smartmontools/trunk/smartmontools"
+ ESVN_PROJECT="smartmontools"
+ inherit subversion autotools
+ SRC_URI=""
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Self-Monitoring, Analysis and Reporting Technology System (S.M.A.R.T.) monitoring tools"
+HOMEPAGE="http://smartmontools.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static minimal caps"
+
+RDEPEND="!minimal? (
+ virtual/mailx
+ caps? ( sys-libs/libcap-ng )
+ )"
+DEPEND=""
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ subversion_src_unpack
+ else
+ unpack ${A}
+ fi
+}
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ #./autogen.sh
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myconf
+ use minimal && einfo "Skipping the monitoring daemon for minimal build."
+ use static && append-ldflags -static
+
+ if ! use minimal; then
+ myconf="${myconf} $(use_with caps libcap-ng)"
+ else
+ # disable it so that we stay safe
+ myconf="${myconf} --without-libcap-ng"
+ fi
+
+ econf \
+ --with-docdir="/usr/share/doc/${PF}" \
+ --with-initscriptdir="/toss-it-away" \
+ ${myconf} \
+ || die
+}
+
+src_install() {
+ if use minimal ; then
+ dosbin smartctl || die
+ doman smartctl.8
+ else
+ emake install DESTDIR="${D}" || die
+ rm -rf "${D}"/toss-it-away
+ newinitd "${FILESDIR}"/smartd.rc smartd
+ newconfd "${FILESDIR}"/smartd.confd smartd
+ fi
+}