summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-17 06:12:50 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-17 06:12:50 +0000
commit279466100623a50079c5b1d11db777999a8ee35b (patch)
treec618103436ade42d247ad4ed22a4ed27ceb667f8 /sys-apps/smartmontools
parentold (diff)
downloadgentoo-2-279466100623a50079c5b1d11db777999a8ee35b.tar.gz
gentoo-2-279466100623a50079c5b1d11db777999a8ee35b.tar.bz2
gentoo-2-279466100623a50079c5b1d11db777999a8ee35b.zip
Fix separator usage in UTF8 output #139409 by Samuli Suominen.
(Portage version: 2.1.1_pre2-r8)
Diffstat (limited to 'sys-apps/smartmontools')
-rw-r--r--sys-apps/smartmontools/ChangeLog8
-rw-r--r--sys-apps/smartmontools/files/digest-smartmontools-5.36-r13
-rw-r--r--sys-apps/smartmontools/files/smartmontools-5.36-utf8.patch34
-rw-r--r--sys-apps/smartmontools/smartmontools-5.36-r1.ebuild45
4 files changed, 89 insertions, 1 deletions
diff --git a/sys-apps/smartmontools/ChangeLog b/sys-apps/smartmontools/ChangeLog
index 32f88b77edd0..77d15351948f 100644
--- a/sys-apps/smartmontools/ChangeLog
+++ b/sys-apps/smartmontools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/smartmontools
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.54 2006/07/15 05:03:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.55 2006/07/17 06:12:50 vapier Exp $
+
+*smartmontools-5.36-r1 (17 Jul 2006)
+
+ 17 Jul 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/smartmontools-5.36-utf8.patch, +smartmontools-5.36-r1.ebuild:
+ Fix separator usage in UTF8 output #139409 by Samuli Suominen.
15 Jul 2006; Mike Frysinger <vapier@gentoo.org> smartmontools-5.36.ebuild:
Add mailx to RDEPEND #140192 by Jacek Sieka.
diff --git a/sys-apps/smartmontools/files/digest-smartmontools-5.36-r1 b/sys-apps/smartmontools/files/digest-smartmontools-5.36-r1
new file mode 100644
index 000000000000..f7a69c6327af
--- /dev/null
+++ b/sys-apps/smartmontools/files/digest-smartmontools-5.36-r1
@@ -0,0 +1,3 @@
+MD5 2e424f2d35efa38a29ebca419c1dbe3c smartmontools-5.36.tar.gz 540786
+RMD160 38efdc3b8dd78ded3f09890683c84973ccc036e7 smartmontools-5.36.tar.gz 540786
+SHA256 f2032adf22f8d17aad7f3dbed0a9361c25e273d3ca6abb996c84159afd624bf4 smartmontools-5.36.tar.gz 540786
diff --git a/sys-apps/smartmontools/files/smartmontools-5.36-utf8.patch b/sys-apps/smartmontools/files/smartmontools-5.36-utf8.patch
new file mode 100644
index 000000000000..a6bf3617c8c6
--- /dev/null
+++ b/sys-apps/smartmontools/files/smartmontools-5.36-utf8.patch
@@ -0,0 +1,34 @@
+Fix separator usage in UTF8 output
+
+http://bugs.gentoo.org/139409
+http://sourceforge.net/mailarchive/forum.php?thread_id=14805424&forum_id=12495
+
+--- smartmontools-5.36/ataprint.c
++++ smartmontools-5.36/ataprint.c
+@@ -445,7 +445,7 @@
+ unsigned short lba_64 = drive->words088_255[103-88];
+ uint64_t capacity_short=0, capacity=0, threedigits, power_of_ten;
+ int started=0,k=1000000000;
+- char separator=',';
++ char *separator=",";
+
+ // get correct character to use as thousands separator
+ #ifdef HAVE_LOCALE_H
+@@ -453,7 +453,7 @@
+ setlocale (LC_ALL, "");
+ currentlocale=localeconv();
+ if (*(currentlocale->thousands_sep))
+- separator=*(currentlocale->thousands_sep);
++ separator=currentlocale->thousands_sep;
+ #endif // #ifdef HAVE_LOCALE_H
+
+ // if drive supports LBA addressing, determine 32-bit LBA capacity
+@@ -485,7 +485,7 @@
+ capacity -= threedigits*power_of_ten;
+ if (started)
+ // we have already printed some digits
+- pstring += sprintf(pstring, "%c%03"PRIu64, separator, threedigits);
++ pstring += sprintf(pstring, "%s%03"PRIu64, separator, threedigits);
+ else if (threedigits || k==6) {
+ // these are the first digits that we are printing
+ pstring += sprintf(pstring, "%"PRIu64, threedigits);
diff --git a/sys-apps/smartmontools/smartmontools-5.36-r1.ebuild b/sys-apps/smartmontools/smartmontools-5.36-r1.ebuild
new file mode 100644
index 000000000000..8643b233be8e
--- /dev/null
+++ b/sys-apps/smartmontools/smartmontools-5.36-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-5.36-r1.ebuild,v 1.1 2006/07/17 06:12:50 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="control and monitor storage systems using the Self-Monitoring, Analysis and Reporting Technology System (S.M.A.R.T.)"
+HOMEPAGE="http://smartmontools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc-macos ~sparc ~x86"
+IUSE="static"
+
+RDEPEND="virtual/mailx"
+DEPEND=">=sys-apps/portage-2.0.51"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-utf8.patch
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ econf || die
+ emake || die
+}
+
+src_install() {
+ dosbin smart{ctl,d} || die "dosbin"
+ doman *.[58]
+ dodoc AUTHORS CHANGELOG NEWS README TODO WARNINGS
+ newdoc smartd.conf smartd.conf.example
+ docinto examplescripts
+ dodoc examplescripts/*
+ rm -f "${D}"/usr/share/doc/${PF}/examplescripts/Makefile*
+
+ insinto /etc
+ doins smartd.conf
+
+ newinitd "${FILESDIR}"/smartd.rc smartd
+ newconfd "${FILESDIR}"/smartd.confd smartd
+}