summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-03-06 23:00:19 +0000
committerMike Frysinger <vapier@gentoo.org>2010-03-06 23:00:19 +0000
commita13707f9a51568cf5a0f2d02baba22aec183203a (patch)
treec3545b292c63319e1fb78d8ed058567e0cbb35d8 /sys-apps/smartmontools
parentold (diff)
downloadgentoo-2-a13707f9a51568cf5a0f2d02baba22aec183203a.tar.gz
gentoo-2-a13707f9a51568cf5a0f2d02baba22aec183203a.tar.bz2
gentoo-2-a13707f9a51568cf5a0f2d02baba22aec183203a.zip
Version bump #305405 by Walther which also fixes #299962 by Dennis Schridde.
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/smartmontools')
-rw-r--r--sys-apps/smartmontools/ChangeLog9
-rw-r--r--sys-apps/smartmontools/smartmontools-5.39.1.ebuild62
2 files changed, 70 insertions, 1 deletions
diff --git a/sys-apps/smartmontools/ChangeLog b/sys-apps/smartmontools/ChangeLog
index 145d415000f9..ab4499988b18 100644
--- a/sys-apps/smartmontools/ChangeLog
+++ b/sys-apps/smartmontools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/smartmontools
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.85 2010/01/05 03:44:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.86 2010/03/06 23:00:19 vapier Exp $
+
+*smartmontools-5.39.1 (06 Mar 2010)
+
+ 06 Mar 2010; Mike Frysinger <vapier@gentoo.org>
+ +smartmontools-5.39.1.ebuild:
+ Version bump #305405 by Walther which also fixes #299962 by Dennis
+ Schridde.
*smartmontools-5.39 (05 Jan 2010)
diff --git a/sys-apps/smartmontools/smartmontools-5.39.1.ebuild b/sys-apps/smartmontools/smartmontools-5.39.1.ebuild
new file mode 100644
index 000000000000..4afd67330f18
--- /dev/null
+++ b/sys-apps/smartmontools/smartmontools-5.39.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-5.39.1.ebuild,v 1.1 2010/03/06 23:00:19 vapier Exp $
+
+EAPI="2"
+
+inherit flag-o-matic
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="https://smartmontools.svn.sourceforge.net/svnroot/smartmontools/trunk/smartmontools"
+ ESVN_PROJECT="smartmontools"
+ inherit subversion autotools
+ SRC_URI=""
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="control and monitor storage systems using the Self-Monitoring, Analysis and Reporting Technology System (S.M.A.R.T.)"
+HOMEPAGE="http://smartmontools.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static minimal"
+
+RDEPEND="!minimal? ( virtual/mailx )"
+DEPEND=""
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ subversion_src_unpack
+ else
+ unpack ${A}
+ fi
+}
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ #./autogen.sh
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ use minimal && einfo "Skipping the monitoring daemon for minimal build."
+ use static && append-ldflags -static
+ econf \
+ --with-docdir="/usr/share/doc/${PF}" \
+ --with-initscriptdir="/toss-it-away" \
+ || die
+}
+
+src_install() {
+ if use minimal ; then
+ dosbin smartctl || die
+ doman smartctl.8
+ else
+ emake install DESTDIR="${D}" || die
+ rm -rf "${D}"/toss-it-away
+ newinitd "${FILESDIR}"/smartd.rc smartd
+ newconfd "${FILESDIR}"/smartd.confd smartd
+ fi
+}