summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2006-09-19 02:00:32 +0000
committerJason Wever <weeve@gentoo.org>2006-09-19 02:00:32 +0000
commit10a644d6f3adfe8b7ae4a461470386e9eed8b3a4 (patch)
tree3ca221a71c893ae5dd77f0343578b0ae8bdf4373 /sys-apps/sparc-utils
parenttcltk -> tk USE flag change as per bug #17808 (diff)
downloadgentoo-2-10a644d6f3adfe8b7ae4a461470386e9eed8b3a4.tar.gz
gentoo-2-10a644d6f3adfe8b7ae4a461470386e9eed8b3a4.tar.bz2
gentoo-2-10a644d6f3adfe8b7ae4a461470386e9eed8b3a4.zip
Adjust ebuild so that audioctl does not install when >=sys-kernel/linux-headers-2.6.0 are present.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'sys-apps/sparc-utils')
-rw-r--r--sys-apps/sparc-utils/ChangeLog6
-rw-r--r--sys-apps/sparc-utils/files/digest-sparc-utils-1.9-r34
-rw-r--r--sys-apps/sparc-utils/sparc-utils-1.9-r3.ebuild24
3 files changed, 26 insertions, 8 deletions
diff --git a/sys-apps/sparc-utils/ChangeLog b/sys-apps/sparc-utils/ChangeLog
index bbf591413c41..44c69055ae83 100644
--- a/sys-apps/sparc-utils/ChangeLog
+++ b/sys-apps/sparc-utils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/sparc-utils
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sparc-utils/ChangeLog,v 1.21 2006/04/11 15:25:47 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sparc-utils/ChangeLog,v 1.22 2006/09/19 02:00:32 weeve Exp $
+
+ 19 Sep 2006; Jason Wever <weeve@gentoo.org> sparc-utils-1.9-r3.ebuild:
+ Adjust ebuild so that audioctl does not install when
+ >=sys-kernel/linux-headers-2.6.0 are present.
*sparc-utils-1.9-r3 (11 Apr 2006)
diff --git a/sys-apps/sparc-utils/files/digest-sparc-utils-1.9-r3 b/sys-apps/sparc-utils/files/digest-sparc-utils-1.9-r3
index 2eb7f575c7f0..03d2c54b6bb3 100644
--- a/sys-apps/sparc-utils/files/digest-sparc-utils-1.9-r3
+++ b/sys-apps/sparc-utils/files/digest-sparc-utils-1.9-r3
@@ -1,2 +1,6 @@
MD5 50bd3e4749473b3effdb00981220f09f sparc-utils_1.9-2.diff.bz2 7992
+RMD160 5d6ed8c107897f2fa71613f7c3dd73c28f966193 sparc-utils_1.9-2.diff.bz2 7992
+SHA256 8124c0ac7d5269ecc4469b6cb0918e5f1797326025ab407822ce536af9f65829 sparc-utils_1.9-2.diff.bz2 7992
MD5 08bf3f6d8433a1f4981a2afaa6b49a6c sparc-utils_1.9.orig.tar.gz 110080
+RMD160 9827d9ff7cb4f06d4fb3709593e341e6a3b71a2e sparc-utils_1.9.orig.tar.gz 110080
+SHA256 b652bc27f95dcf10a7626b1d2943a1084e1e0b7f9bd3a97f9a46b6688370fe4b sparc-utils_1.9.orig.tar.gz 110080
diff --git a/sys-apps/sparc-utils/sparc-utils-1.9-r3.ebuild b/sys-apps/sparc-utils/sparc-utils-1.9-r3.ebuild
index 5b3c7d2bc950..bb65e81bbaf1 100644
--- a/sys-apps/sparc-utils/sparc-utils-1.9-r3.ebuild
+++ b/sys-apps/sparc-utils/sparc-utils-1.9-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sparc-utils/sparc-utils-1.9-r3.ebuild,v 1.2 2006/04/11 23:23:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sparc-utils/sparc-utils-1.9-r3.ebuild,v 1.3 2006/09/19 02:00:32 weeve Exp $
inherit eutils toolchain-funcs
@@ -19,6 +19,14 @@ RDEPEND="sys-apps/setarch"
S=${WORKDIR}/${P}.orig
+# NOTE: If a system has >=sys-kernel/linux-headers-2.6.0, don't build audioctl
+# as the SPARC sound drivers have been replaced by their ALSA equivalents
+
+pkg_setup() {
+ has_version '>=sys-kernel/linux-headers-2.6.0' && \
+ einfo "Linux 2.6 kernel headers detected, not building audioctl"
+}
+
src_unpack() {
unpack ${A}
epatch ${WORKDIR}/${PN}_${PV}-2.diff
@@ -28,7 +36,8 @@ src_compile() {
emake -C elftoaout-2.3 CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die
emake -C src piggyback piggyback64 CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die
emake -C prtconf-1.3 CC="$(tc-getCC)" all || die
- emake -C audioctl-1.3 CC="$(tc-getCC)" || die
+ has_version '>=sys-kernel/linux-headers-2.6.0' || \
+ emake -C audioctl-1.3 CC="$(tc-getCC)" || die
}
src_install() {
@@ -44,12 +53,13 @@ src_install() {
dosbin prtconf-1.3/prtconf || die
dosbin prtconf-1.3/eeprom || die
- dobin audioctl-1.3/audioctl || die
-
- newinitd "${FILESDIR}"/audioctl.init audioctl || die
- newconfd debian/audioctl.def audioctl || die
+ if ! has_version '>=sys-kernel/linux-headers-2.6.0'; then
+ dobin audioctl-1.3/audioctl || die
+ newinitd "${FILESDIR}"/audioctl.init audioctl || die
+ newconfd debian/audioctl.def audioctl || die
+ doman audioctl-1.3/audioctl.1
+ fi
- doman audioctl-1.3/audioctl.1
doman elftoaout-2.3/elftoaout.1
doman prtconf-1.3/prtconf.8
doman prtconf-1.3/eeprom.8