summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-19 03:21:25 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-19 03:21:25 +0000
commit1677350f96f4266a6979abe93bd38bcb42853488 (patch)
tree4f1a43f67e5deb531cbde46d4ba801a715be7e72 /sys-apps/star
parentlintool fixes for #9258 (diff)
downloadgentoo-2-1677350f96f4266a6979abe93bd38bcb42853488.tar.gz
gentoo-2-1677350f96f4266a6979abe93bd38bcb42853488.tar.bz2
gentoo-2-1677350f96f4266a6979abe93bd38bcb42853488.zip
lintool fixes for #9258
Diffstat (limited to 'sys-apps/star')
-rw-r--r--sys-apps/star/star-1.3_alpha8-r2.ebuild13
-rw-r--r--sys-apps/star/star-1.4_alpha15.ebuild7
2 files changed, 10 insertions, 10 deletions
diff --git a/sys-apps/star/star-1.3_alpha8-r2.ebuild b/sys-apps/star/star-1.3_alpha8-r2.ebuild
index 73d03e1a72fd..3c947303897e 100644
--- a/sys-apps/star/star-1.3_alpha8-r2.ebuild
+++ b/sys-apps/star/star-1.3_alpha8-r2.ebuild
@@ -1,17 +1,18 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/star/star-1.3_alpha8-r2.ebuild,v 1.7 2002/10/04 06:30:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/star/star-1.3_alpha8-r2.ebuild,v 1.8 2002/10/19 03:21:24 vapier Exp $
-A=star-1.3a8.tar.gz
+MY_P="${P}a8"
S=${WORKDIR}/star-1.3
DESCRIPTION="An enhanced (world's fastest) tar, as well as enhanced mt/rmt"
-SRC_URI="ftp://ftp.fokus.gmd.de/pub/unix/star/alpha/${A}"
+SRC_URI="ftp://ftp.fokus.gmd.de/pub/unix/star/alpha/${P}.tar.gz"
HOMEPAGE="http://www.fokus.gmd.de/research/cc/glone/employees/joerg.schilling/private/star.html"
KEYWORDS="x86"
SLOT="0"
LICENSE="GPL-2"
DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
@@ -21,11 +22,11 @@ src_unpack() {
}
src_compile() {
- try make COPTX="${CFLAGS}"
+ make COPTX="${CFLAGS}" || die
}
src_install() {
- try make install INS_BASE=${D}/usr
+ make install INS_BASE=${D}/usr || die
insinto /etc/default
newins ${S}/rmt/rmt.dfl rmt
#the mt in app-arch/mt-st is better
@@ -41,5 +42,3 @@ src_install() {
dosym rmt.star /usr/sbin/rmt
dosym rmt.1.gz /usr/share/man/man1/rmt.star.1.gz
}
-
-
diff --git a/sys-apps/star/star-1.4_alpha15.ebuild b/sys-apps/star/star-1.4_alpha15.ebuild
index 6a4c846471d3..9059ae06afc8 100644
--- a/sys-apps/star/star-1.4_alpha15.ebuild
+++ b/sys-apps/star/star-1.4_alpha15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/star/star-1.4_alpha15.ebuild,v 1.6 2002/10/04 06:30:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/star/star-1.4_alpha15.ebuild,v 1.7 2002/10/19 03:21:24 vapier Exp $
S=${WORKDIR}/star-1.4
@@ -11,6 +11,7 @@ KEYWORDS="x86"
SLOT="0"
LICENSE="GPL-2"
DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
@@ -20,11 +21,11 @@ src_unpack() {
}
src_compile() {
- try make COPTX="${CFLAGS}"
+ make COPTX="${CFLAGS}" || die
}
src_install() {
- try make install INS_BASE=${D}/usr
+ make install INS_BASE=${D}/usr || die
insinto /etc/default
newins ${S}/rmt/rmt.dfl rmt
#the mt in app-arch/mt-st is better