summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-03-25 19:25:25 +0000
committerMichał Górny <mgorny@gentoo.org>2013-03-25 19:25:25 +0000
commit355deae597a1f78ceef3dc10af15d932b5bc02dd (patch)
treeecf3561511b20bb20409a2a9b979d409a6b4a0ff /sys-apps/systemd-ui
parentInitial version, ebuild by me (diff)
downloadgentoo-2-355deae597a1f78ceef3dc10af15d932b5bc02dd.tar.gz
gentoo-2-355deae597a1f78ceef3dc10af15d932b5bc02dd.tar.bz2
gentoo-2-355deae597a1f78ceef3dc10af15d932b5bc02dd.zip
Version bump.
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'sys-apps/systemd-ui')
-rw-r--r--sys-apps/systemd-ui/ChangeLog9
-rw-r--r--sys-apps/systemd-ui/systemd-ui-2.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/sys-apps/systemd-ui/ChangeLog b/sys-apps/systemd-ui/ChangeLog
index 12d87fe0a085..c6a74202bf5b 100644
--- a/sys-apps/systemd-ui/ChangeLog
+++ b/sys-apps/systemd-ui/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/systemd-ui
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd-ui/ChangeLog,v 1.2 2012/12/15 13:06:20 mgorny Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd-ui/ChangeLog,v 1.3 2013/03/25 19:25:25 mgorny Exp $
+
+*systemd-ui-2 (25 Mar 2013)
+
+ 25 Mar 2013; Michał Górny <mgorny@gentoo.org> +systemd-ui-2.ebuild:
+ Version bump.
*systemd-ui-9999 (15 Dec 2012)
diff --git a/sys-apps/systemd-ui/systemd-ui-2.ebuild b/sys-apps/systemd-ui/systemd-ui-2.ebuild
new file mode 100644
index 000000000000..567273edeac3
--- /dev/null
+++ b/sys-apps/systemd-ui/systemd-ui-2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd-ui/systemd-ui-2.ebuild,v 1.1 2013/03/25 19:25:25 mgorny Exp $
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="System and service manager for Linux"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
+SRC_URI="http://www.freedesktop.org/software/systemd/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VALASLOT="0.14"
+
+RDEPEND="!sys-apps/systemd[gtk]
+ >=dev-libs/glib-2.26
+ dev-libs/libgee:0.8
+ sys-apps/dbus
+ x11-libs/gtk+:2
+ >=x11-libs/libnotify-0.7"
+
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ dev-lang/vala:${VALASLOT}"
+
+# Due to vala being broken.
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ # Force the rebuild of .vala sources
+ touch src/*.vala || die
+
+ # Fix hardcoded path in .vala.
+ sed -i -e 's:/lib/systemd:/usr/lib/systemd:g' src/*.vala || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ export VALAC="$(type -p valac-${VALASLOT})"
+ autotools-utils_src_configure
+}