summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-06-14 00:19:49 +0000
committerMike Gilbert <floppym@gentoo.org>2015-06-14 00:19:49 +0000
commit9639cc6e3c037652e6bb943473120fd7d00da112 (patch)
tree424896d845f62d315d042ecbdbbd7f10f143f979 /sys-apps/systemd
parentDrop old. (diff)
downloadgentoo-2-9639cc6e3c037652e6bb943473120fd7d00da112.tar.gz
gentoo-2-9639cc6e3c037652e6bb943473120fd7d00da112.tar.bz2
gentoo-2-9639cc6e3c037652e6bb943473120fd7d00da112.zip
Add missing compile-unifont.py. Update EGIT_REPO_URI to point at github.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-apps/systemd')
-rw-r--r--sys-apps/systemd/ChangeLog6
-rw-r--r--sys-apps/systemd/files/compile-unifont.py119
-rw-r--r--sys-apps/systemd/systemd-220-r2.ebuild5
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild5
4 files changed, 130 insertions, 5 deletions
diff --git a/sys-apps/systemd/ChangeLog b/sys-apps/systemd/ChangeLog
index 7b05c92dd849..fda61757edaa 100644
--- a/sys-apps/systemd/ChangeLog
+++ b/sys-apps/systemd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/systemd
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.377 2015/06/10 02:29:34 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.378 2015/06/14 00:19:49 floppym Exp $
+
+ 14 Jun 2015; Mike Gilbert <floppym@gentoo.org> +files/compile-unifont.py,
+ systemd-220-r2.ebuild, systemd-9999.ebuild:
+ Add missing compile-unifont.py. Update EGIT_REPO_URI to point at github.
10 Jun 2015; Mike Gilbert <floppym@gentoo.org> systemd-216-r3.ebuild,
systemd-218-r3.ebuild, systemd-219_p112.ebuild, systemd-220-r2.ebuild:
diff --git a/sys-apps/systemd/files/compile-unifont.py b/sys-apps/systemd/files/compile-unifont.py
new file mode 100644
index 000000000000..5464c53e7f9a
--- /dev/null
+++ b/sys-apps/systemd/files/compile-unifont.py
@@ -0,0 +1,119 @@
+# -*- Mode: python; coding: utf-8; indent-tabs-mode: nil -*- */
+#
+# This file is part of systemd.
+#
+# Copyright 2013-2014 David Herrmann <dh.herrmann@gmail.com>
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+#
+# systemd is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with systemd; If not, see <http://www.gnu.org/licenses/>.
+
+#
+# Parse a unifont.hex file and produce a compressed binary-format.
+#
+
+from __future__ import print_function
+import re
+import sys
+import fileinput
+import struct
+
+#
+# Write "bits" array as binary output.
+#
+
+
+write = getattr(sys.stdout, 'buffer', sys.stdout).write
+
+def write_bin_entry(entry):
+ l = len(entry)
+ if l != 32 and l != 64:
+ entry = "0" * 64
+ l = 0
+ elif l < 64:
+ entry += "0" * (64 - l)
+
+ write(struct.pack('B', int(l / 32))) # width
+ write(struct.pack('B', 0)) # padding
+ write(struct.pack('H', 0)) # padding
+ write(struct.pack('I', 0)) # padding
+
+ i = 0
+ for j in range(0, 16):
+ for k in range(0, 2):
+ if l <= k * 16 * 2:
+ c = 0
+ else:
+ c = int(entry[i:i+2], 16)
+ i += 2
+
+ write(struct.pack('B', c))
+
+def write_bin(bits):
+ write(struct.pack('B', 0x44)) # ASCII: 'D'
+ write(struct.pack('B', 0x56)) # ASCII: 'V'
+ write(struct.pack('B', 0x44)) # ASCII: 'D'
+ write(struct.pack('B', 0x48)) # ASCII: 'H'
+ write(struct.pack('B', 0x52)) # ASCII: 'R'
+ write(struct.pack('B', 0x4d)) # ASCII: 'M'
+ write(struct.pack('B', 0x55)) # ASCII: 'U'
+ write(struct.pack('B', 0x46)) # ASCII: 'F'
+ write(struct.pack('<I', 0)) # compatible-flags
+ write(struct.pack('<I', 0)) # incompatible-flags
+ write(struct.pack('<I', 32)) # header-size
+ write(struct.pack('<H', 8)) # glyph-header-size
+ write(struct.pack('<H', 2)) # glyph-stride
+ write(struct.pack('<Q', 32)) # glyph-body-size
+
+ # write glyphs
+ for idx in range(len(bits)):
+ write_bin_entry(bits[idx])
+
+#
+# Parse hex file into "bits" array
+#
+
+def parse_hex_line(bits, line):
+ m = re.match(r"^([0-9A-Fa-f]+):([0-9A-Fa-f]+)$", line)
+ if m == None:
+ return
+
+ idx = int(m.group(1), 16)
+ val = m.group(2)
+
+ # insert skipped lines
+ for i in range(len(bits), idx):
+ bits.append("")
+
+ bits.insert(idx, val)
+
+def parse_hex():
+ bits = []
+
+ for line in sys.stdin:
+ if not line:
+ continue
+ if line.startswith("#"):
+ continue
+
+ parse_hex_line(bits, line)
+
+ return bits
+
+#
+# In normal mode we simply read line by line from standard-input and write the
+# binary-file to standard-output.
+#
+
+if __name__ == "__main__":
+ bits = parse_hex()
+ write_bin(bits)
diff --git a/sys-apps/systemd/systemd-220-r2.ebuild b/sys-apps/systemd/systemd-220-r2.ebuild
index 171f86e02e32..d74adfa94f8c 100644
--- a/sys-apps/systemd/systemd-220-r2.ebuild
+++ b/sys-apps/systemd/systemd-220-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-220-r2.ebuild,v 1.5 2015/06/10 02:29:34 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-220-r2.ebuild,v 1.6 2015/06/14 00:19:49 floppym Exp $
EAPI=5
@@ -158,6 +158,9 @@ src_prepare() {
# http://lists.freedesktop.org/archives/systemd-devel/2015-May/032149.html
rm src/journal/audit_type-to-name.h src/udev/keyboard-keys-from-name.gperf || die
+
+ cp "${FILESDIR}"/compile-unifont.py tools/compile-unifont.py || die
+ chmod +x tools/compile-unifont.py || die
EPATCH_FORCE=yes EPATCH_SUFFIX=patch epatch
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index b59080229ee7..94f9f843e917 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-9999.ebuild,v 1.171 2015/06/10 01:40:59 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-9999.ebuild,v 1.172 2015/06/14 00:19:49 floppym Exp $
EAPI=5
@@ -9,8 +9,7 @@ PYTHON_COMPAT=( python{2_7,3_3,3_4} )
if [[ ${PV} == 9999 ]]; then
AUTOTOOLS_AUTORECONF=yes
- EGIT_REPO_URI="git://anongit.freedesktop.org/systemd/systemd
- http://cgit.freedesktop.org/systemd/systemd"
+ EGIT_REPO_URI="https://github.com/systemd/systemd.git"
inherit git-r3
else
SRC_URI="http://www.freedesktop.org/software/systemd/${P}.tar.xz"