summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2013-06-11 20:39:12 +0000
committerTony Vroon <chainsaw@gentoo.org>2013-06-11 20:39:12 +0000
commit4071c492950ced6d9e1966cf355882a83bd4d7cb (patch)
treefc8e7d1af0ff513b0c20ad83c7a163446779d0c7 /sys-apps/usbutils
parentRemove old. (diff)
downloadgentoo-2-4071c492950ced6d9e1966cf355882a83bd4d7cb.tar.gz
gentoo-2-4071c492950ced6d9e1966cf355882a83bd4d7cb.tar.bz2
gentoo-2-4071c492950ced6d9e1966cf355882a83bd4d7cb.zip
Version bump to 007, as requested by Christian Schmidt in bug #472882. Features improved descriptor decoding for audio (UAC) and communications devices (CDC), link state reporting for USB 3.0 and handling of non-ASCII strings.
(Portage version: 2.1.12.4/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'sys-apps/usbutils')
-rw-r--r--sys-apps/usbutils/ChangeLog10
-rw-r--r--sys-apps/usbutils/usbutils-007.ebuild53
2 files changed, 62 insertions, 1 deletions
diff --git a/sys-apps/usbutils/ChangeLog b/sys-apps/usbutils/ChangeLog
index 233a18b5d7f3..86d04c8adcf0 100644
--- a/sys-apps/usbutils/ChangeLog
+++ b/sys-apps/usbutils/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/usbutils
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/ChangeLog,v 1.166 2013/05/01 11:10:31 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/ChangeLog,v 1.167 2013/06/11 20:39:12 chainsaw Exp $
+
+*usbutils-007 (11 Jun 2013)
+
+ 11 Jun 2013; Tony Vroon <chainsaw@gentoo.org> +usbutils-007.ebuild:
+ Version bump to 007, as requested by Christian Schmidt in bug #472882.
+ Features improved descriptor decoding for audio (UAC) and communications
+ devices (CDC), link state reporting for USB 3.0 and handling of non-ASCII
+ strings.
01 May 2013; Agostino Sarubbo <ago@gentoo.org> usbutils-006-r1.ebuild:
Stable for sh, wrt bug #466434
diff --git a/sys-apps/usbutils/usbutils-007.ebuild b/sys-apps/usbutils/usbutils-007.ebuild
new file mode 100644
index 000000000000..03bcb713e5eb
--- /dev/null
+++ b/sys-apps/usbutils/usbutils-007.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/usbutils-007.ebuild,v 1.1 2013/06/11 20:39:12 chainsaw Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit base python-single-r1
+
+DESCRIPTION="USB enumeration utilities"
+HOMEPAGE="http://linux-usb.sourceforge.net/"
+SRC_URI="mirror://kernel/linux/utils/usb/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="python zlib"
+
+RDEPEND="virtual/libusb:1=
+ zlib? ( sys-libs/zlib:= )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ sys-apps/hwids
+ python? ( ${PYTHON_DEPS} )"
+PATCHES=( "${FILESDIR}"/${PN}-006-stdint.patch )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ base_src_prepare
+ sed -i -e '/^usbids/s:/usr/share:/usr/share/misc:' lsusb.py || die
+ use python && python_fix_shebang lsusb.py
+}
+
+src_configure() {
+ econf \
+ --datarootdir="${EPREFIX}/usr/share" \
+ --datadir="${EPREFIX}/usr/share/misc" \
+ --disable-usbids \
+ $(use_enable zlib)
+}
+
+src_install() {
+ default
+ newdoc usbhid-dump/NEWS NEWS.usbhid-dump
+
+ use python || rm -f "${ED}"/usr/bin/lsusb.py
+}