summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2008-12-18 18:29:22 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2008-12-18 18:29:22 +0000
commita5add366cfc35543e13106fa1b06a44e475c0379 (patch)
tree4aaa01ef22a97071f713d6848f426f8e09801fde /sys-apps/usermode-utilities
parentAdd eblits in the same fashion as sys-libs/glibc that contain commonly used c... (diff)
downloadgentoo-2-a5add366cfc35543e13106fa1b06a44e475c0379.tar.gz
gentoo-2-a5add366cfc35543e13106fa1b06a44e475c0379.tar.bz2
gentoo-2-a5add366cfc35543e13106fa1b06a44e475c0379.zip
Fix some build issues; bug #251390
(Portage version: 2.2_rc17/cvs/Linux 2.6.27-gentoo-r4 x86_64)
Diffstat (limited to 'sys-apps/usermode-utilities')
-rw-r--r--sys-apps/usermode-utilities/ChangeLog6
-rw-r--r--sys-apps/usermode-utilities/usermode-utilities-20070815.ebuild15
2 files changed, 13 insertions, 8 deletions
diff --git a/sys-apps/usermode-utilities/ChangeLog b/sys-apps/usermode-utilities/ChangeLog
index 4fa944f68a19..847ebdfba6c1 100644
--- a/sys-apps/usermode-utilities/ChangeLog
+++ b/sys-apps/usermode-utilities/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/usermode-utilities
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/usermode-utilities/ChangeLog,v 1.25 2008/02/14 14:20:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usermode-utilities/ChangeLog,v 1.26 2008/12/18 18:29:22 dang Exp $
+
+ 18 Dec 2008; Daniel Gryniewicz <dang@gentoo.org>
+ usermode-utilities-20070815.ebuild:
+ Fix some build issues; bug #251390
14 Feb 2008; Diego Pettenò <flameeyes@gentoo.org>
usermode-utilities-20070815.ebuild:
diff --git a/sys-apps/usermode-utilities/usermode-utilities-20070815.ebuild b/sys-apps/usermode-utilities/usermode-utilities-20070815.ebuild
index 87b2237754f8..16d5549248e1 100644
--- a/sys-apps/usermode-utilities/usermode-utilities-20070815.ebuild
+++ b/sys-apps/usermode-utilities/usermode-utilities-20070815.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/usermode-utilities/usermode-utilities-20070815.ebuild,v 1.3 2008/02/14 14:20:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usermode-utilities/usermode-utilities-20070815.ebuild,v 1.4 2008/12/18 18:29:22 dang Exp $
inherit eutils
-S=${WORKDIR}/tools-${PV}
DESCRIPTION="Tools for use with Usermode Linux virtual machines"
SRC_URI="http://user-mode-linux.sourceforge.net/uml_utilities_${PV}.tar.bz2"
HOMEPAGE="http://user-mode-linux.sourceforge.net/"
@@ -16,21 +15,23 @@ IUSE=""
DEPEND="virtual/libc"
+S="${WORKDIR}"/tools-${PV}
+
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PN}-20060216-unlazy.patch
- epatch ${FILESDIR}/${P}-nostrip.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-20060216-unlazy.patch
+ epatch "${FILESDIR}"/${P}-nostrip.patch
sed -i -e 's:-o \$(BIN):$(LDFLAGS) -o $(BIN):' "${S}"/*/Makefile || die "LDFLAGS sed failed"
sed -i -e 's:-o \$@:$(LDFLAGS) -o $@:' "${S}"/moo/Makefile || die "LDFLAGS sed (moo) failed"
}
src_compile() {
- emake CFLAGS="${CFLAGS} -DTUNTAP -D_LARGEFILE64_SOURCE -g -Wall" all
+ emake CFLAGS="${CFLAGS} -DTUNTAP -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -g -Wall" all || die "Compilation failed"
}
src_install () {
- make DESTDIR=${D} install
+ emake DESTDIR="${D}" install || die "Install phase failed"
dodoc COPYING
}