summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2005-04-15 13:03:31 +0000
committerSeemant Kulleen <seemant@gentoo.org>2005-04-15 13:03:31 +0000
commit18154ac58b187ea00035be7c71e2fa3af0dcbac6 (patch)
tree032c3d7cb668d307ac9c3a82a76c49699b5beba5 /sys-apps/utempter
parentStable on amd64. (diff)
downloadgentoo-2-18154ac58b187ea00035be7c71e2fa3af0dcbac6.tar.gz
gentoo-2-18154ac58b187ea00035be7c71e2fa3af0dcbac6.tar.bz2
gentoo-2-18154ac58b187ea00035be7c71e2fa3af0dcbac6.zip
version bump, that's allegedly compilable with gcc-4. Also, this adds a patch so that utempter can be compiled against uclibc. Patch provided by Peter S. Mazinger <ps.m@gmx.net> in bug #69470 by Daniel Black <dragonheart@gentoo.org>
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-apps/utempter')
-rw-r--r--sys-apps/utempter/ChangeLog13
-rw-r--r--sys-apps/utempter/Manifest2
-rw-r--r--sys-apps/utempter/files/digest-utempter-0.5.5.61
-rw-r--r--sys-apps/utempter/files/utempter-0.5.5.6-no_utmpx.patch38
-rw-r--r--sys-apps/utempter/files/utempter-0.5.5.6-soname-makefile-fix.patch22
-rw-r--r--sys-apps/utempter/utempter-0.5.5.6.ebuild65
6 files changed, 140 insertions, 1 deletions
diff --git a/sys-apps/utempter/ChangeLog b/sys-apps/utempter/ChangeLog
index 59fd2850453d..6a7207629099 100644
--- a/sys-apps/utempter/ChangeLog
+++ b/sys-apps/utempter/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sys-apps/utempter
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/utempter/ChangeLog,v 1.28 2005/04/15 12:41:44 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/utempter/ChangeLog,v 1.29 2005/04/15 13:03:31 seemant Exp $
+
+*utempter-0.5.5.6 (15 Apr 2005)
+
+ 15 Apr 2005; Seemant Kulleen <seemant@gentoo.org>
+ +files/utempter-0.5.5.6-no_utmpx.patch,
+ +files/utempter-0.5.5.6-soname-makefile-fix.patch,
+ +utempter-0.5.5.6.ebuild:
+ version bump, that's allegedly compilable with gcc-4. Also, this adds a
+ patch so that utempter can be compiled against uclibc. Patch provided by
+ Peter S. Mazinger <ps.m@gmx.net> in bug #69470 by Daniel Black
+ <dragonheart@gentoo.org>
15 Apr 2005; Seemant Kulleen <seemant@gentoo.org>
utempter-0.5.5.5-r1.ebuild:
diff --git a/sys-apps/utempter/Manifest b/sys-apps/utempter/Manifest
index 8de1d3be3188..d6efa3d94fe1 100644
--- a/sys-apps/utempter/Manifest
+++ b/sys-apps/utempter/Manifest
@@ -1,5 +1,7 @@
MD5 3f997cf5387935cbcdffb5f2b8e39cf6 ChangeLog 4196
MD5 ead67259560e11f3f635a49255114bf6 metadata.xml 181
MD5 11c09ecfee4dc4f688c5d235f7da3a0f utempter-0.5.5.5-r1.ebuild 1247
+MD5 11c09ecfee4dc4f688c5d235f7da3a0f utempter-0.5.5.6.ebuild 1247
MD5 d3293569252b4437ee84ef41b158aa00 files/digest-utempter-0.5.5.5-r1 68
MD5 b2dc09a11b51ceac5735f963a718fa32 files/utempter-0.5.5.5-soname-makefile-fix.patch 932
+MD5 750feafe77d6007602c6abbacdce262f files/digest-utempter-0.5.5.6 68
diff --git a/sys-apps/utempter/files/digest-utempter-0.5.5.6 b/sys-apps/utempter/files/digest-utempter-0.5.5.6
new file mode 100644
index 000000000000..859f0d2d8643
--- /dev/null
+++ b/sys-apps/utempter/files/digest-utempter-0.5.5.6
@@ -0,0 +1 @@
+MD5 d204e000147675ed4f1533f485fd2d7e utempter-0.5.5-6.src.rpm 21099
diff --git a/sys-apps/utempter/files/utempter-0.5.5.6-no_utmpx.patch b/sys-apps/utempter/files/utempter-0.5.5.6-no_utmpx.patch
new file mode 100644
index 000000000000..8644db837f4a
--- /dev/null
+++ b/sys-apps/utempter/files/utempter-0.5.5.6-no_utmpx.patch
@@ -0,0 +1,38 @@
+--- utempter-0.5.5/utempter.c.mps 2004-12-11 14:54:06.000000000 +0100
++++ utempter-0.5.5/utempter.c 2004-12-11 14:57:46.000000000 +0100
+@@ -11,7 +11,9 @@
+ #include <sys/stat.h>
+ #include <sys/sysmacros.h>
+ #include <utmp.h>
++#ifndef __UCLIBC__
+ #include <utmpx.h>
++#endif
+ #include <unistd.h>
+
+ static void usage(void) {
+@@ -82,7 +84,11 @@
+ }
+
+ int main(int argc, const char ** argv) {
++#ifndef __UCLIBC__
+ struct utmpx utx;
++#else
++ struct utmp utx;
++#endif
+ int add;
+ const char * device, * host;
+ struct passwd * pw;
+@@ -154,8 +160,13 @@
+
+ gettimeofday(&utx.ut_tv, NULL);
+
++#ifndef __UCLIBC__
+ pututxline(&utx);
+ updwtmpx(_PATH_WTMP, &utx);
++#else
++ pututline(&utx);
++ updwtmp(_PATH_WTMP, &utx);
++#endif
+
+ return 0;
+ }
diff --git a/sys-apps/utempter/files/utempter-0.5.5.6-soname-makefile-fix.patch b/sys-apps/utempter/files/utempter-0.5.5.6-soname-makefile-fix.patch
new file mode 100644
index 000000000000..123c77eb357c
--- /dev/null
+++ b/sys-apps/utempter/files/utempter-0.5.5.6-soname-makefile-fix.patch
@@ -0,0 +1,22 @@
+--- Makefile.orig 2005-04-15 08:54:32.000000000 -0400
++++ Makefile 2005-04-15 08:56:17.000000000 -0400
+@@ -5,6 +5,10 @@
+ CVSROOT=$(shell cat CVS/Root)
+ # major number of the .so lib
+ SOMAJOR = 0
++# minor number of the .so lib
++SOMINOR = 5
++# micro number of the .so lib
++SOMICRO = 5
+
+ SHAREDLIB = lib$(NAME).so
+ SONAME = $(SHAREDLIB).$(SOMAJOR)
+@@ -29,6 +33,8 @@
+ install -m 644 utempter.h $(RPM_BUILD_ROOT)/usr/include
+ install -m 644 $(SHAREDLIB) $(RPM_BUILD_ROOT)/$(LIBDIR)/$(SHAREDLIB).$(VERSION)
+ ln -sf $(SHAREDLIB).$(VERSION) $(RPM_BUILD_ROOT)/$(LIBDIR)/$(SHAREDLIB)
++ ln -sf $(SHAREDLIB).$(VERSION) $(RPM_BUILD_ROOT)/$(LIBDIR)/$(SHAREDLIB).$(SOMAJOR).$(SOMINOR)
++ ln -sf $(SHAREDLIB).$(VERSION) $(RPM_BUILD_ROOT)/$(LIBDIR)/$(SHAREDLIB).$(SOMAJOR)
+
+ $(SHAREDLIB): utmpintf.os
+ $(CC) -o $@ -shared -Wl,-soname,$(SONAME) $^ -lc
diff --git a/sys-apps/utempter/utempter-0.5.5.6.ebuild b/sys-apps/utempter/utempter-0.5.5.6.ebuild
new file mode 100644
index 000000000000..0eb23250324b
--- /dev/null
+++ b/sys-apps/utempter/utempter-0.5.5.6.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/utempter/utempter-0.5.5.6.ebuild,v 1.1 2005/04/15 13:03:31 seemant Exp $
+
+inherit rpm eutils flag-o-matic
+
+MY_P=${P%.*}-${PV##*.}
+S=${WORKDIR}/${P%.*}
+DESCRIPTION="App that allows non-privileged apps to write utmp (login) info"
+HOMEPAGE="http://www.redhat.com/"
+SRC_URI="mirror://gentoo/${MY_P}.src.rpm
+ http://dev.gentoo.org/~seemant/distfiles/${MY_P}.src.rpm"
+
+LICENSE="|| ( MIT LGPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/libc"
+
+pkg_setup() {
+ enewgroup utmp 406
+}
+
+src_unpack() {
+ rpm_src_unpack
+ cd ${S}
+ epatch ${FILESDIR}/${P}-soname-makefile-fix.patch
+ epatch ${FILESDIR}/${P}-no_utmpx.patch
+}
+
+src_compile() {
+ append-ldflags -Wl,-z,now
+
+ make RPM_OPT_FLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ make \
+ RPM_BUILD_ROOT="${D}" \
+ LIBDIR=/usr/$(get_libdir) \
+ install || die
+ dobin utmp
+
+ fowners root:utmp /usr/sbin/utempter
+ fperms 2755 /usr/sbin/utempter
+}
+
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" ]
+ then
+ if [ -f /var/log/wtmp ]
+ then
+ chown root:utmp /var/log/wtmp
+ chmod 664 /var/log/wtmp
+ fi
+
+ if [ -f /var/run/utmp ]
+ then
+ chown root:utmp /var/run/utmp
+ chmod 664 /var/run/utmp
+ fi
+ fi
+}