summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2011-11-12 20:49:10 +0000
committerLars Wendler <polynomial-c@gentoo.org>2011-11-12 20:49:10 +0000
commit928270acdcd8369017e75391dd629cb6bb62b97d (patch)
tree9ca87128a8b8502b1d04bb48fc87b65a19ae2ae2 /sys-apps/util-linux
parentRestore ${S} fallback, but with a deprecation notice saying that it will be r... (diff)
downloadgentoo-2-928270acdcd8369017e75391dd629cb6bb62b97d.tar.gz
gentoo-2-928270acdcd8369017e75391dd629cb6bb62b97d.tar.bz2
gentoo-2-928270acdcd8369017e75391dd629cb6bb62b97d.zip
Fixed application of umount-l patch in combination with loop-aes patch (bug #375165)
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/ChangeLog8
-rw-r--r--sys-apps/util-linux/files/util-linux-2.19.1-remove-useless-if-stuff-from-loopaes-patchset.diff27
-rw-r--r--sys-apps/util-linux/util-linux-2.19.1-r1.ebuild8
3 files changed, 40 insertions, 3 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index 5d707436f9f7..78872fe0b35a 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/util-linux
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.359 2011/11/11 13:35:07 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.360 2011/11/12 20:49:10 polynomial-c Exp $
+
+ 12 Nov 2011; Lars Wendler <polynomial-c@gentoo.org>
+ util-linux-2.19.1-r1.ebuild,
+ +files/util-linux-2.19.1-remove-useless-if-stuff-from-loopaes-patchset.diff:
+ non-maintainer commit: Fixed application of umount-l patch in combination
+ with loop-aes patch. This fixes bug #375165.
11 Nov 2011; Tony Vroon <chainsaw@gentoo.org> util-linux-2.19.1-r1.ebuild:
Marked stable on AMD64 based on arch testing by Ian "idella4" Delaney &
diff --git a/sys-apps/util-linux/files/util-linux-2.19.1-remove-useless-if-stuff-from-loopaes-patchset.diff b/sys-apps/util-linux/files/util-linux-2.19.1-remove-useless-if-stuff-from-loopaes-patchset.diff
new file mode 100644
index 000000000000..4e990b01c10e
--- /dev/null
+++ b/sys-apps/util-linux/files/util-linux-2.19.1-remove-useless-if-stuff-from-loopaes-patchset.diff
@@ -0,0 +1,27 @@
+This code coming from the loop-aes patch breaks the umount-l patch from
+Gentoo bug #370051.
+
+Signed-off-by: Lars Wendler (Polynomial-C) <polynomial-c@gentoo.org>
+X-Gentoo-Bug: 375165
+X-Gentoo-Bug-URL: https://bugs.gentoo.org/375165
+
+--- util-linux-2.19.1/mount/umount.c
++++ util-linux-2.19.1/mount/umount.c
+@@ -581,9 +581,6 @@
+
+ file = canonicalize(arg); /* mtab paths are canonicalized */
+
+-/* This is too buggy code. If find_loopdev_by_backing_file() actually finds matching */
+-/* loop device, and assigns file=loopdev, then writable /etc/mtab case fails horribly */
+-#if 0
+ /* if file is a regular file, check if it is associated
+ * with some loop device
+ */
+@@ -603,7 +600,6 @@
+ break;
+ }
+ }
+-#endif
+
+ if (verbose > 1)
+ printf(_("Trying to unmount %s\n"), file);
diff --git a/sys-apps/util-linux/util-linux-2.19.1-r1.ebuild b/sys-apps/util-linux/util-linux-2.19.1-r1.ebuild
index 9860345189a9..f8a30c67f07e 100644
--- a/sys-apps/util-linux/util-linux-2.19.1-r1.ebuild
+++ b/sys-apps/util-linux/util-linux-2.19.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.19.1-r1.ebuild,v 1.7 2011/11/11 13:35:07 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.19.1-r1.ebuild,v 1.8 2011/11/12 20:49:10 polynomial-c Exp $
EAPI="3"
@@ -45,7 +45,11 @@ src_prepare() {
autopoint --force
eautoreconf
else
- use loop-aes && epatch "${WORKDIR}"/util-linux-*.diff
+ if use loop-aes ; then
+ epatch "${WORKDIR}"/util-linux-*.diff \
+ "${FILESDIR}"/${P}-remove-useless-if-stuff-from-loopaes-patchset.diff
+ fi
+
fi
epatch "${FILESDIR}"/${P}-mount-a-segv.patch #366213
epatch "${FILESDIR}"/${P}-umount-l-nfs.patch #370051