summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-06-22 17:59:15 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-06-22 17:59:15 +0000
commitf7406173bcba916f8c0d902180ba8992b1018b28 (patch)
tree701516f9e865303594cfb7488ef5bbc88129be43 /sys-apps/vbetool
parentVersion bump, security bug #182918. (diff)
downloadgentoo-2-f7406173bcba916f8c0d902180ba8992b1018b28.tar.gz
gentoo-2-f7406173bcba916f8c0d902180ba8992b1018b28.tar.bz2
gentoo-2-f7406173bcba916f8c0d902180ba8992b1018b28.zip
Added USE=zlib and a check on sys-apps/pciutils so we'll link with zlib when necessary. This closes bug #165064.
(Portage version: 2.1.3_rc4)
Diffstat (limited to 'sys-apps/vbetool')
-rw-r--r--sys-apps/vbetool/ChangeLog6
-rw-r--r--sys-apps/vbetool/vbetool-0.7.ebuild17
2 files changed, 17 insertions, 6 deletions
diff --git a/sys-apps/vbetool/ChangeLog b/sys-apps/vbetool/ChangeLog
index 81ff4a5ece7f..efda132fe3a4 100644
--- a/sys-apps/vbetool/ChangeLog
+++ b/sys-apps/vbetool/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/vbetool
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/vbetool/ChangeLog,v 1.8 2007/02/22 01:33:05 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/vbetool/ChangeLog,v 1.9 2007/06/22 17:59:15 wolf31o2 Exp $
+
+ 22 Jun 2007; Chris Gianelloni <wolf31o2@gentoo.org> vbetool-0.7.ebuild:
+ Added USE=zlib and a check on sys-apps/pciutils so we'll link with zlib when
+ necessary. This closes bug #165064.
22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/sys-apps/vbetool/vbetool-0.7.ebuild b/sys-apps/vbetool/vbetool-0.7.ebuild
index 2338cbd311d4..b91460836034 100644
--- a/sys-apps/vbetool/vbetool-0.7.ebuild
+++ b/sys-apps/vbetool/vbetool-0.7.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/vbetool/vbetool-0.7.ebuild,v 1.1 2006/09/28 19:56:59 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/vbetool/vbetool-0.7.ebuild,v 1.2 2007/06/22 17:59:15 wolf31o2 Exp $
-inherit eutils
+inherit eutils flag-o-matic
DESCRIPTION="Run real-mode video BIOS code to alter hardware state (i.e. reinitialize video card)"
HOMEPAGE="http://www.srcf.ucam.org/~mjg59/vbetool/"
@@ -12,8 +12,8 @@ SRC_URI="http://www.srcf.ucam.org/~mjg59/${PN}/${P//-/_}-1.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~amd64"
-IUSE=""
-RDEPEND="sys-apps/pciutils"
+IUSE="zlib"
+RDEPEND="zlib? ( sys-libs/zlib ) sys-apps/pciutils"
DEPEND="${RDEPEND}"
S="${WORKDIR}/${PN}-0.7"
@@ -23,6 +23,13 @@ S="${WORKDIR}/${PN}-0.7"
#}
src_compile() {
+ if use zlib
+ then
+ append-ldflags -lz
+ elif built_with_use sys-apps/pciutils zlib
+ then
+ die "You need to build with USE=zlib to match sys-apps/pcituils"
+ fi
# when on non-x86 machines, we need to use the x86 emulator
LIBS="-lpci" econf `use_with !x86 x86emu` || die "could not configure"
emake || die "emake failed"