summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-01-25 03:27:56 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-01-25 03:27:56 +0000
commit4fb3ec6ba5b24059b85d2d3abe43d40793c3f895 (patch)
treedf02ea32b6d5111f892c724438238ad8ca75bb27 /sys-apps/vgabios
parentDrop nicolas as he is no longer the upstream maintainer. (diff)
downloadgentoo-2-4fb3ec6ba5b24059b85d2d3abe43d40793c3f895.tar.gz
gentoo-2-4fb3ec6ba5b24059b85d2d3abe43d40793c3f895.tar.bz2
gentoo-2-4fb3ec6ba5b24059b85d2d3abe43d40793c3f895.zip
Add 0.7a based vesion. Add debug USE flag.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/vgabios')
-rw-r--r--sys-apps/vgabios/ChangeLog8
-rw-r--r--sys-apps/vgabios/vgabios-0.6c.ebuild17
-rw-r--r--sys-apps/vgabios/vgabios-0.7a.ebuild67
3 files changed, 84 insertions, 8 deletions
diff --git a/sys-apps/vgabios/ChangeLog b/sys-apps/vgabios/ChangeLog
index e1287b7a5f05..a1cdfbf79b39 100644
--- a/sys-apps/vgabios/ChangeLog
+++ b/sys-apps/vgabios/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/vgabios
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/vgabios/ChangeLog,v 1.1 2012/01/25 03:00:17 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/vgabios/ChangeLog,v 1.2 2012/01/25 03:27:56 cardoe Exp $
+
+*vgabios-0.7a (25 Jan 2012)
+
+ 25 Jan 2012; Doug Goldstein <cardoe@gentoo.org> vgabios-0.6c.ebuild,
+ +vgabios-0.7a.ebuild:
+ Add 0.7a based vesion. Add debug USE flag.
*vgabios-0.6c (25 Jan 2012)
diff --git a/sys-apps/vgabios/vgabios-0.6c.ebuild b/sys-apps/vgabios/vgabios-0.6c.ebuild
index 874d1ca01cd9..e95c44d741a3 100644
--- a/sys-apps/vgabios/vgabios-0.6c.ebuild
+++ b/sys-apps/vgabios/vgabios-0.6c.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/vgabios/vgabios-0.6c.ebuild,v 1.1 2012/01/25 03:00:17 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/vgabios/vgabios-0.6c.ebuild,v 1.2 2012/01/25 03:27:56 cardoe Exp $
# Can't really call them backports when they're fixes that upstream
# won't carry
@@ -19,7 +19,7 @@ LICENSE="LGPL-2.1"
SLOT="0"
#KEYWORDS="~amd64 ~x86"
KEYWORDS="-*"
-IUSE=""
+IUSE="debug"
DEPEND="sys-devel/dev86"
RDEPEND=""
@@ -43,22 +43,25 @@ src_install() {
# Stock VGABIOS
newins VGABIOS-lgpl-latest.bin vgabios.bin
- newins VGABIOS-lgpl-latest.debug.bin vgabios.debug.bin
+ use debug && newins VGABIOS-lgpl-latest.debug.bin vgabios.debug.bin
# Cirrus
newins VGABIOS-lgpl-latest.cirrus.bin vgabios.cirrus.bin
- newins VGABIOS-lgpl-latest.cirrus.debug.bin vgabios.cirrus.debug.bin
+ use debug && newins VGABIOS-lgpl-latest.cirrus.debug.bin \
+ vgabios.cirrus.debug.bin
# QXL
newins VGABIOS-lgpl-latest.qxl.bin vgabios.qxl.bin
- newins VGABIOS-lgpl-latest.qxl.debug.bin vgabios.qxl.debug.bin
+ use debug && newins VGABIOS-lgpl-latest.qxl.debug.bin vgabios.qxl.debug.bin
# Standard VGA
newins VGABIOS-lgpl-latest.stdvga.bin vgabios.stdvga.bin
- newins VGABIOS-lgpl-latest.stdvga.debug.bin vgabios.stdvga.debug.bin
+ use debug && newins VGABIOS-lgpl-latest.stdvga.debug.bin \
+ vgabios.stdvga.debug.bin
# VMWare
newins VGABIOS-lgpl-latest.vmware.bin vgabios.vmware.bin
- newins VGABIOS-lgpl-latest.vmware.debug.bin vgabios.vmware.debug.bin
+ use debug && newins VGABIOS-lgpl-latest.vmware.debug.bin \
+ vgabios.vmware.debug.bin
}
diff --git a/sys-apps/vgabios/vgabios-0.7a.ebuild b/sys-apps/vgabios/vgabios-0.7a.ebuild
new file mode 100644
index 000000000000..9dd0d1d3aa16
--- /dev/null
+++ b/sys-apps/vgabios/vgabios-0.7a.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/vgabios/vgabios-0.7a.ebuild,v 1.1 2012/01/25 03:27:56 cardoe Exp $
+
+# Can't really call them backports when they're fixes that upstream
+# won't carry
+FIXES=1
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="VGA BIOS implementation"
+HOMEPAGE="http://www.nongnu.org/vgabios/"
+SRC_URI="http://savannah.gnu.org/download/${PN}/${P}.tgz
+ http://dev.gentoo.org/~cardoe/distfiles/${P}-fixes-${FIXES}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+#KEYWORDS="~amd64 ~x86"
+KEYWORDS="-*"
+IUSE="debug"
+
+DEPEND="sys-devel/dev86"
+RDEPEND=""
+
+src_prepare() {
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
+ epatch
+}
+
+pkg_configure() {
+ :
+}
+
+src_compile() {
+ emake biossums
+ emake
+}
+
+src_install() {
+ insinto /usr/share/vgabios
+
+ # Stock VGABIOS
+ newins VGABIOS-lgpl-latest.bin vgabios.bin
+ use debug && newins VGABIOS-lgpl-latest.debug.bin vgabios.debug.bin
+
+ # Cirrus
+ newins VGABIOS-lgpl-latest.cirrus.bin vgabios.cirrus.bin
+ use debug && newins VGABIOS-lgpl-latest.cirrus.debug.bin \
+ vgabios.cirrus.debug.bin
+
+ # QXL
+ newins VGABIOS-lgpl-latest.qxl.bin vgabios.qxl.bin
+ use debug && newins VGABIOS-lgpl-latest.qxl.debug.bin vgabios.qxl.debug.bin
+
+ # Standard VGA
+ newins VGABIOS-lgpl-latest.stdvga.bin vgabios.stdvga.bin
+ use debug && newins VGABIOS-lgpl-latest.stdvga.debug.bin \
+ vgabios.stdvga.debug.bin
+
+ # VMWare
+ newins VGABIOS-lgpl-latest.vmware.bin vgabios.vmware.bin
+ use debug && newins VGABIOS-lgpl-latest.vmware.debug.bin \
+ vgabios.vmware.debug.bin
+}
+