summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-13 23:36:18 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-13 23:36:18 +0000
commit8f6d18790d455fb23781b92ee6b690ed38cd4ac0 (patch)
tree32b62bd7c98b1209ae6e70888adff949fee17344 /sys-apps/x86info
parentAdded to ~ppc-macos. (diff)
downloadgentoo-2-8f6d18790d455fb23781b92ee6b690ed38cd4ac0.tar.gz
gentoo-2-8f6d18790d455fb23781b92ee6b690ed38cd4ac0.tar.bz2
gentoo-2-8f6d18790d455fb23781b92ee6b690ed38cd4ac0.zip
pic support #67365
Diffstat (limited to 'sys-apps/x86info')
-rw-r--r--sys-apps/x86info/ChangeLog5
-rw-r--r--sys-apps/x86info/x86info-1.12b.ebuild44
2 files changed, 21 insertions, 28 deletions
diff --git a/sys-apps/x86info/ChangeLog b/sys-apps/x86info/ChangeLog
index 30789a5b9752..945a75579757 100644
--- a/sys-apps/x86info/ChangeLog
+++ b/sys-apps/x86info/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/x86info
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/ChangeLog,v 1.5 2004/06/24 22:32:54 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/ChangeLog,v 1.6 2004/10/13 23:36:18 vapier Exp $
+
+ 13 Oct 2004; Mike Frysinger <vapier@gentoo.org> x86info-1.12b.ebuild:
+ Add a pic patch to fix #67365.
05 May 2004; Travis Tilley <lv@gentoo.org> x86info-1.11.ebuild,
x86info-1.12b.ebuild:
diff --git a/sys-apps/x86info/x86info-1.12b.ebuild b/sys-apps/x86info/x86info-1.12b.ebuild
index 960bcc7766bb..e8e0c885da85 100644
--- a/sys-apps/x86info/x86info-1.12b.ebuild
+++ b/sys-apps/x86info/x86info-1.12b.ebuild
@@ -1,35 +1,43 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/x86info-1.12b.ebuild,v 1.5 2004/07/15 02:47:51 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/x86info-1.12b.ebuild,v 1.6 2004/10/13 23:36:18 vapier Exp $
inherit eutils
DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
-HOMEPAGE="http://www.codemonkey.org.uk/projects/${PN}/"
-SRC_URI="${HOMEPAGE}/${P}.tgz"
+HOMEPAGE="http://www.codemonkey.org.uk/projects/x86info/"
+SRC_URI="http://www.codemonkey.org.uk/projects/x86info/${P}.tgz"
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 -amd64 -ppc -sparc -mips -alpha -hppa"
-DEPEND="virtual/kernel"
-RDEPEND=""
+KEYWORDS="-* x86"
IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-pic.patch
+}
+
src_compile() {
emake x86info CFLAGS="${CFLAGS}" || die "emake failed"
}
src_install() {
# binaries first
- into /usr
dobin x86info
+
# modules stuff next
insinto /etc/modules.d
newins ${FILESDIR}/x86info-modules.conf-rc x86info
+
# now we all all the docs
- dodoc TODO README COPYING ChangeLog
+ dodoc TODO README ChangeLog
doman x86info.1
cp -a results ${D}/usr/share/doc/${PF}
- # prepalldocs rocks! I saw it in net-fs/samba/samba-2.2.8
prepalldocs
}
@@ -39,22 +47,4 @@ pkg_postinst() {
ewarn " Processor type and features ->"
ewarn " [*] /dev/cpu/*/msr - Model-specific register support"
ewarn " [*] /dev/cpu/*/cpuid - CPU information support"
- # copied from media-libs/svgalib/svgalib-1.9.17
- if [ "${ROOT}" = "/" ]; then
- /sbin/modules-update &> /dev/null
-
- # create device nodes for x86info
- # based off the scripts/makenode
- # there isn't any proper devfs support in cpuid/msr
- einfo "Creating device nodes for x86info"
- mkdir -p ${ROOT}/dev/cpu
- local numprocs
- #subtract one because we are using a 0-based count
- numprocs=$((`grep -c '^processor' /proc/cpuinfo`-1))
- for i in `seq 0 $numprocs`; do
- mkdir ${ROOT}/dev/cpu/$i
- mknod ${ROOT}/dev/cpu/$i/cpuid c 203 $i 2>/dev/null
- mknod ${ROOT}/dev/cpu/$i/msr c 202 $i 2>/dev/null
- done
- fi
}