summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-10 20:45:43 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-10 20:45:43 +0000
commitc62c9366854bbacc33d796a6033c244d5ce5cf6a (patch)
treeeefab7805804cbb7fe92588987e79bade82bc687 /sys-apps/x86info
parentUpdate upstream URLs, minor dodoc QA. Bug #276632 (diff)
downloadgentoo-2-c62c9366854bbacc33d796a6033c244d5ce5cf6a.tar.gz
gentoo-2-c62c9366854bbacc33d796a6033c244d5ce5cf6a.tar.bz2
gentoo-2-c62c9366854bbacc33d796a6033c244d5ce5cf6a.zip
Respect LDFLAGS.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/x86info')
-rw-r--r--sys-apps/x86info/x86info-1.24-r2.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-apps/x86info/x86info-1.24-r2.ebuild b/sys-apps/x86info/x86info-1.24-r2.ebuild
index fa93d61c5fd1..09826a75b39e 100644
--- a/sys-apps/x86info/x86info-1.24-r2.ebuild
+++ b/sys-apps/x86info/x86info-1.24-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/x86info-1.24-r2.ebuild,v 1.1 2009/07/05 20:11:39 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/x86info-1.24-r2.ebuild,v 1.2 2009/07/10 20:45:43 ssuominen Exp $
inherit eutils toolchain-funcs
@@ -13,13 +13,15 @@ SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE=""
-DEPEND=""
RDEPEND=""
+DEPEND="sys-apps/sed"
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/1.21-pic.patch
+ sed -i -e 's:$(CFLAGS) -o x86:$(LDFLAGS) $(CFLAGS) -o x86:' \
+ Makefile || die "I don't want your LDFLAGS."
}
src_compile() {