summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-30 15:30:48 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-30 15:30:48 +0000
commit1f8bc79d41a32ac275dcf829dff4cde1462c3a50 (patch)
tree2c7b8cc519189cff624d249ed57f210966679b47 /sys-apps/xinetd
parentAnother version bump (diff)
downloadgentoo-2-1f8bc79d41a32ac275dcf829dff4cde1462c3a50.tar.gz
gentoo-2-1f8bc79d41a32ac275dcf829dff4cde1462c3a50.tar.bz2
gentoo-2-1f8bc79d41a32ac275dcf829dff4cde1462c3a50.zip
Version bump
Diffstat (limited to 'sys-apps/xinetd')
-rw-r--r--sys-apps/xinetd/ChangeLog8
-rw-r--r--sys-apps/xinetd/files/digest-xinetd-2.3.41
-rw-r--r--sys-apps/xinetd/xinetd-2.3.4.ebuild50
3 files changed, 58 insertions, 1 deletions
diff --git a/sys-apps/xinetd/ChangeLog b/sys-apps/xinetd/ChangeLog
index cb110542ccbb..d67074a2204e 100644
--- a/sys-apps/xinetd/ChangeLog
+++ b/sys-apps/xinetd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/xinetd
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/ChangeLog,v 1.1 2002/02/01 21:53:38 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/ChangeLog,v 1.2 2002/03/30 15:30:48 seemant Exp $
+
+*xinetd-2.3.4 (30 Mar 2002)
+
+ 30 Mar 2002; Seemant Kulleen <seemant@gentoo.org> xinetd-2.3.4.ebuild :
+
+ Version bump -- copied the 2.3.3-r7 ebuild over.
*xinetd-2.3.3-r7 (1 Feb 2002)
diff --git a/sys-apps/xinetd/files/digest-xinetd-2.3.4 b/sys-apps/xinetd/files/digest-xinetd-2.3.4
new file mode 100644
index 000000000000..bf863f579675
--- /dev/null
+++ b/sys-apps/xinetd/files/digest-xinetd-2.3.4
@@ -0,0 +1 @@
+MD5 8f7ac612910aaf811c4554f4ab40fd65 xinetd-2.3.4.tar.gz 270723
diff --git a/sys-apps/xinetd/xinetd-2.3.4.ebuild b/sys-apps/xinetd/xinetd-2.3.4.ebuild
new file mode 100644
index 000000000000..74b021e0220b
--- /dev/null
+++ b/sys-apps/xinetd/xinetd-2.3.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/xinetd-2.3.4.ebuild,v 1.1 2002/03/30 15:30:48 seemant Exp $
+
+# NB: This ebuild introduces the /etc/xinetd.d includedir with a default
+# /etc/xinetd.conf file. Check your config files if you're upgrading
+# from an older ebuild version. You should browse /etc/xinetd.conf
+# and the files in /etc/xinetd.d. Everything is off by default with
+# access restricted to localhost.
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Xinetd is a powerful replacement for inetd, with advanced features"
+HOMEPAGE="http://www.xinetd.org"
+SRC_URI="http://www.xinetd.org/${P}.tar.gz"
+
+DEPEND="virtual/glibc tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+RDEPEND="virtual/glibc sys-devel/perl"
+
+src_compile() {
+
+ local myconf
+ use tcpd && myconf="--with-libwrap"
+
+ ./configure --with-loadavg --host=${CHOST} ${myconf} || die
+
+ # Parallel make does not work
+ make || die
+}
+
+src_install() {
+
+ into /usr ; dosbin xinetd/xinetd xinetd/itox
+ exeinto /usr/sbin ; doexe ${FILESDIR}/xconv.pl
+
+ newman xinetd/xinetd.conf.man xinetd.conf.5
+ newman xinetd/xinetd.log.man xinetd.log.8
+ newman xinetd/xinetd.man xinetd.8
+ doman xinetd/itox.8
+
+ newdoc xinetd/sample.conf xinetd.conf.dist.sample
+ newdoc ${FILESDIR}/xinetd.conf xinetd.conf.default
+ dodoc AUDIT CHANGELOG README COPYRIGHT
+
+ insinto /etc/xinetd.d ; doins ${FILESDIR}/etc.xinetd.d/*
+ exeinto /etc/init.d ; newexe ${FILESDIR}/xinetd.rc6 xinetd
+ insinto /etc/conf.d ; newins ${FILESDIR}/xinetd.confd xinetd
+ insinto /etc ; doins ${FILESDIR}/xinetd.conf
+}