summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-30 09:41:45 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-30 09:41:45 +0000
commit0a5e2c0d29293e933adf144680c7aae3b1ed2732 (patch)
tree3a67c3b80fcc308ef8445c281d3afcef9d7955e3 /sys-apps
parenttidy patches (diff)
downloadgentoo-2-0a5e2c0d29293e933adf144680c7aae3b1ed2732.tar.gz
gentoo-2-0a5e2c0d29293e933adf144680c7aae3b1ed2732.tar.bz2
gentoo-2-0a5e2c0d29293e933adf144680c7aae3b1ed2732.zip
Fix building with x11-libs/libnotify >= 0.7.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/syslog-notify/ChangeLog8
-rw-r--r--sys-apps/syslog-notify/files/syslog-notify-0.1-libnotify-0.7.patch18
-rw-r--r--sys-apps/syslog-notify/syslog-notify-0.1.ebuild19
3 files changed, 36 insertions, 9 deletions
diff --git a/sys-apps/syslog-notify/ChangeLog b/sys-apps/syslog-notify/ChangeLog
index a6d99cbe0b7a..2512d34f0914 100644
--- a/sys-apps/syslog-notify/ChangeLog
+++ b/sys-apps/syslog-notify/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/syslog-notify
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/syslog-notify/ChangeLog,v 1.3 2010/06/29 08:57:31 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/syslog-notify/ChangeLog,v 1.4 2011/01/30 09:41:45 ssuominen Exp $
+
+ 30 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> syslog-notify-0.1.ebuild,
+ +files/syslog-notify-0.1-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7.
29 Jun 2010; Christian Faulhammer <fauli@gentoo.org>
syslog-notify-0.1.ebuild:
diff --git a/sys-apps/syslog-notify/files/syslog-notify-0.1-libnotify-0.7.patch b/sys-apps/syslog-notify/files/syslog-notify-0.1-libnotify-0.7.patch
new file mode 100644
index 000000000000..acefdd765c20
--- /dev/null
+++ b/sys-apps/syslog-notify/files/syslog-notify-0.1-libnotify-0.7.patch
@@ -0,0 +1,18 @@
+--- src/syslog-notify.c
++++ src/syslog-notify.c
+@@ -66,7 +66,15 @@
+ close(fd);
+ return;
+ }
++#ifdef NOTIFY_CHECK_VERSION
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ notification=notify_notification_new(title,message,NULL);
++#else
+ notification=notify_notification_new(title,message,NULL,NULL);
++#endif
++#else
++ notification=notify_notification_new(title,message,NULL,NULL);
++#endif
+ notify_notification_set_timeout(notification,NOTIFY_EXPIRES_DEFAULT);
+ notify_notification_set_urgency(notification,NOTIFY_URGENCY_NORMAL);
+ notify_notification_set_hint_string(notification,"x-canonical-append",
diff --git a/sys-apps/syslog-notify/syslog-notify-0.1.ebuild b/sys-apps/syslog-notify/syslog-notify-0.1.ebuild
index ad453f1d5b6a..664b128ce149 100644
--- a/sys-apps/syslog-notify/syslog-notify-0.1.ebuild
+++ b/sys-apps/syslog-notify/syslog-notify-0.1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/syslog-notify/syslog-notify-0.1.ebuild,v 1.3 2010/06/29 08:57:31 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/syslog-notify/syslog-notify-0.1.ebuild,v 1.4 2011/01/30 09:41:45 ssuominen Exp $
-EAPI="2"
+EAPI=2
+inherit eutils
DESCRIPTION="Notifications for syslog entries via libnotify"
HOMEPAGE="http://jtniehof.github.com/syslog-notify/"
@@ -17,13 +18,17 @@ DEPEND="x11-libs/libnotify"
RDEPEND="${DEPEND}
app-admin/syslog-ng"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+}
+
src_install() {
- dosbin src/syslog-notify || die "install failed"
+ dosbin src/syslog-notify || die
ebegin "Creating /var/spool/syslog-notify FIFO"
- dodir /var/spool/ || die "dodir failed"
- mkfifo "${D}"var/spool/syslog-notify || die "mkfifo failed"
+ dodir /var/spool/ || die
+ mkfifo "${D}"var/spool/syslog-notify || die
eend $?
- dodoc AUTHORS INSTALL README || die "dodoc failed"
+ dodoc AUTHORS INSTALL README || die
}
pkg_postinst() {