summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-01-15 13:41:16 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-01-15 13:41:16 +0000
commit0c0c34fb3c2e6380f55d7cc15fc2557868031969 (patch)
treeeb0533d672bd4209aadda768b8cc1adf46eaae93 /sys-apps
parentFix the installation path from /usr/kde/x.x to /usr, patch submitted to the a... (diff)
downloadgentoo-2-0c0c34fb3c2e6380f55d7cc15fc2557868031969.tar.gz
gentoo-2-0c0c34fb3c2e6380f55d7cc15fc2557868031969.tar.bz2
gentoo-2-0c0c34fb3c2e6380f55d7cc15fc2557868031969.zip
Added support for hackish profiles that symlink lib to lib64.
(Portage version: 2.0.51-r12)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/baselayout/ChangeLog6
-rw-r--r--sys-apps/baselayout/baselayout-1.11.8-r2.ebuild59
-rw-r--r--sys-apps/baselayout/baselayout-1.9.4-r7.ebuild53
3 files changed, 78 insertions, 40 deletions
diff --git a/sys-apps/baselayout/ChangeLog b/sys-apps/baselayout/ChangeLog
index 1279c41824c0..4cf9b749f1b7 100644
--- a/sys-apps/baselayout/ChangeLog
+++ b/sys-apps/baselayout/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for sys-apps/baselayout
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.200 2005/01/15 00:59:35 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.201 2005/01/15 13:41:16 eradicator Exp $
# See the gentoo-src rc-scripts ChangeLog for up-to-date release information:
# http://www.gentoo.org/cgi-bin/viewcvs.cgi/rc-scripts/ChangeLog?rev=HEAD&cvsroot=gentoo-src&content-type=text/vnd.viewcvs-markup
+ 15 Jan 2005; Jeremy Huddleston <eradicator@gentoo.org>
+ baselayout-1.11.8-r2.ebuild, baselayout-1.9.4-r7.ebuild:
+ Added support for hackish profiles that symlink lib to lib64.
+
14 Jan 2005; Jeremy Huddleston <eradicator@gentoo.org>
baselayout-1.9.4-r7.ebuild:
Stable for 2005.0.
diff --git a/sys-apps/baselayout/baselayout-1.11.8-r2.ebuild b/sys-apps/baselayout/baselayout-1.11.8-r2.ebuild
index ef3145a522ce..dc4b221868d8 100644
--- a/sys-apps/baselayout/baselayout-1.11.8-r2.ebuild
+++ b/sys-apps/baselayout/baselayout-1.11.8-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.11.8-r2.ebuild,v 1.1 2005/01/13 07:37:54 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.11.8-r2.ebuild,v 1.2 2005/01/15 13:41:16 eradicator Exp $
inherit flag-o-matic eutils toolchain-funcs multilib
@@ -111,12 +111,32 @@ unkdir() {
}
src_install() {
- local dir libdirs libdirs_env
+ local dir libdirs libdirs_env rcscripts_dir
# This directory is to stash away things that will be used in
# pkg_postinst; it's needed first for kdir to function
dodir /usr/share/baselayout
+ # Jeremy Huddleston <eradicator@gentoo.org>
+ # For multilib, we want to make sure that all our multilibdirs exist
+ # and make lib even if it's not listed as one (like on amd64/ppc64
+ # which sometimes has lib32/lib64 instead of lib/lib64).
+ # lib should NOT be a symlink to one of the other libdirs.
+ # Old systems with symlinks won't be affected by this change, as the
+ # symlinks already exist and won't get removed, but new systems will
+ # be setup properly.
+ #
+ # I'll be making a script to convert existing systems from symlink to
+ # nosymlink and putting it in /usr/portage/scripts.
+ libdirs=$(get_all_libdirs)
+ : ${libdirs:=lib} # it isn't that we don't trust multilib.eclass...
+
+ if [ "${SYMLINK_LIB}" = "yes" ]; then
+ rcscripts_dir="/$(get_abi_LIBDIR ${DEFAULT_ABI})/rcscripts"
+ else
+ rcscripts_dir="/lib/rcscripts"
+ fi
+
einfo "Creating directories..."
kdir /usr
kdir /usr/local
@@ -184,27 +204,24 @@ src_install() {
kdir /var/state
kdir -m 1777 /var/tmp
- # Jeremy Huddleston <eradicator@gentoo.org>
- # For multilib, we want to make sure that all our multilibdirs exist
- # and make lib even if it's not listed as one (like on amd64/ppc64
- # which sometimes has lib32/lib64 instead of lib/lib64).
- # lib should NOT be a symlink to one of the other libdirs.
- # Old systems with symlinks won't be affected by this change, as the
- # symlinks already exist and won't get removed, but new systems will
- # be setup properly.
- #
- # I'll be making a script to convert existing systems from symlink to
- # nosymlink and putting it in /usr/portage/scripts.
- libdirs=$(get_all_libdirs)
- : ${libdirs:=lib} # it isn't that we don't trust multilib.eclass...
for dir in ${libdirs}; do
+ libdirs_env="${libdirs_env:+$libdirs_env:}/${dir}:/usr/${dir}:/usr/local/${dir}"
+ [ "${dir}" = "lib" -a "${SYMLINK_LIB}" = "yes" ] && continue
kdir /${dir}
kdir /usr/${dir}
kdir /usr/local/${dir}
kdir /usr/X11R6/${dir}
- libdirs_env="${libdirs_env:+$libdirs_env:}/${dir}:/usr/${dir}:/usr/local/${dir}"
done
+ # Ugly compatibility with stupid ebuilds and old profiles symlinks
+ if [ "${SYMLINK_LIB}" = "yes" ]; then
+ rm -rf ${D}/lib ${D}/usr/lib ${D}/usr/local/lib ${D}/usr/X11R6/lib
+ dosym $(get_abi_LIBDIR ${DEFAULT_ABI}) /lib
+ dosym $(get_abi_LIBDIR ${DEFAULT_ABI}) /usr/lib
+ dosym $(get_abi_LIBDIR ${DEFAULT_ABI}) /usr/local/lib
+ dosym $(get_abi_LIBDIR ${DEFAULT_ABI}) /usr/X11R6/lib
+ fi
+
# FHS compatibility symlinks stuff
dosym /var/tmp /usr/tmp
dosym ../../share/info /usr/X11R6/share/info
@@ -304,7 +321,7 @@ src_install() {
# under CONFIG_PROTECTed /etc
#
cd ${S}/sbin
- exeinto /lib/rcscripts/sh
+ exeinto ${rcscripts_dir}/sh
doexe rc-services.sh rc-daemon.sh rc-help.sh
# We can only install new, fast awk versions of scripts
@@ -318,15 +335,15 @@ src_install() {
into /
dosbin depscan.sh
dosbin env-update.sh
- insinto /lib/rcscripts/awk
+ insinto ${rcscripts_dir}/awk
doins ${S}/src/awk/*.awk
fi
# Original design had these in /etc/net.modules.d but that is too
# problematic with CONFIG_PROTECT
- dodir /lib/rcscripts
- cp -a ${S}/lib/rcscripts/net.modules.d ${D}/lib/rcscripts
- chown -R root:root ${D}/lib/rcscripts
+ dodir ${rcscripts_dir}
+ cp -a ${S}${rcscripts_dir}/net.modules.d ${D}${rcscripts_dir}
+ chown -R root:root ${D}${rcscripts_dir}
#
# Install baselayout documentation
diff --git a/sys-apps/baselayout/baselayout-1.9.4-r7.ebuild b/sys-apps/baselayout/baselayout-1.9.4-r7.ebuild
index 577562fb00c3..748103a56bb5 100644
--- a/sys-apps/baselayout/baselayout-1.9.4-r7.ebuild
+++ b/sys-apps/baselayout/baselayout-1.9.4-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.9.4-r7.ebuild,v 1.2 2005/01/15 00:59:35 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.9.4-r7.ebuild,v 1.3 2005/01/15 13:41:16 eradicator Exp $
inherit flag-o-matic eutils toolchain-funcs multilib
@@ -170,7 +170,7 @@ unkdir() {
}
src_install() {
- local foo bar dir libdirs libdirs_env
+ local foo bar dir libdirs libdirs_env rcscripts_dir
# ROOT is purged from the environment prior to calling
# src_install. Good thing we saved it in a temporary file.
@@ -185,6 +185,26 @@ src_install() {
# pkg_postinst
dodir /usr/share/baselayout
+ # Jeremy Huddleston <eradicator@gentoo.org>
+ # For multilib, we want to make sure that all our multilibdirs exist
+ # and make lib even if it's not listed as one (like on amd64/ppc64
+ # which sometimes has lib32/lib64 instead of lib/lib64).
+ # lib should NOT be a symlink to one of the other libdirs.
+ # Old systems with symlinks won't be affected by this change, as the
+ # symlinks already exist and won't get removed, but new systems will
+ # be setup properly.
+ #
+ # I'll be making a script to convert existing systems from symlink to
+ # nosymlink and putting it in /usr/portage/scripts.
+ libdirs=$(get_all_libdirs)
+ : ${libdirs:=lib} # it isn't that we don't trust multilib.eclass...
+
+ if [ "${SYMLINK_LIB}" = "yes" ]; then
+ rcscripts_dir="/$(get_abi_LIBDIR ${DEFAULT_ABI})/rcscripts"
+ else
+ rcscripts_dir="/lib/rcscripts"
+ fi
+
einfo "Creating directories..."
kdir /boot
kdir /dev
@@ -248,27 +268,24 @@ src_install() {
dodir /etc/init.d # .keep file might mess up init.d stuff
dodir /var/db/pkg # .keep file messes up Portage when looking in /var/db/pkg
- # Jeremy Huddleston <eradicator@gentoo.org>
- # For multilib, we want to make sure that all our multilibdirs exist
- # and make lib even if it's not listed as one (like on amd64/ppc64
- # which sometimes has lib32/lib64 instead of lib/lib64).
- # lib should NOT be a symlink to one of the other libdirs.
- # Old systems with symlinks won't be affected by this change, as the
- # symlinks already exist and won't get removed, but new systems will
- # be setup properly.
- #
- # I'll be making a script to convert existing systems from symlink to
- # nosymlink and putting it in /usr/portage/scripts.
- libdirs=$(get_all_libdirs)
- : ${libdirs:=lib} # it isn't that we don't trust multilib.eclass...
for dir in ${libdirs}; do
+ libdirs_env="${libdirs_env:+$libdirs_env:}/${dir}:/usr/${dir}:/usr/local/${dir}"
+ [ "${dir}" = "lib" -a "${SYMLINK_LIB}" = "yes" ] && continue
kdir /${dir}
kdir /usr/${dir}
kdir /usr/local/${dir}
kdir /usr/X11R6/${dir}
- libdirs_env="${libdirs_env:+$libdirs_env:}/${dir}:/usr/${dir}:/usr/local/${dir}"
done
+ # Ugly compatibility with stupid ebuilds and old profiles symlinks
+ if [ "${SYMLINK_LIB}" = "yes" ]; then
+ rm -rf ${D}/lib ${D}/usr/lib ${D}/usr/local/lib ${D}/usr/X11R6/lib
+ dosym $(get_abi_LIBDIR ${DEFAULT_ABI}) /lib
+ dosym $(get_abi_LIBDIR ${DEFAULT_ABI}) /usr/lib
+ dosym $(get_abi_LIBDIR ${DEFAULT_ABI}) /usr/local/lib
+ dosym $(get_abi_LIBDIR ${DEFAULT_ABI}) /usr/X11R6/lib
+ fi
+
# FHS compatibility symlinks stuff
dosym ../var/tmp /usr/tmp
dosym share/man /usr/man
@@ -388,7 +405,7 @@ src_install() {
# Setup files in /lib/rcsripts/sh
#
cd ${S}/sbin
- exeinto /lib/rcscripts/sh
+ exeinto ${rcscripts_dir}/sh
doexe rc-services.sh rc-daemon.sh rc-help.sh
# We can only install new, fast awk versions of scripts
@@ -402,7 +419,7 @@ src_install() {
into /
dosbin depscan.sh
dosbin env-update.sh
- insinto /lib/rcscripts/awk
+ insinto ${rcscripts_dir}/awk
doins ${S}/src/awk/*.awk
fi