summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-07-16 07:30:08 +0000
committerMichał Górny <mgorny@gentoo.org>2013-07-16 07:30:08 +0000
commit1f36e06780b2f48c3513f06a76314774a8e21ace (patch)
tree52c75bd219d5df31875cf9b46fc3998fa21a777e /sys-apps
parentFix leveldb memenv header search location (diff)
downloadgentoo-2-1f36e06780b2f48c3513f06a76314774a8e21ace.tar.gz
gentoo-2-1f36e06780b2f48c3513f06a76314774a8e21ace.tar.bz2
gentoo-2-1f36e06780b2f48c3513f06a76314774a8e21ace.zip
Use get_bashcompdir for future bash-completion compat.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/ChangeLog6
-rw-r--r--sys-apps/systemd/systemd-201.ebuild9
-rw-r--r--sys-apps/systemd/systemd-204.ebuild6
-rw-r--r--sys-apps/systemd/systemd-205.ebuild9
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild9
5 files changed, 23 insertions, 16 deletions
diff --git a/sys-apps/systemd/ChangeLog b/sys-apps/systemd/ChangeLog
index a825b0caf7a9..21b29888ef9e 100644
--- a/sys-apps/systemd/ChangeLog
+++ b/sys-apps/systemd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/systemd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.143 2013/07/14 00:00:50 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.144 2013/07/16 07:30:08 mgorny Exp $
+
+ 16 Jul 2013; Michał Górny <mgorny@gentoo.org> systemd-201.ebuild,
+ systemd-204.ebuild, systemd-205.ebuild, systemd-9999.ebuild:
+ Use get_bashcompdir for future bash-completion compat.
14 Jul 2013; Mike Gilbert <floppym@gentoo.org> systemd-205.ebuild,
systemd-9999.ebuild:
diff --git a/sys-apps/systemd/systemd-201.ebuild b/sys-apps/systemd/systemd-201.ebuild
index 920e3082f1e4..882fce40099e 100644
--- a/sys-apps/systemd/systemd-201.ebuild
+++ b/sys-apps/systemd/systemd-201.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-201.ebuild,v 1.22 2013/07/04 13:43:37 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-201.ebuild,v 1.23 2013/07/16 07:30:08 mgorny Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit autotools-utils linux-info multilib pam python-single-r1 systemd toolchain-funcs udev user
+inherit autotools-utils bash-completion-r1 linux-info multilib pam \
+ python-single-r1 systemd toolchain-funcs udev user
DESCRIPTION="System and service manager for Linux"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
@@ -105,8 +106,8 @@ src_configure() {
local myeconfargs=(
--localstatedir=/var
--with-pamlibdir=$(getpam_mod_dir)
- # avoid bash-completion dep, default is stupid
- --with-bashcompletiondir=/usr/share/bash-completion
+ # avoid bash-completion dep
+ --with-bashcompletiondir="$(get_bashcompdir)"
# make sure we get /bin:/sbin in $PATH
--enable-split-usr
# disable sysv compatibility
diff --git a/sys-apps/systemd/systemd-204.ebuild b/sys-apps/systemd/systemd-204.ebuild
index f0307dcdd956..4d3b62aea6cc 100644
--- a/sys-apps/systemd/systemd-204.ebuild
+++ b/sys-apps/systemd/systemd-204.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-204.ebuild,v 1.3 2013/06/20 12:29:10 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-204.ebuild,v 1.4 2013/07/16 07:30:08 mgorny Exp $
EAPI=5
@@ -122,8 +122,8 @@ src_configure() {
local myeconfargs=(
--localstatedir=/var
--with-pamlibdir=$(getpam_mod_dir)
- # avoid bash-completion dep, default is stupid
- --with-bashcompletiondir=/usr/share/bash-completion
+ # avoid bash-completion dep
+ --with-bashcompletiondir="$(get_bashcompdir)"
# make sure we get /bin:/sbin in $PATH
--enable-split-usr
# disable sysv compatibility
diff --git a/sys-apps/systemd/systemd-205.ebuild b/sys-apps/systemd/systemd-205.ebuild
index 59312bd7a464..4862d1d4e56e 100644
--- a/sys-apps/systemd/systemd-205.ebuild
+++ b/sys-apps/systemd/systemd-205.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-205.ebuild,v 1.2 2013/07/14 00:00:50 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-205.ebuild,v 1.3 2013/07/16 07:30:08 mgorny Exp $
EAPI=5
AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
PYTHON_COMPAT=( python2_7 )
-inherit autotools-utils fcaps linux-info multilib pam python-single-r1 systemd toolchain-funcs udev user
+inherit autotools-utils bash-completion-r1 fcaps linux-info multilib \
+ pam python-single-r1 systemd toolchain-funcs udev user
DESCRIPTION="System and service manager for Linux"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
@@ -122,8 +123,8 @@ src_configure() {
local myeconfargs=(
--localstatedir=/var
--with-pamlibdir=$(getpam_mod_dir)
- # avoid bash-completion dep, default is stupid
- --with-bashcompletiondir=/usr/share/bash-completion
+ # avoid bash-completion dep
+ --with-bashcompletiondir="$(get_bashcompdir)"
# make sure we get /bin:/sbin in $PATH
--enable-split-usr
# disable sysv compatibility
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 18c37b364ebb..de82111568c0 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-9999.ebuild,v 1.63 2013/07/14 00:00:50 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-9999.ebuild,v 1.64 2013/07/16 07:30:08 mgorny Exp $
EAPI=5
@@ -14,7 +14,8 @@ inherit git-2
AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
PYTHON_COMPAT=( python2_7 )
-inherit autotools-utils fcaps linux-info multilib pam python-single-r1 systemd toolchain-funcs udev user
+inherit autotools-utils bash-completion-r1 fcaps linux-info multilib \
+ pam python-single-r1 systemd toolchain-funcs udev user
DESCRIPTION="System and service manager for Linux"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
@@ -146,8 +147,8 @@ src_configure() {
local myeconfargs=(
--localstatedir=/var
--with-pamlibdir=$(getpam_mod_dir)
- # avoid bash-completion dep, default is stupid
- --with-bashcompletiondir=/usr/share/bash-completion
+ # avoid bash-completion dep
+ --with-bashcompletiondir="$(get_bashcompdir)"
# make sure we get /bin:/sbin in $PATH
--enable-split-usr
# disable sysv compatibility