summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-02-13 23:54:50 +0000
committerMike Frysinger <vapier@gentoo.org>2011-02-13 23:54:50 +0000
commit36d70a0e4e7c38abd54be82267e67dabb712ffa5 (patch)
treef59e9a32838863732f0663938dad22f581cd2052 /sys-apps
parentVersion bump (bug #353095). (diff)
downloadgentoo-2-36d70a0e4e7c38abd54be82267e67dabb712ffa5.tar.gz
gentoo-2-36d70a0e4e7c38abd54be82267e67dabb712ffa5.tar.bz2
gentoo-2-36d70a0e4e7c38abd54be82267e67dabb712ffa5.zip
old
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/busybox/busybox-1.17.1-r1.ebuild269
-rw-r--r--sys-apps/busybox/files/busybox-1.16.0-bb.patch23
-rw-r--r--sys-apps/busybox/files/busybox-1.17.1-date.patch32
-rw-r--r--sys-apps/busybox/files/busybox-1.17.1-grep.patch39
-rw-r--r--sys-apps/busybox/files/busybox-1.17.1-make.patch32
-rw-r--r--sys-apps/busybox/files/busybox-1.17.1-mdev.patch49
-rw-r--r--sys-apps/busybox/files/busybox-1.17.1-mktemp.patch12
-rw-r--r--sys-apps/busybox/files/busybox-1.17.1-sed.patch117
-rw-r--r--sys-apps/busybox/files/busybox-1.17.1-shell.patch105
9 files changed, 0 insertions, 678 deletions
diff --git a/sys-apps/busybox/busybox-1.17.1-r1.ebuild b/sys-apps/busybox/busybox-1.17.1-r1.ebuild
deleted file mode 100644
index 9121abc8b661..000000000000
--- a/sys-apps/busybox/busybox-1.17.1-r1.ebuild
+++ /dev/null
@@ -1,269 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.17.1-r1.ebuild,v 1.3 2010/11/16 12:14:41 vapier Exp $
-
-EAPI=2
-inherit eutils flag-o-matic savedconfig toolchain-funcs
-
-################################################################################
-# BUSYBOX ALTERNATE CONFIG MINI-HOWTO
-#
-# Busybox can be modified in many different ways. Here's a few ways to do it:
-#
-# (1) Emerge busybox with FEATURES=keepwork so the work directory won't
-# get erased afterwards. Add a definition like ROOT=/my/root/path to the
-# start of the line if you're installing to somewhere else than the root
-# directory. This command will save the default configuration to
-# ${PORTAGE_CONFIGROOT} (or ${ROOT} if ${PORTAGE_CONFIGROOT} is not
-# defined), and it will tell you that it has done this. Note the location
-# where the config file was saved.
-#
-# FEATURES=keepwork USE=savedconfig emerge busybox
-#
-# (2) Go to the work directory and change the configuration of busybox using its
-# menuconfig feature.
-#
-# cd /var/tmp/portage/busybox*/work/busybox-*
-# make menuconfig
-#
-# (3) Save your configuration to the default location and copy it to the
-# one of the locations listed in /usr/portage/eclass/savedconfig.eclass
-#
-# (4) Emerge busybox with USE=savedconfig to use the configuration file you
-# just generated.
-#
-################################################################################
-#
-# (1) Alternatively skip the above steps and simply emerge busybox without
-# USE=savedconfig.
-#
-# (2) Edit the file it saves by hand. ${ROOT}"/etc/portage/savedconfig/${CATEGORY}/${PF}
-#
-# (3) Remerge busybox as using USE=savedconfig.
-#
-################################################################################
-
-#SNAPSHOT=20040726
-SNAPSHOT=""
-
-DESCRIPTION="Utilities for rescue and embedded systems"
-HOMEPAGE="http://www.busybox.net/"
-if [[ -n ${SNAPSHOT} ]] ; then
- MY_P=${PN}
- SRC_URI="http://www.busybox.net/downloads/snapshots/${PN}-${SNAPSHOT}.tar.bz2"
-else
- MY_P=${PN}-${PV/_/-}
- SRC_URI="http://www.busybox.net/downloads/${MY_P}.tar.bz2"
-fi
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="debug ipv6 make-symlinks +mdev -pam selinux static elibc_glibc"
-RESTRICT="test"
-
-DEPEND="selinux? ( sys-libs/libselinux )
- pam? ( sys-libs/pam )"
-
-S=${WORKDIR}/${MY_P}
-
-busybox_config_option() {
- case $1 in
- y) sed -i -e "s:.*\<CONFIG_$2\>.*set:CONFIG_$2=y:g" .config;;
- n) sed -i -e "s:CONFIG_$2=y:# CONFIG_$2 is not set:g" .config;;
- *) use $1 \
- && busybox_config_option y $2 \
- || busybox_config_option n $2
- return 0
- ;;
- esac
- einfo $(grep "CONFIG_$2[= ]" .config || echo Could not find CONFIG_$2 ...)
-}
-
-src_prepare() {
- unset KBUILD_OUTPUT #88088
- append-flags -fno-strict-aliasing #310413
-
- # patches go here!
- epatch "${FILESDIR}"/busybox-1.17.0-bb.patch
- epatch "${FILESDIR}"/busybox-${PV}-*.patch
-
- # flag cleanup
- sed -i -r \
- -e 's:[[:space:]]?-(Werror|Os|falign-(functions|jumps|loops|labels)=1|fomit-frame-pointer)\>::g' \
- Makefile.flags || die
- #sed -i '/bbsh/s:^//::' include/applets.h
- sed -i '/^#error Aborting compilation./d' applets/applets.c || die
- use elibc_glibc && sed -i 's:-Wl,--gc-sections::' Makefile
- sed -i \
- -e "/^CROSS_COMPILE/s:=.*:= ${CHOST}-:" \
- -e "/^CC/s:=.*:= $(tc-getCC):" \
- -e "/^HOSTCC/s:=.*:= $(tc-getBUILD_CC):" \
- Makefile || die
-}
-
-src_configure() {
- # check for a busybox config before making one of our own.
- # if one exist lets return and use it.
-
- restore_config .config
- if [ -f .config ]; then
- yes "" | emake -j1 oldconfig > /dev/null
- return 0
- else
- ewarn "Could not locate user configfile, so we will save a default one"
- fi
-
- # setup the config file
- emake -j1 allyesconfig > /dev/null
- busybox_config_option n DMALLOC
- busybox_config_option n FEATURE_SUID_CONFIG
- busybox_config_option n BUILD_AT_ONCE
- busybox_config_option n BUILD_LIBBUSYBOX
- busybox_config_option n NOMMU
- busybox_config_option n MONOTONIC_SYSCALL
-
- # If these are not set and we are using a uclibc/busybox setup
- # all calls to system() will fail.
- busybox_config_option y ASH
- busybox_config_option n HUSH
-
- # disable ipv6 applets
- if ! use ipv6; then
- busybox_config_option n FEATURE_IPV6
- busybox_config_option n TRACEROUTE6
- busybox_config_option n PING6
- fi
-
- if use static && use pam ; then
- ewarn "You cannot have USE='static pam'. Assuming static is more important."
- fi
- use static \
- && busybox_config_option n PAM \
- || busybox_config_option pam PAM
- busybox_config_option static STATIC
- busybox_config_option debug DEBUG
- use debug \
- && busybox_config_option y NO_DEBUG_LIB \
- && busybox_config_option n DMALLOC \
- && busybox_config_option n EFENCE
-
- busybox_config_option selinux SELINUX
-
- # default a bunch of uncommon options to off
- local opt
- for opt in \
- CRONTAB \
- DC DEVFSD DNSD DPKG \
- FAKEIDENTD FBSPLASH FOLD FTP{GET,PUT} \
- HOSTID HUSH \
- INETD INOTIFYD IPCALC \
- LASH LOCALE_SUPPORT LOGNAME LPD \
- MSH \
- OD \
- RFKILL \
- SLATTACH SULOGIN \
- TASKSET TCPSVD \
- RPM RPM2CPIO \
- UDPSVD UUDECODE UUENCODE
- do
- busybox_config_option n ${opt}
- done
-
- emake -j1 oldconfig > /dev/null
-}
-
-src_compile() {
- unset KBUILD_OUTPUT #88088
- export SKIP_STRIP=y
-
- emake busybox || die "build failed"
- if ! use static ; then
- cp .config{,.bak}
- mv busybox_unstripped{,.bak}
- use pam && busybox_config_option n PAM
- emake CONFIG_STATIC=y busybox || die "static build failed"
- mv busybox_unstripped bb
- mv busybox_unstripped{.bak,}
- mv .config{.bak,}
- fi
-}
-
-src_install() {
- unset KBUILD_OUTPUT #88088
- save_config .config
-
- into /
- newbin busybox_unstripped busybox || die
- if use static || use pam ; then
- dosym busybox /bin/bb || die
- dosym bb /bin/busybox.static || die
- else
- dobin bb || die
- fi
- if use mdev; then
- dodir /$(get_libdir)/mdev/
- use make-symlinks || dosym /bin/bb /sbin/mdev
- cp "${S}"/examples/mdev_fat.conf "${D}"/etc/mdev.conf
-
- exeinto /$(get_libdir)/mdev/
- doexe "${FILESDIR}"/mdev/*
-
- insinto /$(get_libdir)/rcscripts/addons
- doins "${FILESDIR}"/mdev-start.sh || die
- newinitd "${FILESDIR}"/mdev.rc mdev || die
- fi
-
- # bundle up the symlink files for use later
- emake install || die
- rm _install/bin/busybox
- tar cf busybox-links.tar -C _install . || : #;die
- insinto /usr/share/${PN}
- doins busybox-links.tar || die
- newins .config ${PF}.config || die
-
- dodoc AUTHORS README TODO
-
- cd docs || die
- docinto txt
- dodoc *.txt
- docinto pod
- dodoc *.pod
- dohtml *.html
-
- cd ../examples || die
- docinto examples
- dodoc inittab depmod.pl *.conf *.script undeb unrpm
-
- cd bootfloppy || die
- docinto bootfloppy
- dodoc $(find . -type f)
-}
-
-pkg_preinst() {
- if use make-symlinks && [[ ! ${VERY_BRAVE_OR_VERY_DUMB} == "yes" ]] && [[ ${ROOT} == "/" ]] ; then
- ewarn "setting USE=make-symlinks and emerging to / is very dangerous."
- ewarn "it WILL overwrite lots of system programs like: ls bash awk grep (bug 60805 for full list)."
- ewarn "If you are creating a binary only and not merging this is probably ok."
- ewarn "set env VERY_BRAVE_OR_VERY_DUMB=yes if this is realy what you want."
- die "silly options will destroy your system"
- fi
-
- if use make-symlinks ; then
- mv "${D}"/usr/share/${PN}/busybox-links.tar "${T}"/ || die
- fi
-}
-
-pkg_postinst() {
- if use make-symlinks ; then
- cd "${T}" || die
- mkdir _install
- tar xf busybox-links.tar -C _install || die
- cp -vpPR _install/* "${ROOT}"/ || die "copying links for ${x} failed"
- fi
-
- echo
- einfo "This ebuild has support for user defined configs"
- einfo "Please read this ebuild for more details and re-emerge as needed"
- einfo "if you want to add or remove functionality for ${PN}"
- echo
-}
diff --git a/sys-apps/busybox/files/busybox-1.16.0-bb.patch b/sys-apps/busybox/files/busybox-1.16.0-bb.patch
deleted file mode 100644
index c6071a3727d3..000000000000
--- a/sys-apps/busybox/files/busybox-1.16.0-bb.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- include/applets.h.orig 2010-03-14 19:05:22.000000000 +0000
-+++ include/applets.h 2010-03-14 19:07:09.000000000 +0000
-@@ -79,7 +79,9 @@
- IF_ASH(APPLET(ash, _BB_DIR_BIN, _BB_SUID_DROP))
- IF_AWK(APPLET_NOEXEC(awk, awk, _BB_DIR_USR_BIN, _BB_SUID_DROP, awk))
- IF_BASENAME(APPLET_NOFORK(basename, basename, _BB_DIR_USR_BIN, _BB_SUID_DROP, basename))
-+IF_ASH(APPLET_ODDNAME(bb, ash, _BB_DIR_BIN, _BB_SUID_DROP, ash))
- IF_BBCONFIG(APPLET(bbconfig, _BB_DIR_BIN, _BB_SUID_DROP))
-+IF_ASH(APPLET_ODDNAME(bbsh, ash, _BB_DIR_BIN, _BB_SUID_DROP, ash))
- //IF_BBSH(APPLET(bbsh, _BB_DIR_BIN, _BB_SUID_DROP))
- IF_BEEP(APPLET(beep, _BB_DIR_USR_BIN, _BB_SUID_DROP))
- IF_BLKID(APPLET(blkid, _BB_DIR_SBIN, _BB_SUID_DROP))
---- shell/ash.c.orig 2010-03-14 19:05:34.000000000 +0000
-+++ shell/ash.c 2010-03-14 19:08:32.000000000 +0000
-@@ -7185,6 +7185,8 @@
- }
- /* re-exec ourselves with the new arguments */
- execve(bb_busybox_exec_path, argv, envp);
-+ execve("/bin/busybox.static", argv, envp);
-+ execve("/bin/busybox", argv, envp);
- /* If they called chroot or otherwise made the binary no longer
- * executable, fall through */
- }
diff --git a/sys-apps/busybox/files/busybox-1.17.1-date.patch b/sys-apps/busybox/files/busybox-1.17.1-date.patch
deleted file mode 100644
index 4dfad710b984..000000000000
--- a/sys-apps/busybox/files/busybox-1.17.1-date.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-http://bugs.gentoo.org/335947
-
-From f2da16f451812f40bed51fd60a304df3d7dfc1bd Mon Sep 17 00:00:00 2001
-From: Denys Vlasenko <vda.linux@googlemail.com>
-Date: Sun, 6 Jun 2010 17:53:48 +0200
-Subject: [PATCH] date: make FEATURE_NANO compile on glibc systems
-
-Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
----
- coreutils/date.c | 6 +++++-
- 1 files changed, 5 insertions(+), 1 deletions(-)
-
-diff --git a/coreutils/date.c b/coreutils/date.c
-index c599df7..3d78a53 100644
---- a/coreutils/date.c
-+++ b/coreutils/date.c
-@@ -204,7 +204,11 @@ int date_main(int argc UNUSED_PARAM, char **argv)
- xstat(filename, &statbuf);
- ts.tv_sec = statbuf.st_mtime;
- #if ENABLE_FEATURE_DATE_NANO
-- ts.tv_nsec = statbuf.st_mtim.tv_nsec;
-+# if defined __GLIBC__ && !defined __UCLIBC__
-+ ts.tv_nsec = statbuf.st_mtim.tv_nsec;
-+# else
-+ ts.tv_nsec = statbuf.st_mtimensec;
-+# endif
- #endif
- } else {
- #if ENABLE_FEATURE_DATE_NANO
---
-1.7.3
-
diff --git a/sys-apps/busybox/files/busybox-1.17.1-grep.patch b/sys-apps/busybox/files/busybox-1.17.1-grep.patch
deleted file mode 100644
index f8fc25d3f3fe..000000000000
--- a/sys-apps/busybox/files/busybox-1.17.1-grep.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff -urpN busybox-1.17.1/findutils/grep.c busybox-1.17.1-grep/findutils/grep.c
---- busybox-1.17.1/findutils/grep.c 2010-07-06 04:25:54.000000000 +0200
-+++ busybox-1.17.1-grep/findutils/grep.c 2010-08-23 02:37:08.000000000 +0200
-@@ -461,15 +461,19 @@ static int grep_file(FILE *file)
- if (found)
- print_line(gl->pattern, strlen(gl->pattern), linenum, ':');
- } else while (1) {
-+ unsigned start = gl->matched_range.rm_so;
- unsigned end = gl->matched_range.rm_eo;
-+ unsigned len = end - start;
- char old = line[end];
- line[end] = '\0';
-- print_line(line + gl->matched_range.rm_so,
-- end - gl->matched_range.rm_so,
-- linenum, ':');
-+ /* Empty match is not printed: try "echo test | grep -o ''" */
-+ if (len != 0)
-+ print_line(line + start, len, linenum, ':');
- if (old == '\0')
- break;
- line[end] = old;
-+ if (len == 0)
-+ end++;
- #if !ENABLE_EXTRA_COMPAT
- if (regexec(&gl->compiled_regex, line + end,
- 1, &gl->matched_range, REG_NOTBOL) != 0)
-diff -urpN busybox-1.17.1/testsuite/grep.tests busybox-1.17.1-grep/testsuite/grep.tests
---- busybox-1.17.1/testsuite/grep.tests 2010-07-06 04:25:54.000000000 +0200
-+++ busybox-1.17.1-grep/testsuite/grep.tests 2010-08-23 02:37:08.000000000 +0200
-@@ -98,5 +98,9 @@ testing "grep -o does not loop forever"
- 'grep -o "[^/]*$"' \
- "test\n" \
- "" "/var/test\n"
-+testing "grep -o does not loop forever on zero-length match" \
-+ 'grep -o "" | head -n1' \
-+ "" \
-+ "" "test\n"
-
- exit $FAILCOUNT
diff --git a/sys-apps/busybox/files/busybox-1.17.1-make.patch b/sys-apps/busybox/files/busybox-1.17.1-make.patch
deleted file mode 100644
index 6177696d9aa3..000000000000
--- a/sys-apps/busybox/files/busybox-1.17.1-make.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -urpN busybox-1.17.1/Makefile busybox-1.17.1-make/Makefile
---- busybox-1.17.1/Makefile 2010-07-25 00:13:44.000000000 +0200
-+++ busybox-1.17.1-make/Makefile 2010-08-22 09:30:33.000000000 +0200
-@@ -433,7 +433,12 @@ ifeq ($(config-targets),1)
- -include $(srctree)/arch/$(ARCH)/Makefile
- export KBUILD_DEFCONFIG
-
--config %config: scripts_basic outputmakefile gen_build_files FORCE
-+config: scripts_basic outputmakefile gen_build_files FORCE
-+ $(Q)mkdir -p include
-+ $(Q)$(MAKE) $(build)=scripts/kconfig $@
-+ $(Q)$(MAKE) -C $(srctree) KBUILD_SRC= .kernelrelease
-+
-+%config: scripts_basic outputmakefile gen_build_files FORCE
- $(Q)mkdir -p include
- $(Q)$(MAKE) $(build)=scripts/kconfig $@
- $(Q)$(MAKE) -C $(srctree) KBUILD_SRC= .kernelrelease
-@@ -1285,9 +1290,13 @@ endif
- $(Q)$(MAKE) $(build)=$(build-dir) $(target-dir)$(notdir $@)
-
- # Modules
--/ %/: prepare scripts FORCE
-+%/: prepare scripts FORCE
- $(Q)$(MAKE) KBUILD_MODULES=$(if $(CONFIG_MODULES),1) \
- $(build)=$(build-dir)
-+/: prepare scripts FORCE
-+ $(Q)$(MAKE) KBUILD_MODULES=$(if $(CONFIG_MODULES),1) \
-+ $(build)=$(build-dir)
-+
- %.ko: prepare scripts FORCE
- $(Q)$(MAKE) KBUILD_MODULES=$(if $(CONFIG_MODULES),1) \
- $(build)=$(build-dir) $(@:.ko=.o)
diff --git a/sys-apps/busybox/files/busybox-1.17.1-mdev.patch b/sys-apps/busybox/files/busybox-1.17.1-mdev.patch
deleted file mode 100644
index e20192cfffe2..000000000000
--- a/sys-apps/busybox/files/busybox-1.17.1-mdev.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-diff -urpN busybox-1.17.1/testsuite/mdev.tests busybox-1.17.1-mdev/testsuite/mdev.tests
---- busybox-1.17.1/testsuite/mdev.tests 2010-07-06 04:25:54.000000000 +0200
-+++ busybox-1.17.1-mdev/testsuite/mdev.tests 2010-08-16 14:28:26.192074223 +0200
-@@ -38,6 +38,16 @@ brw-rw---- 1 0 0 8,0 sda
- SKIP=
-
- # continuing to use directory structure from prev test
-+optional STATIC FEATURE_MDEV_CONF FEATURE_LS_TIMESTAMPS FEATURE_LS_USERNAME
-+testing "mdev deletes /block/sda" \
-+ "env - PATH=$PATH ACTION=remove DEVPATH=/block/sda chroot mdev.testdir /mdev 2>&1;
-+ ls -ln mdev.testdir/dev | $FILTER_LS" \
-+"\
-+" \
-+ "" ""
-+SKIP=
-+
-+# continuing to use directory structure from prev test
- rm -rf mdev.testdir/dev/*
- echo ".* 1:1 666" >mdev.testdir/etc/mdev.conf
- echo "sda 2:2 444" >>mdev.testdir/etc/mdev.conf
-diff -urpN busybox-1.17.1/util-linux/mdev.c busybox-1.17.1-mdev/util-linux/mdev.c
---- busybox-1.17.1/util-linux/mdev.c 2010-07-06 04:25:54.000000000 +0200
-+++ busybox-1.17.1-mdev/util-linux/mdev.c 2010-08-16 14:28:26.193074080 +0200
-@@ -132,6 +132,7 @@ static void make_device(char *path, int
- major = -1;
- }
- }
-+ /* else: for delete, -1 still deletes the node, but < -1 suppresses that */
-
- /* Determine device name, type, major and minor */
- device_name = (char*) bb_basename(path);
-@@ -279,7 +280,7 @@ static void make_device(char *path, int
- if (aliaslink == '!' && s == a+1) {
- val = st;
- /* "!": suppress node creation/deletion */
-- major = -1;
-+ major = -2;
- }
- else if (aliaslink == '>' || aliaslink == '=') {
- val = st;
-@@ -379,7 +380,7 @@ static void make_device(char *path, int
- free(command);
- }
-
-- if (delete && major >= 0) {
-+ if (delete && major >= -1) {
- if (ENABLE_FEATURE_MDEV_RENAME && alias) {
- if (aliaslink == '>')
- unlink(device_name);
diff --git a/sys-apps/busybox/files/busybox-1.17.1-mktemp.patch b/sys-apps/busybox/files/busybox-1.17.1-mktemp.patch
deleted file mode 100644
index 557e337b15f6..000000000000
--- a/sys-apps/busybox/files/busybox-1.17.1-mktemp.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urpN busybox-1.17.1/debianutils/mktemp.c busybox-1.17.1-mktemp/debianutils/mktemp.c
---- busybox-1.17.1/debianutils/mktemp.c 2010-07-25 00:12:56.000000000 +0200
-+++ busybox-1.17.1-mktemp/debianutils/mktemp.c 2010-07-27 08:21:26.000000000 +0200
-@@ -50,7 +50,7 @@ int mktemp_main(int argc UNUSED_PARAM, c
- opts = getopt32(argv, "dqtp:", &path);
-
- chp = argv[optind] ? argv[optind] : xstrdup("tmp.XXXXXX");
-- if (chp[0] != '/' || (opts & 8))
-+ if (!strchr(chp, '/') || (opts & 8))
- chp = concat_path_file(path, chp);
-
- if (opts & 1) { /* -d */
diff --git a/sys-apps/busybox/files/busybox-1.17.1-sed.patch b/sys-apps/busybox/files/busybox-1.17.1-sed.patch
deleted file mode 100644
index 15b77064aa6f..000000000000
--- a/sys-apps/busybox/files/busybox-1.17.1-sed.patch
+++ /dev/null
@@ -1,117 +0,0 @@
-diff -urpN busybox-1.17.1/editors/sed.c busybox-1.17.1-sed/editors/sed.c
---- busybox-1.17.1/editors/sed.c 2010-07-06 04:25:53.000000000 +0200
-+++ busybox-1.17.1-sed/editors/sed.c 2010-08-16 16:27:49.966074102 +0200
-@@ -61,6 +61,10 @@
- #include "libbb.h"
- #include "xregex.h"
-
-+enum {
-+ OPT_in_place = 1 << 0,
-+};
-+
- /* Each sed command turns into one of these structures. */
- typedef struct sed_cmd_s {
- /* Ordered by alignment requirements: currently 36 bytes on x86 */
-@@ -938,8 +942,11 @@ static void process_files(void)
-
- if (matched) {
- /* once matched, "n,xxx" range is dead, disabling it */
-- if (sed_cmd->beg_line > 0)
-+ if (sed_cmd->beg_line > 0
-+ && !(option_mask32 & OPT_in_place) /* but not for -i */
-+ ) {
- sed_cmd->beg_line = -2;
-+ }
- sed_cmd->in_match = !(
- /* has the ending line come, or is this a single address command? */
- (sed_cmd->end_line ?
-@@ -985,6 +992,8 @@ static void process_files(void)
- }
-
- /* actual sedding */
-+ //bb_error_msg("pattern_space:'%s' next_line:'%s' cmd:%c",
-+ //pattern_space, next_line, sed_cmd->cmd);
- switch (sed_cmd->cmd) {
-
- /* Print line number */
-@@ -1111,10 +1120,16 @@ static void process_files(void)
- {
- int len;
- /* If no next line, jump to end of script and exit. */
-+ /* http://www.gnu.org/software/sed/manual/sed.html:
-+ * "Most versions of sed exit without printing anything
-+ * when the N command is issued on the last line of
-+ * a file. GNU sed prints pattern space before exiting
-+ * unless of course the -n command switch has been
-+ * specified. This choice is by design."
-+ */
- if (next_line == NULL) {
-- free(next_line);
-- next_line = NULL;
-- goto discard_line;
-+ //goto discard_line;
-+ goto discard_commands; /* GNU behavior */
- }
- /* Append next_line, read new next_line. */
- len = strlen(pattern_space);
-@@ -1270,9 +1285,6 @@ static void add_cmd_block(char *cmdstr)
- int sed_main(int argc, char **argv) MAIN_EXTERNALLY_VISIBLE;
- int sed_main(int argc UNUSED_PARAM, char **argv)
- {
-- enum {
-- OPT_in_place = 1 << 0,
-- };
- unsigned opt;
- llist_t *opt_e, *opt_f;
- int status = EXIT_SUCCESS;
-@@ -1292,6 +1304,7 @@ int sed_main(int argc UNUSED_PARAM, char
- opt_e = opt_f = NULL;
- opt_complementary = "e::f::" /* can occur multiple times */
- "nn"; /* count -n */
-+ /* -i must be first, to match OPT_in_place definition */
- opt = getopt32(argv, "irne:f:", &opt_e, &opt_f,
- &G.be_quiet); /* counter for -n */
- //argc -= optind;
-diff -urpN busybox-1.17.1/testsuite/sed.tests busybox-1.17.1-sed/testsuite/sed.tests
---- busybox-1.17.1/testsuite/sed.tests 2010-07-06 04:25:54.000000000 +0200
-+++ busybox-1.17.1-sed/testsuite/sed.tests 2010-08-16 16:27:49.967074313 +0200
-@@ -80,10 +80,18 @@ test x"$SKIP_KNOWN_BUGS" = x"" && {
- # Query: how does this interact with no newline at EOF?
- testing "sed n (flushes pattern space, terminates early)" "sed -e 'n;p'" \
- "a\nb\nb\nc\n" "" "a\nb\nc\n"
--# N does _not_ flush pattern space, therefore c is still in there @ script end.
--testing "sed N (doesn't flush pattern space when terminating)" "sed -e 'N;p'" \
-- "a\nb\na\nb\nc\n" "" "a\nb\nc\n"
- }
-+# non-GNU sed: N does _not_ flush pattern space, therefore c is eaten @ script end
-+# GNU sed: N flushes pattern space, therefore c is printed too @ script end
-+testing "sed N (flushes pattern space (GNU behavior))" "sed -e 'N;p'" \
-+ "a\nb\na\nb\nc\n" "" "a\nb\nc\n"
-+
-+testing "sed N test2" "sed ':a;N;s/\n/ /;ta'" \
-+ "a b c\n" "" "a\nb\nc\n"
-+
-+testing "sed N test3" "sed 'N;s/\n/ /'" \
-+ "a b\nc\n" "" "a\nb\nc\n"
-+
- testing "sed address match newline" 'sed "/b/N;/b\\nc/i woo"' \
- "a\nwoo\nb\nc\nd\n" "" "a\nb\nc\nd\n"
-
-@@ -270,11 +278,16 @@ testing "sed a cmd ended by double backs
- | two \\
- '
-
--# fisrt three lines are deleted; 4th line is matched and printed by "2,3" and by "4" ranges
-+# first three lines are deleted; 4th line is matched and printed by "2,3" and by "4" ranges
- testing "sed with N skipping lines past ranges on next cmds" \
- "sed -n '1{N;N;d};1p;2,3p;3p;4p'" \
- "4\n4\n" "" "1\n2\n3\n4\n"
-
-+testing "sed -i with address modifies all files, not only first" \
-+ "cp input input2; sed -i -e '1s/foo/bar/' input input2 && cat input input2; rm input2" \
-+ "bar\nbar\n" "foo\n" ""
-+
-+
- # testing "description" "arguments" "result" "infile" "stdin"
-
- exit $FAILCOUNT
diff --git a/sys-apps/busybox/files/busybox-1.17.1-shell.patch b/sys-apps/busybox/files/busybox-1.17.1-shell.patch
deleted file mode 100644
index 5279b1202c46..000000000000
--- a/sys-apps/busybox/files/busybox-1.17.1-shell.patch
+++ /dev/null
@@ -1,105 +0,0 @@
-diff -urpN busybox-1.17.1/shell/ash.c busybox-1.17.1-shell/shell/ash.c
---- busybox-1.17.1/shell/ash.c 2010-07-25 00:12:43.000000000 +0200
-+++ busybox-1.17.1-shell/shell/ash.c 2010-07-25 13:09:32.000000000 +0200
-@@ -4515,6 +4515,7 @@ clear_traps(void)
- INT_ON;
- }
- }
-+ may_have_traps = 0;
- }
-
- /* Lives far away from here, needed for forkchild */
-diff -urpN busybox-1.17.1/shell/ash_test/ash-signals/signal7.right busybox-1.17.1-shell/shell/ash_test/ash-signals/signal7.right
---- busybox-1.17.1/shell/ash_test/ash-signals/signal7.right 1970-01-01 01:00:00.000000000 +0100
-+++ busybox-1.17.1-shell/shell/ash_test/ash-signals/signal7.right 2010-07-25 13:09:32.000000000 +0200
-@@ -0,0 +1 @@
-+Bug detected: 0
-diff -urpN busybox-1.17.1/shell/ash_test/ash-signals/signal7.tests busybox-1.17.1-shell/shell/ash_test/ash-signals/signal7.tests
---- busybox-1.17.1/shell/ash_test/ash-signals/signal7.tests 1970-01-01 01:00:00.000000000 +0100
-+++ busybox-1.17.1-shell/shell/ash_test/ash-signals/signal7.tests 2010-07-25 13:09:32.000000000 +0200
-@@ -0,0 +1,18 @@
-+bug() {
-+ trap : exit
-+ # Bug was causing sh to be run in subshell,
-+ # as if this line is replaced with (sh -c ...; exit $?) &
-+ # here:
-+ sh -c 'echo REAL_CHILD=$$' &
-+ echo PARENTS_IDEA_OF_CHILD=$!
-+ wait # make sure bkgd shell completes
-+}
-+
-+bug | {
-+while read varval; do
-+ eval $varval
-+done
-+test x"$REAL_CHILD" != x"" \
-+&& test x"$REAL_CHILD" = x"$PARENTS_IDEA_OF_CHILD"
-+echo "Bug detected: $?"
-+}
-diff -urpN busybox-1.17.1/shell/hush.c busybox-1.17.1-shell/shell/hush.c
---- busybox-1.17.1/shell/hush.c 2010-07-25 00:12:43.000000000 +0200
-+++ busybox-1.17.1-shell/shell/hush.c 2010-07-25 13:09:32.000000000 +0200
-@@ -3901,8 +3901,6 @@ static void insert_bg_job(struct pipe *p
-
- if (G_interactive_fd)
- printf("[%d] %d %s\n", job->jobid, job->cmds[0].pid, job->cmdtext);
-- /* Last command's pid goes to $! */
-- G.last_bg_pid = job->cmds[job->num_cmds - 1].pid;
- G.last_jobid = job->jobid;
- }
-
-@@ -4825,6 +4823,8 @@ static int run_list(struct pipe *pi)
- if (G.run_list_level == 1)
- insert_bg_job(pi);
- #endif
-+ /* Last command's pid goes to $! */
-+ G.last_bg_pid = pi->cmds[pi->num_cmds - 1].pid;
- G.last_exitcode = rcode = EXIT_SUCCESS;
- debug_printf_exec(": cmd&: exitcode EXIT_SUCCESS\n");
- } else {
-diff -urpN busybox-1.17.1/shell/hush_test/hush-trap/signal7.right busybox-1.17.1-shell/shell/hush_test/hush-trap/signal7.right
---- busybox-1.17.1/shell/hush_test/hush-trap/signal7.right 1970-01-01 01:00:00.000000000 +0100
-+++ busybox-1.17.1-shell/shell/hush_test/hush-trap/signal7.right 2010-07-25 13:09:32.000000000 +0200
-@@ -0,0 +1 @@
-+Bug detected: 0
-diff -urpN busybox-1.17.1/shell/hush_test/hush-trap/signal7.tests busybox-1.17.1-shell/shell/hush_test/hush-trap/signal7.tests
---- busybox-1.17.1/shell/hush_test/hush-trap/signal7.tests 1970-01-01 01:00:00.000000000 +0100
-+++ busybox-1.17.1-shell/shell/hush_test/hush-trap/signal7.tests 2010-07-25 13:09:32.000000000 +0200
-@@ -0,0 +1,18 @@
-+bug() {
-+ trap : exit
-+ # Bug was causing sh to be run in subshell,
-+ # as if this line is replaced with (sh -c ...; exit $?) &
-+ # here:
-+ sh -c 'echo REAL_CHILD=$$' &
-+ echo PARENTS_IDEA_OF_CHILD=$!
-+ wait # make sure bkgd shell completes
-+}
-+
-+bug | {
-+while read varval; do
-+ eval $varval
-+done
-+test x"$REAL_CHILD" != x"" \
-+&& test x"$REAL_CHILD" = x"$PARENTS_IDEA_OF_CHILD"
-+echo "Bug detected: $?"
-+}
-diff -urpN busybox-1.17.1/shell/shell_common.c busybox-1.17.1-shell/shell/shell_common.c
---- busybox-1.17.1/shell/shell_common.c 2010-07-06 04:25:54.000000000 +0200
-+++ busybox-1.17.1-shell/shell/shell_common.c 2010-07-27 08:41:43.000000000 +0200
-@@ -428,9 +428,14 @@ shell_builtin_ulimit(char **argv)
- val <<= l->factor_shift;
- }
- //bb_error_msg("opt %c val_str:'%s' val:%lld", opt_char, val_str, (long long)val);
-+ /* from man bash: "If neither -H nor -S
-+ * is specified, both the soft and hard
-+ * limits are set. */
-+ if (!opts)
-+ opts = OPT_hard + OPT_soft;
- if (opts & OPT_hard)
- limit.rlim_max = val;
-- if ((opts & OPT_soft) || opts == 0)
-+ if (opts & OPT_soft)
- limit.rlim_cur = val;
- //bb_error_msg("setrlimit(%d, %lld, %lld)", l->cmd, (long long)limit.rlim_cur, (long long)limit.rlim_max);
- if (setrlimit(l->cmd, &limit) < 0) {