summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-07-24 06:19:29 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-07-24 06:19:29 +0000
commit7b77b45b3b64d49f56334665b941572d4dc0f613 (patch)
tree35d40df40b2000ce0a15bb48a955d17754d5464f /sys-apps
parentNew version (diff)
downloadgentoo-2-7b77b45b3b64d49f56334665b941572d4dc0f613.tar.gz
gentoo-2-7b77b45b3b64d49f56334665b941572d4dc0f613.tar.bz2
gentoo-2-7b77b45b3b64d49f56334665b941572d4dc0f613.zip
New version
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/util-linux/ChangeLog7
-rw-r--r--sys-apps/util-linux/Manifest4
-rw-r--r--sys-apps/util-linux/files/digest-util-linux-2.122
-rw-r--r--sys-apps/util-linux/util-linux-2.12.ebuild114
4 files changed, 124 insertions, 3 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index 107ea713e828..ca2a0210bb2b 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/util-linux
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.50 2003/07/21 11:15:59 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.51 2003/07/24 06:19:08 azarah Exp $
+
+*util-linux-2.12 (24 Jul 2003)
+
+ 24 Jul 2003; Martin Schlemmer <azarah@gentoo.org> util-linux-2.12.ebuild:
+ New version, bug #24880.
21 Jul 2003; <solar@gentoo.org> util-linux-2.11z-r7.ebuild:
verified -fPIC works with this pkg on x86, sparc64, ppc and hppa
diff --git a/sys-apps/util-linux/Manifest b/sys-apps/util-linux/Manifest
index c6a1cb4925dd..35145ae7ad44 100644
--- a/sys-apps/util-linux/Manifest
+++ b/sys-apps/util-linux/Manifest
@@ -1,8 +1,8 @@
-MD5 f4c06446879a02f384454ec485e549c8 ChangeLog 8174
+MD5 c5f819b71fb8c1634af57caca148b754 ChangeLog 8311
MD5 c6692828888581ffce700c60c14ea9b8 util-linux-2.11z-r5.ebuild 2776
MD5 64dd00d9b5bf0874da357a4e8c0203b2 util-linux-2.11z-r6.ebuild 3145
MD5 a29d38eb88686e730cef4334a02ebcbf util-linux-2.11z-r7.ebuild 3325
-MD5 c4d2951a57f78ade2fa3c821dacf407c util-linux-2.12.ebuild 3408
+MD5 63e12a1874feaf734c5d1d17ba4edab7 util-linux-2.12.ebuild 3058
MD5 fdc6f7ebf1e7f279d96f19c330868aa2 util-linux-2.11y.ebuild 2109
MD5 b73abbe53ce7a49cad81cc855b7d5924 util-linux-2.11z-r4.ebuild 2410
MD5 02afa4d774f45ab0b9ef42ecc1748005 files/digest-util-linux-2.11z-r5 153
diff --git a/sys-apps/util-linux/files/digest-util-linux-2.12 b/sys-apps/util-linux/files/digest-util-linux-2.12
new file mode 100644
index 000000000000..1d6f1c06a55d
--- /dev/null
+++ b/sys-apps/util-linux/files/digest-util-linux-2.12
@@ -0,0 +1,2 @@
+MD5 997adf78b98d9d1c5db4f37ea982acff util-linux-2.12.tar.gz 1857871
+MD5 9d6c4c8a99188b6696b0735fa48f67c2 util-linux-2.11z-crypt-gentoo.patch.bz2 18249
diff --git a/sys-apps/util-linux/util-linux-2.12.ebuild b/sys-apps/util-linux/util-linux-2.12.ebuild
new file mode 100644
index 000000000000..1481b7fa236d
--- /dev/null
+++ b/sys-apps/util-linux/util-linux-2.12.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12.ebuild,v 1.1 2003/07/24 06:19:08 azarah Exp $
+
+IUSE="crypt nls static pam"
+
+inherit eutils flag-o-matic
+
+## see below for details on pic.patch
+case ${ARCH} in
+ "x86"|"hppa"|"sparc"|"ppc")
+ ;;
+ *)
+ filter-flags -fPIC
+ ;;
+esac
+
+S="${WORKDIR}/${P}"
+CRYPT_PATCH_P="${PN}-2.11z-crypt-gentoo"
+DESCRIPTION="Various useful Linux utilities"
+SRC_URI="mirror://kernel/linux/utils/${PN}/${P}.tar.gz
+ ftp://ftp.cwi.nl/pub/aeb/${PN}/${P}.tar.gz
+ crypt? ( mirror://gentoo/${CRYPT_PATCH_P}.patch.bz2 )"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
+
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~arm ~mips ~hppa"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ >=sys-apps/sed-4.0.5
+ >=sys-libs/ncurses-5.2-r2
+ pam? ( sys-apps/pam-login )"
+
+RDEPEND="${DEPEND} dev-lang/perl
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+# if [ ! -z "`use crypt`" ] ; then
+# epatch ${DISTDIR}/${CRYPT_PATCH_P}.patch.bz2
+# fi
+
+ # Fix rare failures with -j4 or higher
+ epatch ${FILESDIR}/${PN}-2.11z-parallel-make.patch
+
+ # Fix unreadable df output
+ epatch ${FILESDIR}/no-symlink-resolve.patch
+
+ # Add the O option to agetty to display DNS domainname in the issue
+ # file, thanks to Marius Mauch <genone@genone.de>, bug #22275.
+ #
+ # NOTE: Removing this will break future baselayout, so PLEASE
+ # consult with me before doing so.
+ #
+ # <azarah@gentoo.og> (17 Jul 2003)
+ epatch ${FILESDIR}/${PN}-2.11z-agetty-domainname-option.patch
+
+ # Add NFS4 support (kernel 2.5/2.6).
+# if [ ! -z "`use crypt`" ] ; then
+# epatch ${FILESDIR}/${PN}-2.11z-01-nfsv4-crypt.dif
+# else
+ epatch ${FILESDIR}/${PN}-2.11z-01-nfsv4.dif
+# fi
+
+ # <solar@gentoo.org> This patch should allow us to remove -fPIC
+ # out of the filter-flags we need this be able to emit position
+ # independent code so we can link our elf executables as shared
+ # objects. "prelink" should now also be able to take advantage
+ epatch ${FILESDIR}/${PN}-2.11z-pic.patch
+
+ #enable pam only if we use it
+ use pam && sed -i "s:HAVE_PAM=no:HAVE_PAM=yes:" MCONFIG
+
+ sed -i \
+ -e "s:-pipe -O2 \$(CPUOPT) -fomit-frame-pointer:${CFLAGS}:" \
+ -e "s:CPU=.*:CPU=${CHOST%%-*}:" \
+ -e "s:HAVE_SLN=no:HAVE_SLN=yes:" \
+ -e "s:HAVE_TSORT=no:HAVE_TSORT=yes:" \
+ -e "s:usr/man:usr/share/man:" \
+ -e "s:usr/info:usr/share/info:" \
+ -e "s:SUIDMODE=.*4755:SUIDMODE=4711:" \
+ MCONFIG || die "MCONFIG sed"
+
+ if [ -z "`use nls`" ] ; then
+ sed -i -e 's/DISABLE_NLS=no/DISABLE_NLS=yes/' MCONFIG ||
+ die "MCONFIG nls sed"
+ fi
+}
+
+src_compile() {
+
+ econf || die "configure failed"
+
+ if [ "`use static`" ] ; then
+ export LDFLAGS=-static
+ fi
+ emake || die "emake failed"
+ cd sys-utils && makeinfo *.texi || die "makeinfo failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+
+ dodoc HISTORY MAINTAINER README VERSION
+ docinto licenses
+ dodoc licenses/* HISTORY
+ docinto examples
+ dodoc example.files/*
+}
+