summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-11-23 15:02:44 +0000
committerMike Frysinger <vapier@gentoo.org>2008-11-23 15:02:44 +0000
commit7c5e440daa3a7daa7684567392113f659e7457cd (patch)
tree0d1b0b46970528b69dfa6c8463933db98d018c6d /sys-apps
parentManifest fix. (diff)
downloadgentoo-2-7c5e440daa3a7daa7684567392113f659e7457cd.tar.gz
gentoo-2-7c5e440daa3a7daa7684567392113f659e7457cd.tar.bz2
gentoo-2-7c5e440daa3a7daa7684567392113f659e7457cd.zip
make option setting a bit more readable and disable a few more daemons
(Portage version: 2.2_rc14/cvs/Linux 2.6.27.4 x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/busybox/busybox-1.12.2-r1.ebuild23
1 files changed, 17 insertions, 6 deletions
diff --git a/sys-apps/busybox/busybox-1.12.2-r1.ebuild b/sys-apps/busybox/busybox-1.12.2-r1.ebuild
index 9c2b3b54f3a1..e3fd32c1eed6 100644
--- a/sys-apps/busybox/busybox-1.12.2-r1.ebuild
+++ b/sys-apps/busybox/busybox-1.12.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.12.2-r1.ebuild,v 1.1 2008/11/21 00:14:05 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.12.2-r1.ebuild,v 1.2 2008/11/23 15:02:44 vapier Exp $
inherit eutils flag-o-matic savedconfig toolchain-funcs
@@ -75,7 +75,7 @@ busybox_config_option() {
return 0
;;
esac
- einfo $(grep "CONFIG_$2[= ]" .config)
+ einfo $(grep "CONFIG_$2[= ]" .config || echo Could not find CONFIG_$2 ...)
}
src_unpack() {
@@ -147,10 +147,21 @@ src_unpack() {
busybox_config_option selinux SELINUX
# default a bunch of uncommon options to off
- for opt in LOCALE_SUPPORT TFTP FTP{GET,PUT} IPCALC TFTP HUSH \
- LASH MSH INETD DPKG RPM2CPIO RPM FOLD LOGNAME OD CRONTAB \
- UUDECODE UUENCODE SULOGIN DC DEBUG_YANK_SUSv2 DEBUG_INIT \
- DEBUG_CROND_OPTION FEATURE_UDHCP_DEBUG TASKSET INOTIFYD
+ local opt
+ for opt in \
+ APP_UDHCPD \
+ CRONTAB \
+ DC DEBUG_CROND_OPTION DEBUG_INIT DPKG \
+ FAKEIDENTD FBSPLASH FEATURE_UDHCP_DEBUG FOLD FTP{GET,PUT} \
+ HTTPD HUSH \
+ INETD INOTIFYD IPCALC \
+ LASH LOCALE_SUPPORT LOGNAME \
+ MSH \
+ OD \
+ SULOGIN \
+ TASKSET TFTP{,D} \
+ RPM RPM2CPIO \
+ UDPSVD UUDECODE UUENCODE
do
busybox_config_option n ${opt}
done