summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-08-07 22:49:56 +0000
committerTim Harder <radhermit@gentoo.org>2013-08-07 22:49:56 +0000
commit8aecf6f91713e192e35b162086629e0383088e4c (patch)
tree526e68d1489c502ebe0f5904e9bebfd9d107d3aa /sys-apps
parentRevert masking app-arch/xz-utils. It is not part of emul-linux, actually. (diff)
downloadgentoo-2-8aecf6f91713e192e35b162086629e0383088e4c.tar.gz
gentoo-2-8aecf6f91713e192e35b162086629e0383088e4c.tar.bz2
gentoo-2-8aecf6f91713e192e35b162086629e0383088e4c.zip
Update live ebuild.
(Portage version: 2.2.0_alpha194/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/util-linux/ChangeLog5
-rw-r--r--sys-apps/util-linux/util-linux-9999.ebuild46
2 files changed, 27 insertions, 24 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index d12155071a31..c5ce03d63ac2 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/util-linux
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.434 2013/08/07 22:40:04 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.435 2013/08/07 22:49:56 radhermit Exp $
+
+ 07 Aug 2013; Tim Harder <radhermit@gentoo.org> util-linux-9999.ebuild:
+ Update live ebuild.
*util-linux-2.23.2 (07 Aug 2013)
diff --git a/sys-apps/util-linux/util-linux-9999.ebuild b/sys-apps/util-linux/util-linux-9999.ebuild
index 6a601bc9a15d..91933ef91f51 100644
--- a/sys-apps/util-linux/util-linux-9999.ebuild
+++ b/sys-apps/util-linux/util-linux-9999.ebuild
@@ -1,30 +1,24 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-9999.ebuild,v 1.45 2013/07/16 01:23:22 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-9999.ebuild,v 1.46 2013/08/07 22:49:56 radhermit Exp $
-EAPI="3"
-
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux/util-linux.git"
+EAPI="4"
inherit eutils toolchain-funcs libtool flag-o-matic bash-completion-r1
-if [[ ${PV} == "9999" ]] ; then
- inherit git-2 autotools
- #KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
-fi
MY_PV=${PV/_/-}
MY_P=${PN}-${MY_PV}
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="Various useful Linux utilities"
-HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
-if [[ ${PV} == "9999" ]] ; then
- SRC_URI=""
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-2 autotools
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux/util-linux.git"
else
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
SRC_URI="mirror://kernel/linux/utils/util-linux/v${PV:0:4}/${MY_P}.tar.xz"
fi
+DESCRIPTION="Various useful Linux utilities"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
+
LICENSE="GPL-2 GPL-3 LGPL-2.1 BSD-4 MIT public-domain"
SLOT="0"
IUSE="bash-completion caps +cramfs cytune fdformat ncurses nls old-linux selinux slang static-libs +suid test tty-helpers udev unicode"
@@ -43,12 +37,15 @@ RDEPEND="!sys-process/schedutils
slang? ( sys-libs/slang )
udev? ( virtual/udev )"
DEPEND="${RDEPEND}
+ virtual/pkgconfig
nls? ( sys-devel/gettext )
test? ( sys-devel/bc )
virtual/os-headers"
+S=${WORKDIR}/${MY_P}
+
src_prepare() {
- if [[ ${PV} == "9999" ]] ; then
+ if [[ ${PV} == 9999 ]] ; then
po/update-potfiles
eautoreconf
fi
@@ -58,9 +55,9 @@ src_prepare() {
lfs_fallocate_test() {
# Make sure we can use fallocate with LFS #300307
cat <<-EOF > "${T}"/fallocate.c
- #define _GNU_SOURCE
- #include <fcntl.h>
- main() { return fallocate(0, 0, 0, 0); }
+ #define _GNU_SOURCE
+ #include <fcntl.h>
+ main() { return fallocate(0, 0, 0, 0); }
EOF
append-lfs-flags
$(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} "${T}"/fallocate.c -o /dev/null >/dev/null 2>&1 \
@@ -104,16 +101,19 @@ src_configure() {
}
src_install() {
- emake install DESTDIR="${D}" || die
+ default
dodoc AUTHORS NEWS README* Documentation/{TODO,*.txt,releases/*}
# need the libs in /
gen_usr_ldscript -a blkid mount uuid
+
# e2fsprogs-libs didnt install .la files, and .pc work fine
- find "${ED}" -name '*.la' -delete
+ prune_libtool_files
}
pkg_postinst() {
- elog "The agetty util now clears the terminal by default. You"
- elog "might want to add --noclear to your /etc/inittab lines."
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "The agetty util now clears the terminal by default. You"
+ elog "might want to add --noclear to your /etc/inittab lines."
+ fi
}