summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2010-02-10 00:49:49 +0000
committerZac Medico <zmedico@gentoo.org>2010-02-10 00:49:49 +0000
commit9581e79d412450ad9e93030873080b712c6f461b (patch)
tree59e2a121c8a7527cb88aa3ac906ab7f94ba97948 /sys-apps
parentTouchup ebuild. (diff)
downloadgentoo-2-9581e79d412450ad9e93030873080b712c6f461b.tar.gz
gentoo-2-9581e79d412450ad9e93030873080b712c6f461b.tar.bz2
gentoo-2-9581e79d412450ad9e93030873080b712c6f461b.zip
Bug #303211 - Add a ewarn message for people upgrading with PORTAGE_BINHOST set.
(Portage version: 2.2_rc62_p15331/cvs/Linux i686)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/portage/ChangeLog7
-rw-r--r--sys-apps/portage/portage-2.1.7.16.ebuild21
-rw-r--r--sys-apps/portage/portage-2.1.7.17.ebuild21
3 files changed, 46 insertions, 3 deletions
diff --git a/sys-apps/portage/ChangeLog b/sys-apps/portage/ChangeLog
index b2adba195a3a..d04e17a5cb99 100644
--- a/sys-apps/portage/ChangeLog
+++ b/sys-apps/portage/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/portage
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.670 2010/02/07 02:11:42 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.671 2010/02/10 00:49:49 zmedico Exp $
+
+ 10 Feb 2010; Zac Medico <zmedico@gentoo.org> portage-2.1.7.16.ebuild,
+ portage-2.1.7.17.ebuild:
+ Bug #303211 - Add a ewarn message for people upgrading with
+ PORTAGE_BINHOST set.
07 Feb 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
portage-2.1.7.17.ebuild, portage-2.2_rc62.ebuild:
diff --git a/sys-apps/portage/portage-2.1.7.16.ebuild b/sys-apps/portage/portage-2.1.7.16.ebuild
index 5e822ce3a38a..5486ae71577e 100644
--- a/sys-apps/portage/portage-2.1.7.16.ebuild
+++ b/sys-apps/portage/portage-2.1.7.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.7.16.ebuild,v 1.6 2010/01/26 16:16:03 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.7.16.ebuild,v 1.7 2010/02/10 00:49:49 zmedico Exp $
# Require EAPI 2 since we now require at least python-2.6 (for python 3
# syntax support) which also requires EAPI 2.
@@ -269,6 +269,8 @@ pkg_preinst() {
[[ -n $PORTDIR_OVERLAY ]] && has_version "<${CATEGORY}/${PN}-2.1.6.12"
REPO_LAYOUT_CONF_WARN=$?
+ has_version "<${CATEGORY}/${PN}-2.1.7"
+ UPGRADE_FROM_2_1=$?
}
pkg_postinst() {
@@ -276,6 +278,7 @@ pkg_postinst() {
# will be identified and removed in postrm.
python_mod_optimize /usr/$(get_libdir)/portage/pym
+ local warning_shown=0
if [ $REPO_LAYOUT_CONF_WARN = 0 ] ; then
ewarn
echo "If you want overlay eclasses to override eclasses from" \
@@ -283,7 +286,23 @@ pkg_postinst() {
"for information about the new layout.conf and repos.conf" \
"configuration files." \
| fmt -w 75 | while read -r ; do ewarn "$REPLY" ; done
+ fi
+ if [[ $UPGRADE_FROM_2_1 = 0 && -n $PORTAGE_BINHOST ]] ; then
ewarn
+ echo "If you have an old PORTAGE_BINHOST setting in /etc/make.conf" \
+ "then you will encounter bug #303211. Therefore, please ensure" \
+ "that your PORTAGE_BINHOST setting points to a remote directory" \
+ "containing a \$PKGDIR/Packages file which is created by" \
+ ">=portage-2.1.6. If \$PKGDIR/Packages does not exist on" \
+ "the server or it is incomplete, you must run \`emaint" \
+ "--fix binhost\` on the server in order to generate it." \
+ "See \`man make.conf\` for more information about" \
+ "PORTAGE_BINHOST." | \
+ fmt -w 70 | while read -r ; do ewarn "$REPLY" ; done
+ warning_shown=1
+ fi
+ if [ $warning_shown = 1 ] ; then
+ ewarn # for symmetry
fi
einfo
diff --git a/sys-apps/portage/portage-2.1.7.17.ebuild b/sys-apps/portage/portage-2.1.7.17.ebuild
index 1bfe0112a8f1..a3a7aa5be2cb 100644
--- a/sys-apps/portage/portage-2.1.7.17.ebuild
+++ b/sys-apps/portage/portage-2.1.7.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.7.17.ebuild,v 1.2 2010/02/07 02:11:42 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.7.17.ebuild,v 1.3 2010/02/10 00:49:49 zmedico Exp $
# Require EAPI 2 since we now require at least python-2.6 (for python 3
# syntax support) which also requires EAPI 2.
@@ -273,6 +273,8 @@ pkg_preinst() {
[[ -n $PORTDIR_OVERLAY ]] && has_version "<${CATEGORY}/${PN}-2.1.6.12"
REPO_LAYOUT_CONF_WARN=$?
+ has_version "<${CATEGORY}/${PN}-2.1.7"
+ UPGRADE_FROM_2_1=$?
}
pkg_postinst() {
@@ -280,6 +282,7 @@ pkg_postinst() {
# will be identified and removed in postrm.
python_mod_optimize /usr/$(get_libdir)/portage/pym
+ local warning_shown=0
if [ $REPO_LAYOUT_CONF_WARN = 0 ] ; then
ewarn
echo "If you want overlay eclasses to override eclasses from" \
@@ -287,7 +290,23 @@ pkg_postinst() {
"for information about the new layout.conf and repos.conf" \
"configuration files." \
| fmt -w 75 | while read -r ; do ewarn "$REPLY" ; done
+ fi
+ if [[ $UPGRADE_FROM_2_1 = 0 && -n $PORTAGE_BINHOST ]] ; then
ewarn
+ echo "If you have an old PORTAGE_BINHOST setting in /etc/make.conf" \
+ "then you will encounter bug #303211. Therefore, please ensure" \
+ "that your PORTAGE_BINHOST setting points to a remote directory" \
+ "containing a \$PKGDIR/Packages file which is created by" \
+ ">=portage-2.1.6. If \$PKGDIR/Packages does not exist on" \
+ "the server or it is incomplete, you must run \`emaint" \
+ "--fix binhost\` on the server in order to generate it." \
+ "See \`man make.conf\` for more information about" \
+ "PORTAGE_BINHOST." | \
+ fmt -w 70 | while read -r ; do ewarn "$REPLY" ; done
+ warning_shown=1
+ fi
+ if [ $warning_shown = 1 ] ; then
+ ewarn # for symmetry
fi
einfo