summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Rothe <corsair@gentoo.org>2006-06-28 06:52:04 +0000
committerMarkus Rothe <corsair@gentoo.org>2006-06-28 06:52:04 +0000
commit96ee9ca4a8d59166a36bf3c3156e888479f2bd01 (patch)
treede1ef53063838f219cf1a2ca1f5dbda20986f308 /sys-apps
parentLayman-1.0.4 fixes the relocation check. (diff)
downloadgentoo-2-96ee9ca4a8d59166a36bf3c3156e888479f2bd01.tar.gz
gentoo-2-96ee9ca4a8d59166a36bf3c3156e888479f2bd01.tar.bz2
gentoo-2-96ee9ca4a8d59166a36bf3c3156e888479f2bd01.zip
Added tgall's diff to newer versions, too
(Portage version: 2.1-r1)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/busybox/ChangeLog6
-rw-r--r--sys-apps/busybox/busybox-1.1.1.ebuild3
-rw-r--r--sys-apps/busybox/busybox-1.1.2.ebuild3
-rw-r--r--sys-apps/busybox/busybox-1.1.3.ebuild3
4 files changed, 11 insertions, 4 deletions
diff --git a/sys-apps/busybox/ChangeLog b/sys-apps/busybox/ChangeLog
index 48e3ab367fca..6a0f0c8782b2 100644
--- a/sys-apps/busybox/ChangeLog
+++ b/sys-apps/busybox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/busybox
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.91 2006/06/28 03:33:18 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.92 2006/06/28 06:52:04 corsair Exp $
+
+ 28 Jun 2006; Markus Rothe <corsair@gentoo.org> busybox-1.1.1.ebuild,
+ busybox-1.1.2.ebuild, busybox-1.1.3.ebuild:
+ Added tgall's diff to newer versions, too
27 June 2006; Tom Gall <tgall@gentoo.org> busybox-1.1.0.ebuild:
- add -mminimal-toc to fix static builds against glibc
diff --git a/sys-apps/busybox/busybox-1.1.1.ebuild b/sys-apps/busybox/busybox-1.1.1.ebuild
index 8fcf5989e593..0efda5fc3ab6 100644
--- a/sys-apps/busybox/busybox-1.1.1.ebuild
+++ b/sys-apps/busybox/busybox-1.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.1.1.ebuild,v 1.4 2006/04/10 03:18:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.1.1.ebuild,v 1.5 2006/06/28 06:52:04 corsair Exp $
inherit eutils
@@ -127,6 +127,7 @@ src_unpack() {
src_compile() {
busybox_set_env
+ use ppc64 && CFLAGS="${CFLAGS} -mminimal-toc"
emake CROSS="${CROSS}" busybox || die "build failed"
if ! use static ; then
mv busybox_unstripped{,.bak}
diff --git a/sys-apps/busybox/busybox-1.1.2.ebuild b/sys-apps/busybox/busybox-1.1.2.ebuild
index 73925eb0593a..9537d917d7b6 100644
--- a/sys-apps/busybox/busybox-1.1.2.ebuild
+++ b/sys-apps/busybox/busybox-1.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.1.2.ebuild,v 1.2 2006/04/26 05:15:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.1.2.ebuild,v 1.3 2006/06/28 06:52:04 corsair Exp $
inherit eutils
@@ -126,6 +126,7 @@ src_unpack() {
src_compile() {
busybox_set_env
+ use ppc64 && CFLAGS="${CFLAGS} -mminimal-toc"
emake CROSS="${CROSS}" busybox || die "build failed"
if ! use static ; then
mv busybox_unstripped{,.bak}
diff --git a/sys-apps/busybox/busybox-1.1.3.ebuild b/sys-apps/busybox/busybox-1.1.3.ebuild
index 195367de1371..ba500ffac1b0 100644
--- a/sys-apps/busybox/busybox-1.1.3.ebuild
+++ b/sys-apps/busybox/busybox-1.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.1.3.ebuild,v 1.1 2006/05/18 11:47:15 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.1.3.ebuild,v 1.2 2006/06/28 06:52:04 corsair Exp $
inherit eutils
@@ -126,6 +126,7 @@ src_unpack() {
src_compile() {
busybox_set_env
+ use ppc64 && CFLAGS="${CFLAGS} -mminimal-toc"
emake CROSS="${CROSS}" busybox || die "build failed"
if ! use static ; then
mv busybox_unstripped{,.bak}