summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-09-30 01:18:25 +0000
committerDonny Davies <woodchip@gentoo.org>2002-09-30 01:18:25 +0000
commit9f083d77fd507bfe755b1cc0117ffced10087fd9 (patch)
treee0ab83e90ccdc9e2bb9cb8e9856b59459d73e875 /sys-apps
parentuse mount-boot eclass; #7903 (diff)
downloadgentoo-2-9f083d77fd507bfe755b1cc0117ffced10087fd9.tar.gz
gentoo-2-9f083d77fd507bfe755b1cc0117ffced10087fd9.tar.bz2
gentoo-2-9f083d77fd507bfe755b1cc0117ffced10087fd9.zip
nuke old pkg_setup junk
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/lilo/lilo-21.7.5-r2.ebuild33
-rw-r--r--sys-apps/lilo/lilo-22.1-r3.ebuild33
-rw-r--r--sys-apps/lilo/lilo-22.3.3.ebuild37
3 files changed, 9 insertions, 94 deletions
diff --git a/sys-apps/lilo/lilo-21.7.5-r2.ebuild b/sys-apps/lilo/lilo-21.7.5-r2.ebuild
index 8c2568bd0f31..b69b59208b1f 100644
--- a/sys-apps/lilo/lilo-21.7.5-r2.ebuild
+++ b/sys-apps/lilo/lilo-21.7.5-r2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/lilo-21.7.5-r2.ebuild,v 1.4 2002/07/20 19:01:50 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/lilo-21.7.5-r2.ebuild,v 1.5 2002/09/30 01:18:25 woodchip Exp $
+
+inherit mount-boot
#
# This lilo has the Suse animated bootlogo patches.. fun!
@@ -16,35 +18,6 @@ LICENSE="BSD"
DEPEND="virtual/glibc >=sys-devel/bin86-0.15.5"
RDEPEND="virtual/glibc"
-pkg_setup() {
- [ "${ROOT}" != "/" ] && return 0
- . ${ROOT}/etc/init.d/functions.sh
- local fstabstate="$(cat /etc/fstab |grep -v -e '#' |awk '{print $2}')"
- local procstate="$(cat /proc/mounts |awk '{print $2}')"
- if [ -n "$(echo ${fstabstate} |grep -e "/boot")" ] && \
- [ -n "$(echo ${procstate} |grep -e "/boot")" ]
- then
- einfo "Your boot partition was detected as being mounted as /boot."
- einfo "Files will be installed there for lilo to function correctly."
- elif [ -n "$(echo ${fstabstate} |grep -e "/boot")" ] && \
- [ -z "$(echo ${procstate} |grep -e "/boot")" ]
- then
- mount /boot &>/dev/null
- if [ "$?" -eq 0 ]
- then
- einfo "Your boot partition was not mounted as /boot, but portage was able to mount"
- einfo "it without additional intervention."
- einfo "Files will be installed there for lilo to function correctly."
- else
- eerror "Your boot partition has to be mounted on /boot before the installation"
- eerror "can continue. Lilo needs to install important files there."
- die "Please mount your /boot partition."
- fi
- else
- einfo "You do not have a seperate /boot partition."
- fi
-}
-
src_unpack() {
unpack ${A} ; cd ${S}
diff --git a/sys-apps/lilo/lilo-22.1-r3.ebuild b/sys-apps/lilo/lilo-22.1-r3.ebuild
index 68f60a6b909a..a008d3e2539b 100644
--- a/sys-apps/lilo/lilo-22.1-r3.ebuild
+++ b/sys-apps/lilo/lilo-22.1-r3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/lilo-22.1-r3.ebuild,v 1.6 2002/07/20 19:01:50 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/lilo-22.1-r3.ebuild,v 1.7 2002/09/30 01:18:25 woodchip Exp $
+
+inherit mount-boot
S=${WORKDIR}/${P}
DESCRIPTION="Standard Linux boot loader"
@@ -13,35 +15,6 @@ DEPEND="virtual/glibc >=sys-devel/bin86-0.15.5"
RDEPEND="virtual/glibc"
-pkg_setup() {
- [ "${ROOT}" != "/" ] && return 0
- . ${ROOT}/etc/init.d/functions.sh
- local fstabstate="$(cat /etc/fstab |grep -v -e '#' |awk '{print $2}')"
- local procstate="$(cat /proc/mounts |awk '{print $2}')"
- if [ -n "$(echo ${fstabstate} |grep -e "/boot")" ] && \
- [ -n "$(echo ${procstate} |grep -e "/boot")" ]
- then
- einfo "Your boot partition was detected as being mounted as /boot."
- einfo "Files will be installed there for lilo to function correctly."
- elif [ -n "$(echo ${fstabstate} |grep -e "/boot")" ] && \
- [ -z "$(echo ${procstate} |grep -e "/boot")" ]
- then
- mount /boot &>/dev/null
- if [ "$?" -eq 0 ]
- then
- einfo "Your boot partition was not mounted as /boot, but portage was able to mount"
- einfo "it without additional intervention."
- einfo "Files will be installed there for lilo to function correctly."
- else
- eerror "Your boot partition has to be mounted on /boot before the installation"
- eerror "can continue. Lilo needs to install important files there."
- die "Please mount your /boot partition."
- fi
- else
- einfo "You do not have a seperate /boot partition."
- fi
-}
-
src_unpack() {
unpack ${A}
cd ${S}
diff --git a/sys-apps/lilo/lilo-22.3.3.ebuild b/sys-apps/lilo/lilo-22.3.3.ebuild
index ab7cfed531d8..011805b3f55a 100644
--- a/sys-apps/lilo/lilo-22.3.3.ebuild
+++ b/sys-apps/lilo/lilo-22.3.3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/lilo-22.3.3.ebuild,v 1.1 2002/09/03 00:08:10 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/lilo-22.3.3.ebuild,v 1.2 2002/09/30 01:18:25 woodchip Exp $
+
+inherit mount-boot
S=${WORKDIR}/${P}
DESCRIPTION="Standard Linux boot loader"
@@ -17,39 +19,6 @@ DEPEND="virtual/glibc
RDEPEND="virtual/glibc"
-pkg_setup() {
-
- [ "${ROOT}" != "/" ] && return 0
-
- local fstabstate="$(cat /etc/fstab | awk '!/^#|^\t+#/ {print $2}')"
- local procstate="$(cat /proc/mounts | awk '{print $2}')"
-
- if [ -n "$(echo ${fstabstate} | egrep "/boot")" ] && \
- [ -n "$(echo ${procstate} | egrep "/boot")" ]
- then
- einfo "Your boot partition was detected as being mounted as /boot."
- einfo "Files will be installed there for lilo to function correctly."
-
- elif [ -n "$(echo ${fstabstate} | egrep "/boot")" ] && \
- [ -z "$(echo ${procstate} | egrep "/boot")" ]
- then
- mount /boot &>/dev/null
-
- if [ "$?" -eq 0 ]
- then
- einfo "Your boot partition was not mounted as /boot, but portage was able to mount"
- einfo "it without additional intervention."
- einfo "Files will be installed there for lilo to function correctly."
- else
- eerror "Your boot partition has to be mounted on /boot before the installation"
- eerror "can continue. Lilo needs to install important files there."
- die "Please mount your /boot partition."
- fi
- else
- einfo "You do not have a seperate /boot partition."
- fi
-}
-
src_unpack() {
unpack ${A}