summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2013-04-04 17:45:27 +0000
committerZac Medico <zmedico@gentoo.org>2013-04-04 17:45:27 +0000
commita0d05c5c39636cd93462de8bd4fcb5181c5d3523 (patch)
treefb0b241b95daa49d93792cc1153fc3fc28d5eac4 /sys-apps
parentDrop old versions (diff)
downloadgentoo-2-a0d05c5c39636cd93462de8bd4fcb5181c5d3523.tar.gz
gentoo-2-a0d05c5c39636cd93462de8bd4fcb5181c5d3523.tar.bz2
gentoo-2-a0d05c5c39636cd93462de8bd4fcb5181c5d3523.zip
Tolerate --nodeps at beginning of stage1 for catalyst.
(Portage version: 2.2.0_alpha171/cvs/Linux i686, signed Manifest commit with key 0xFDE8EF85AE5719A3)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/portage/ChangeLog6
-rw-r--r--sys-apps/portage/portage-2.1.11.60.ebuild8
-rw-r--r--sys-apps/portage/portage-2.2.0_alpha171.ebuild8
-rw-r--r--sys-apps/portage/portage-9999.ebuild8
4 files changed, 26 insertions, 4 deletions
diff --git a/sys-apps/portage/ChangeLog b/sys-apps/portage/ChangeLog
index 98cb8e9ea9b6..ed3ad335ffc4 100644
--- a/sys-apps/portage/ChangeLog
+++ b/sys-apps/portage/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/portage
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.1244 2013/04/04 00:12:57 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.1245 2013/04/04 17:45:27 zmedico Exp $
+
+ 04 Apr 2013; Zac Medico <zmedico@gentoo.org> portage-2.1.11.60.ebuild,
+ portage-2.2.0_alpha171.ebuild, portage-9999.ebuild:
+ Tolerate --nodeps at beginning of stage1 for catalyst.
04 Apr 2013; Zac Medico <zmedico@gentoo.org> -portage-2.1.11.59.ebuild,
-portage-2.2.0_alpha170.ebuild:
diff --git a/sys-apps/portage/portage-2.1.11.60.ebuild b/sys-apps/portage/portage-2.1.11.60.ebuild
index 921c7fe64cf8..1c58e7d571e3 100644
--- a/sys-apps/portage/portage-2.1.11.60.ebuild
+++ b/sys-apps/portage/portage-2.1.11.60.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.11.60.ebuild,v 1.1 2013/04/01 18:54:33 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.11.60.ebuild,v 1.2 2013/04/04 17:45:27 zmedico Exp $
# Require EAPI 2 since we now require at least python-2.6 (for python 3
# syntax support) which also requires EAPI 2.
@@ -324,6 +324,12 @@ src_install() {
local impl files mod_dir dest_mod_dir python relative_path x
for impl in "${PYTHON_COMPAT[@]}" ; do
use "python_targets_${impl}" || continue
+ if use build && [[ ${ROOT} == / &&
+ ! -x /usr/bin/$(get_python_interpreter ${impl}) ]] ; then
+ # Tolerate --nodeps at beginning of stage1 for catalyst
+ ewarn "skipping python_targets_${impl}, interpreter not found"
+ continue
+ fi
while read -r mod_dir ; do
cd "${D}/usr/lib/portage/pym/${mod_dir}" || die
files=$(echo *.py)
diff --git a/sys-apps/portage/portage-2.2.0_alpha171.ebuild b/sys-apps/portage/portage-2.2.0_alpha171.ebuild
index c56cc993f69b..d44646802c8d 100644
--- a/sys-apps/portage/portage-2.2.0_alpha171.ebuild
+++ b/sys-apps/portage/portage-2.2.0_alpha171.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.2.0_alpha171.ebuild,v 1.1 2013/04/01 18:56:46 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.2.0_alpha171.ebuild,v 1.2 2013/04/04 17:45:27 zmedico Exp $
# Require EAPI 2 since we now require at least python-2.6 (for python 3
# syntax support) which also requires EAPI 2.
@@ -357,6 +357,12 @@ src_install() {
local impl files mod_dir dest_mod_dir python relative_path x
for impl in "${PYTHON_COMPAT[@]}" ; do
use "python_targets_${impl}" || continue
+ if use build && [[ ${ROOT} == / &&
+ ! -x ${EPREFIX}/usr/bin/$(get_python_interpreter ${impl}) ]] ; then
+ # Tolerate --nodeps at beginning of stage1 for catalyst
+ ewarn "skipping python_targets_${impl}, interpreter not found"
+ continue
+ fi
while read -r mod_dir ; do
cd "${ED}/usr/lib/portage/pym/${mod_dir}" || die
files=$(echo *.py)
diff --git a/sys-apps/portage/portage-9999.ebuild b/sys-apps/portage/portage-9999.ebuild
index 22f0fd475abb..a7690bfccc74 100644
--- a/sys-apps/portage/portage-9999.ebuild
+++ b/sys-apps/portage/portage-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-9999.ebuild,v 1.73 2013/03/26 05:17:45 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-9999.ebuild,v 1.74 2013/04/04 17:45:27 zmedico Exp $
EAPI=3
PYTHON_COMPAT=(
@@ -335,6 +335,12 @@ src_install() {
local impl files mod_dir dest_mod_dir python relative_path x
for impl in "${PYTHON_COMPAT[@]}" ; do
use "python_targets_${impl}" || continue
+ if use build && [[ ${ROOT} == / &&
+ ! -x ${EPREFIX}/usr/bin/$(get_python_interpreter ${impl}) ]] ; then
+ # Tolerate --nodeps at beginning of stage1 for catalyst
+ ewarn "skipping python_targets_${impl}, interpreter not found"
+ continue
+ fi
while read -r mod_dir ; do
cd "${ED}/usr/lib/portage/pym/${mod_dir}" || die
files=$(echo *.py)