summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-11-18 10:29:14 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-11-18 10:29:14 +0000
commita4ddc9da3e59d2f2cd5430f4ccb812f6f999cdc7 (patch)
tree832244c625f1b03d7f7bff9c76702bb3dc6b79a8 /sys-apps
parentclean up (diff)
downloadgentoo-2-a4ddc9da3e59d2f2cd5430f4ccb812f6f999cdc7.tar.gz
gentoo-2-a4ddc9da3e59d2f2cd5430f4ccb812f6f999cdc7.tar.bz2
gentoo-2-a4ddc9da3e59d2f2cd5430f4ccb812f6f999cdc7.zip
remove Bashisms from cron file, thanks to Richard Li <admin AT chys DOT info> in bug 293459
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/mlocate/ChangeLog9
-rw-r--r--sys-apps/mlocate/files/mlocate.cron-r222
-rw-r--r--sys-apps/mlocate/mlocate-0.22.2-r1.ebuild (renamed from sys-apps/mlocate/mlocate-0.22.2.ebuild)4
3 files changed, 32 insertions, 3 deletions
diff --git a/sys-apps/mlocate/ChangeLog b/sys-apps/mlocate/ChangeLog
index 6b2247594b2d..f0ea4fe5c9c3 100644
--- a/sys-apps/mlocate/ChangeLog
+++ b/sys-apps/mlocate/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/mlocate
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/mlocate/ChangeLog,v 1.51 2009/11/18 10:25:00 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mlocate/ChangeLog,v 1.52 2009/11/18 10:29:14 fauli Exp $
+
+*mlocate-0.22.2-r1 (18 Nov 2009)
+
+ 18 Nov 2009; Christian Faulhammer <fauli@gentoo.org>
+ -mlocate-0.22.2.ebuild, +mlocate-0.22.2-r1.ebuild, +files/mlocate.cron-r2:
+ remove Bashisms from cron file, thanks to Richard Li <admin AT chys DOT
+ info> in bug 293459
18 Nov 2009; Christian Faulhammer <fauli@gentoo.org>
-mlocate-0.22.1.ebuild:
diff --git a/sys-apps/mlocate/files/mlocate.cron-r2 b/sys-apps/mlocate/files/mlocate.cron-r2
new file mode 100644
index 000000000000..3074f132aaa7
--- /dev/null
+++ b/sys-apps/mlocate/files/mlocate.cron-r2
@@ -0,0 +1,22 @@
+#! /bin/sh
+
+if [ -x /usr/bin/updatedb ]
+then
+ if [ -f /etc/updatedb.conf ]
+ then
+ args=""
+ else
+ args="-f proc"
+ fi
+
+ if [ -f /etc/mlocate-cron.conf ]
+ then
+ . /etc/mlocate-cron.conf
+ fi
+
+ # run on active process in case ionice isnt installed, or
+ # system is really old and ionice doesnt work ...
+ ionice -c ${IONICE_CLASS:-2} -n ${IONICE_PRIORITY:-7} -p $$ 2>/dev/null
+
+ nice -n ${NICE:-10} /usr/bin/updatedb ${args}
+fi
diff --git a/sys-apps/mlocate/mlocate-0.22.2.ebuild b/sys-apps/mlocate/mlocate-0.22.2-r1.ebuild
index cbcc237c53ee..6d5caef79c05 100644
--- a/sys-apps/mlocate/mlocate-0.22.2.ebuild
+++ b/sys-apps/mlocate/mlocate-0.22.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/mlocate/mlocate-0.22.2.ebuild,v 1.1 2009/10/24 14:43:30 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mlocate/mlocate-0.22.2-r1.ebuild,v 1.1 2009/11/18 10:29:14 fauli Exp $
inherit eutils
@@ -38,7 +38,7 @@ src_install() {
fperms 0644 /etc/mlocate-cron.conf
insinto /etc/cron.daily
- newins "${FILESDIR}/mlocate.cron-r1" mlocate
+ newins "${FILESDIR}/mlocate.cron-r2" mlocate
fperms 0755 /etc/cron.daily/mlocate
fowners 0:locate /usr/bin/locate