summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-05-31 07:04:58 +0000
committerMike Frysinger <vapier@gentoo.org>2008-05-31 07:04:58 +0000
commitb14a7b6ffb731f441123121aa567288b4aaba903 (patch)
tree28a474e4fce25b4a12a08791cf982a38f5e85809 /sys-apps
parentAdding opendesktop-fonts-1.3.0.ebuild from fireflysung-1.3.0.ebuild to prepar... (diff)
downloadgentoo-2-b14a7b6ffb731f441123121aa567288b4aaba903.tar.gz
gentoo-2-b14a7b6ffb731f441123121aa567288b4aaba903.tar.bz2
gentoo-2-b14a7b6ffb731f441123121aa567288b4aaba903.zip
Do the timezone upgrade before moving the clock conf.d as pointed out by Hopeless #222867.
(Portage version: 2.2_pre5.spank.spunk)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/openrc/ChangeLog7
-rw-r--r--sys-apps/openrc/openrc-0.2.5.ebuild18
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild18
3 files changed, 24 insertions, 19 deletions
diff --git a/sys-apps/openrc/ChangeLog b/sys-apps/openrc/ChangeLog
index 8304edad2a0e..d44450ccaf98 100644
--- a/sys-apps/openrc/ChangeLog
+++ b/sys-apps/openrc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/openrc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/ChangeLog,v 1.37 2008/05/29 13:47:47 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/ChangeLog,v 1.38 2008/05/31 07:04:58 vapier Exp $
+
+ 31 May 2008; Mike Frysinger <vapier@gentoo.org> openrc-0.2.5.ebuild,
+ openrc-9999.ebuild:
+ Do the timezone upgrade before moving the clock conf.d as pointed out by
+ Hopeless #222867.
*openrc-0.2.5 (29 May 2008)
diff --git a/sys-apps/openrc/openrc-0.2.5.ebuild b/sys-apps/openrc/openrc-0.2.5.ebuild
index 0777c76aa244..89a8cc226740 100644
--- a/sys-apps/openrc/openrc-0.2.5.ebuild
+++ b/sys-apps/openrc/openrc-0.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-0.2.5.ebuild,v 1.1 2008/05/29 13:47:47 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-0.2.5.ebuild,v 1.2 2008/05/31 07:04:58 vapier Exp $
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -127,6 +127,14 @@ pkg_preinst() {
mv "${D}"/etc/conf.d/net "${T}"/
[[ -e ${ROOT}/etc/conf.d/net ]] && cp "${ROOT}"/etc/conf.d/net "${T}"/
+ # upgrade timezone file ... do it before moving clock
+ if [[ -e ${ROOT}/etc/conf.d/clock && ! -e ${ROOT}/etc/timezone ]] ; then
+ (
+ source "${ROOT}"/etc/conf.d/clock
+ [[ -n ${TIMEZONE} ]] && echo "${TIMEZONE}" > "${ROOT}"/etc/timezone
+ )
+ fi
+
# /etc/conf.d/clock moved to /etc/conf.d/hwclock
local clock
use kernel_FreeBSD && clock="adjkerntz" || clock="hwclock"
@@ -149,14 +157,6 @@ pkg_preinst() {
elog "and delete /etc/conf.d/rc"
fi
- # upgrade timezone file
- if [[ -e ${ROOT}/etc/conf.d/clock && ! -e ${ROOT}/etc/timezone ]] ; then
- (
- source "${ROOT}"/etc/conf.d/clock
- [[ -n ${TIMEZONE} ]] && echo "${TIMEZONE}" > "${ROOT}"/etc/timezone
- )
- fi
-
# force net init.d scripts into symlinks
for f in "${ROOT}"/etc/init.d/net.* ; do
[[ -e ${f} ]] || continue # catch net.* not matching anything
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index 901e745785d1..ff4c8fee760e 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.33 2008/05/05 03:54:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.34 2008/05/31 07:04:58 vapier Exp $
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -127,6 +127,14 @@ pkg_preinst() {
mv "${D}"/etc/conf.d/net "${T}"/
[[ -e ${ROOT}/etc/conf.d/net ]] && cp "${ROOT}"/etc/conf.d/net "${T}"/
+ # upgrade timezone file ... do it before moving clock
+ if [[ -e ${ROOT}/etc/conf.d/clock && ! -e ${ROOT}/etc/timezone ]] ; then
+ (
+ source "${ROOT}"/etc/conf.d/clock
+ [[ -n ${TIMEZONE} ]] && echo "${TIMEZONE}" > "${ROOT}"/etc/timezone
+ )
+ fi
+
# /etc/conf.d/clock moved to /etc/conf.d/hwclock
local clock
use kernel_FreeBSD && clock="adjkerntz" || clock="hwclock"
@@ -149,14 +157,6 @@ pkg_preinst() {
elog "and delete /etc/conf.d/rc"
fi
- # upgrade timezone file
- if [[ -e ${ROOT}/etc/conf.d/clock && ! -e ${ROOT}/etc/timezone ]] ; then
- (
- source "${ROOT}"/etc/conf.d/clock
- [[ -n ${TIMEZONE} ]] && echo "${TIMEZONE}" > "${ROOT}"/etc/timezone
- )
- fi
-
# force net init.d scripts into symlinks
for f in "${ROOT}"/etc/init.d/net.* ; do
[[ -e ${f} ]] || continue # catch net.* not matching anything