summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-21 05:23:00 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-21 05:23:00 +0000
commitb1cc535abfcf96de1b649fefa9fcd5c3783a8ade (patch)
tree6d532f363c71e393afdf4dfbb5822e79a71e9c15 /sys-apps
parentold (diff)
downloadgentoo-2-b1cc535abfcf96de1b649fefa9fcd5c3783a8ade.tar.gz
gentoo-2-b1cc535abfcf96de1b649fefa9fcd5c3783a8ade.tar.bz2
gentoo-2-b1cc535abfcf96de1b649fefa9fcd5c3783a8ade.zip
Fixup cron script #130435 by Caster.
(Portage version: 2.1_pre9-r1)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/slocate/ChangeLog8
-rw-r--r--sys-apps/slocate/files/digest-slocate-3.1-r13
-rw-r--r--sys-apps/slocate/files/slocate-3.1-cron.patch19
-rw-r--r--sys-apps/slocate/slocate-3.1-r1.ebuild84
4 files changed, 113 insertions, 1 deletions
diff --git a/sys-apps/slocate/ChangeLog b/sys-apps/slocate/ChangeLog
index 24da58cbe896..c76f9e5656c3 100644
--- a/sys-apps/slocate/ChangeLog
+++ b/sys-apps/slocate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/slocate
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/slocate/ChangeLog,v 1.65 2006/04/19 04:47:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/slocate/ChangeLog,v 1.66 2006/04/21 05:23:00 vapier Exp $
+
+*slocate-3.1-r1 (21 Apr 2006)
+
+ 21 Apr 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/slocate-3.1-cron.patch, +slocate-3.1-r1.ebuild:
+ Fixup cron script #130435 by Caster.
*slocate-3.1 (19 Apr 2006)
diff --git a/sys-apps/slocate/files/digest-slocate-3.1-r1 b/sys-apps/slocate/files/digest-slocate-3.1-r1
new file mode 100644
index 000000000000..fae5f81751c0
--- /dev/null
+++ b/sys-apps/slocate/files/digest-slocate-3.1-r1
@@ -0,0 +1,3 @@
+MD5 908e6949d959ae7b686c10bb76b35bf3 slocate-3.1.tar.gz 37748
+RMD160 d3b1e818cc35ce8e87ec1b0764f6b2145a319e13 slocate-3.1.tar.gz 37748
+SHA256 6abec68ab50fa743739fb78a5063c295ae2f7d04d2e538f7c3108120e49a3266 slocate-3.1.tar.gz 37748
diff --git a/sys-apps/slocate/files/slocate-3.1-cron.patch b/sys-apps/slocate/files/slocate-3.1-cron.patch
new file mode 100644
index 000000000000..b5d7ec064a3d
--- /dev/null
+++ b/sys-apps/slocate/files/slocate-3.1-cron.patch
@@ -0,0 +1,19 @@
+--- debian/cron.daily.orig 2006-04-21 01:21:18.000000000 -0400
++++ debian/cron.daily 2006-04-21 01:21:34.000000000 -0400
+@@ -1,12 +1,12 @@
+ #! /bin/sh
+
+-if [ -x /usr/bin/slocate ]
++if [ -x /usr/bin/updatedb ]
+ then
+ if [ -f /etc/updatedb.conf ]
+ then
+- /usr/bin/updatedb
++ nice /usr/bin/updatedb
+ else
+- /usr/bin/updatedb -f proc
++ nice /usr/bin/updatedb -f proc
+ fi
+- chown root.slocate /var/lib/slocate/slocate.db
++ chown root.locate /var/lib/slocate/slocate.db
+ fi
diff --git a/sys-apps/slocate/slocate-3.1-r1.ebuild b/sys-apps/slocate/slocate-3.1-r1.ebuild
new file mode 100644
index 000000000000..44277e45b382
--- /dev/null
+++ b/sys-apps/slocate/slocate-3.1-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/slocate/slocate-3.1-r1.ebuild,v 1.1 2006/04/21 05:23:00 vapier Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Secure way to index and quickly search for files on your system (drop-in replacement for 'locate')"
+HOMEPAGE="http://slocate.trakker.ca/"
+SRC_URI="http://slocate.trakker.ca/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-apps/shadow"
+RDEPEND="${DEPEND}
+ !sys-apps/rlocate"
+
+pkg_setup() {
+ if [[ -n $(egetent group slocate) ]] ; then
+ eerror "The 'slocate' group has been renamed to 'locate'."
+ eerror "You seem to already have a 'slocate' group."
+ eerror "Please rename it:"
+ eerror "groupmod -n locate slocate"
+ die "Change 'slocate' to 'locate'"
+ fi
+ enewgroup locate 245
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-incompat-warning.patch
+ epatch "${FILESDIR}"/${P}-cron.patch
+}
+
+src_compile() {
+ filter-lfs-flags
+ # this is safe since slocate only has 1 binary
+ append-ldflags $(bindnow-flags)
+ emake -C src || die
+}
+
+src_install() {
+ dobin src/slocate || die
+ dodir /usr/bin
+ dosym slocate /usr/bin/locate
+ dosym slocate /usr/bin/updatedb
+
+ exeinto /etc/cron.daily
+ newexe debian/cron.daily slocate || die
+
+ doman doc/*.1
+ dosym slocate.1 /usr/share/man/man1/locate.1
+
+ keepdir /var/lib/slocate
+
+ dodoc Changelog README WISHLIST notes
+
+ insinto /etc
+ doins "${FILESDIR}"/updatedb.conf
+
+ fowners root:locate /usr/bin/slocate
+ fperms go-r,g+s /usr/bin/slocate
+
+ chown -R root:locate "${D}"/var/lib/slocate
+ fperms 0750 /var/lib/slocate
+}
+
+pkg_postinst() {
+ if [[ -f ${ROOT}/etc/cron.daily/slocate.cron ]]; then
+ ewarn "If you merged slocate-2.7.ebuild, please remove"
+ ewarn "/etc/cron.daily/slocate.cron since .cron has been removed"
+ ewarn "from the filename"
+ echo
+ fi
+ einfo "Note that the /etc/updatedb.conf file is generic"
+ einfo "Please customize it to your system requirements"
+ echo
+ ewarn "The slocate database created by slocate-2.x is incompatible"
+ ewarn "with slocate-3.x. Make sure you run updatedb!"
+}