summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-06-15 07:16:28 +0000
committerNed Ludd <solar@gentoo.org>2004-06-15 07:16:28 +0000
commitc1454a5fd16119bc0817360d6abe242728d9e2cc (patch)
tree4d5d0b642d5c808c3be7be59680b8d6f8ffb8d8d /sys-apps
parentadded uclibc support (Manifest recommit) (diff)
downloadgentoo-2-c1454a5fd16119bc0817360d6abe242728d9e2cc.tar.gz
gentoo-2-c1454a5fd16119bc0817360d6abe242728d9e2cc.tar.bz2
gentoo-2-c1454a5fd16119bc0817360d6abe242728d9e2cc.zip
added patch to allow the disabling of nls for psmisc
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/psmisc/ChangeLog6
-rw-r--r--sys-apps/psmisc/files/psmisc-21.2-no-nls.patch56
-rw-r--r--sys-apps/psmisc/files/psmisc-21.4-no-nls.patch71
-rw-r--r--sys-apps/psmisc/psmisc-21.2-r4.ebuild6
-rw-r--r--sys-apps/psmisc/psmisc-21.4.ebuild6
5 files changed, 140 insertions, 5 deletions
diff --git a/sys-apps/psmisc/ChangeLog b/sys-apps/psmisc/ChangeLog
index 5b0c867bb4c3..ecf08951f3fb 100644
--- a/sys-apps/psmisc/ChangeLog
+++ b/sys-apps/psmisc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/psmisc
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/psmisc/ChangeLog,v 1.35 2004/06/11 13:54:12 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/psmisc/ChangeLog,v 1.36 2004/06/15 07:16:28 solar Exp $
+
+ 15 Jun 2004; <solar@gentoo.org> psmisc-21.2-r4.ebuild, psmisc-21.4.ebuild,
+ files/psmisc-21.2-no-nls.patch, files/psmisc-21.4-no-nls.patch:
+ added patch to allow the disabling of nls for psmisc
11 Jun 2004; Bryan Østergaard <kloeri@gentoo.org> psmisc-21.4.ebuild:
Stable on alpha.
diff --git a/sys-apps/psmisc/files/psmisc-21.2-no-nls.patch b/sys-apps/psmisc/files/psmisc-21.2-no-nls.patch
new file mode 100644
index 000000000000..79292b40a5c6
--- /dev/null
+++ b/sys-apps/psmisc/files/psmisc-21.2-no-nls.patch
@@ -0,0 +1,56 @@
+--- src/fuser.c.nonls~ Fri Sep 27 12:58:54 2002
++++ src/fuser.c Tue Jun 8 20:55:24 2004
+@@ -31,9 +31,13 @@
+ #include <linux/kdev_t.h> /* for MKDEV */
+ #include <linux/major.h> /* for LOOP_MAJOR */
+ #endif
++#ifdef USE_NLS
+ #include <libintl.h>
+ #include <locale.h>
+ #define _(String) gettext (String)
++#else
++#define _(String) (String)
++#endif
+
+ #include "comm.h"
+ #include "loop.h" /* for loop_info */
+@@ -981,9 +985,11 @@
+ no_files = 1;
+
+ /* Setup the i18n */
++#ifdef USE_NLS
+ setlocale(LC_ALL, "");
+ bindtextdomain(PACKAGE, LOCALEDIR);
+ textdomain(PACKAGE);
++#endif
+
+ if (argc < 2)
+ usage ();
+--- src/killall.c.nonls~ Tue Jun 8 20:52:00 2004
++++ src/killall.c Tue Jun 8 20:55:24 2004
+@@ -24,9 +24,13 @@
+ #include <fs_secure.h>
+ #include <ss.h>
+ #endif /*FLASK_LINUX*/
++#ifdef USE_NLS
+ #include <libintl.h>
+ #include <locale.h>
+ #define _(String) gettext (String)
++#else
++#define _(String) (String)
++#endif
+
+ #include "comm.h"
+ #include "signals.h"
+@@ -461,9 +465,11 @@
+ sig_num = SIGTERM;
+
+ /* Setup the i18n */
++#ifdef USE_NLS
+ setlocale(LC_ALL, "");
+ bindtextdomain(PACKAGE, LOCALEDIR);
+ textdomain(PACKAGE);
++#endif
+
+ opterr = 0;
+ while ( (optc = getopt_long_only(argc,argv,"egilqs:vwS:c:V",options,NULL)) != EOF) {
diff --git a/sys-apps/psmisc/files/psmisc-21.4-no-nls.patch b/sys-apps/psmisc/files/psmisc-21.4-no-nls.patch
new file mode 100644
index 000000000000..89546b3a072d
--- /dev/null
+++ b/sys-apps/psmisc/files/psmisc-21.4-no-nls.patch
@@ -0,0 +1,71 @@
+--- src/fuser.c.mps 2004-06-08 18:21:33 +0200
++++ src/fuser.c 2004-06-08 18:27:13 +0200
+@@ -31,9 +31,13 @@
+ #include <linux/kdev_t.h> /* for MKDEV */
+ #include <linux/major.h> /* for LOOP_MAJOR */
+ #endif
++#ifdef USE_NLS
+ #include <libintl.h>
+ #include <locale.h>
+ #define _(String) gettext (String)
++#else
++#define _(String) (String)
++#endif
+
+ #include "comm.h"
+ #include "loop.h" /* for loop_info */
+@@ -1007,9 +1011,11 @@ main (int argc, char **argv)
+ no_files = 1;
+
+ /* Setup the i18n */
++#ifdef USE_NLS
+ setlocale(LC_ALL, "");
+ bindtextdomain(PACKAGE, LOCALEDIR);
+ textdomain(PACKAGE);
++#endif
+
+ if (argc < 2)
+ usage ();
+--- src/killall.c.mps 2004-06-08 18:21:38 +0200
++++ src/killall.c 2004-06-08 18:26:51 +0200
+@@ -25,9 +25,13 @@
+ #include <selinux/fs_secure.h>
+ #include <selinux/ss.h>
+ #endif /*FLASK_LINUX*/
++#ifdef USE_NLS
+ #include <libintl.h>
+ #include <locale.h>
+ #define _(String) gettext (String)
++#else
++#define _(String) (String)
++#endif
+
+ #include "comm.h"
+ #include "signals.h"
+@@ -467,9 +471,11 @@ main (int argc, char **argv)
+ sig_num = SIGTERM;
+
+ /* Setup the i18n */
++#ifdef USE_NLS
+ setlocale(LC_ALL, "");
+ bindtextdomain(PACKAGE, LOCALEDIR);
+ textdomain(PACKAGE);
++#endif
+
+ opterr = 0;
+ #ifdef FLASK_LINUX
+--- src/pstree.c.mps 2004-06-08 18:27:39 +0200
++++ src/pstree.c 2004-06-08 18:28:03 +0200
+@@ -22,8 +22,12 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <sys/ioctl.h>
++#ifdef USE_NLS
+ #include <libintl.h>
+ #define _(String) gettext (String)
++#else
++#define _(String) (String)
++#endif
+
+ #include "comm.h"
+
diff --git a/sys-apps/psmisc/psmisc-21.2-r4.ebuild b/sys-apps/psmisc/psmisc-21.2-r4.ebuild
index c0e607de4899..a8915f28cb8f 100644
--- a/sys-apps/psmisc/psmisc-21.2-r4.ebuild
+++ b/sys-apps/psmisc/psmisc-21.2-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/psmisc/psmisc-21.2-r4.ebuild,v 1.15 2004/04/09 05:00:27 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/psmisc/psmisc-21.2-r4.ebuild,v 1.16 2004/06/15 07:16:28 solar Exp $
inherit eutils gnuconfig
@@ -16,7 +16,8 @@ KEYWORDS="x86 amd64 ppc sparc ~alpha hppa mips ia64 ppc64 s390"
IUSE="nls selinux"
DEPEND=">=sys-libs/ncurses-5.2-r2
- selinux? ( sys-libs/libselinux )"
+ selinux? ( sys-libs/libselinux )
+ nls? ( sys-devel/gettext )"
src_unpack() {
unpack ${A}
@@ -42,6 +43,7 @@ src_unpack() {
# pointer that is used, thanks to bug submitted (bug #28234) by
# Grant McDorman <grant.mcdorman@sympatico.ca>.
epatch ${FILESDIR}/${P}-fix-realloc.patch
+ use nls || epatch ${FILESDIR}/${P}-no-nls.patch
}
src_compile() {
diff --git a/sys-apps/psmisc/psmisc-21.4.ebuild b/sys-apps/psmisc/psmisc-21.4.ebuild
index 47d213693b91..65a2768af50e 100644
--- a/sys-apps/psmisc/psmisc-21.4.ebuild
+++ b/sys-apps/psmisc/psmisc-21.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/psmisc/psmisc-21.4.ebuild,v 1.7 2004/06/11 13:54:12 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/psmisc/psmisc-21.4.ebuild,v 1.8 2004/06/15 07:16:28 solar Exp $
inherit eutils gnuconfig
@@ -16,7 +16,8 @@ KEYWORDS="~x86 ~ppc ~sparc ~mips alpha arm hppa ~amd64 ~ia64 ~ppc64 s390"
IUSE="nls selinux"
DEPEND=">=sys-libs/ncurses-5.2-r2
- selinux? ( sys-libs/libselinux )"
+ selinux? ( sys-libs/libselinux )
+ nls? ( sys-devel/gettext )"
src_unpack() {
unpack ${A}
@@ -26,6 +27,7 @@ src_unpack() {
# Necessary selinux patch
epatch ${FILESDIR}/${SELINUX_PATCH}
fi
+ use nls || epatch ${FILESDIR}/${P}-no-nls.patch
}
src_compile() {