summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-04-06 18:03:29 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-04-06 18:03:29 +0000
commitce77b82978c3010ae46958b6bd0dd493c4ff0521 (patch)
tree834790c1b9a82957ed7d9396f54581ff0055f509 /sys-apps
parentVersion cleanup: Removing unused versions (diff)
downloadgentoo-2-ce77b82978c3010ae46958b6bd0dd493c4ff0521.tar.gz
gentoo-2-ce77b82978c3010ae46958b6bd0dd493c4ff0521.tar.bz2
gentoo-2-ce77b82978c3010ae46958b6bd0dd493c4ff0521.zip
Version bump, reduce init script.
(Portage version: 2.2.0_alpha99/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/irqbalance/ChangeLog8
-rw-r--r--sys-apps/irqbalance/files/irqbalance.init.212
-rw-r--r--sys-apps/irqbalance/irqbalance-1.0.3.ebuild35
3 files changed, 54 insertions, 1 deletions
diff --git a/sys-apps/irqbalance/ChangeLog b/sys-apps/irqbalance/ChangeLog
index 285755bf4c37..7c95c3e6ef97 100644
--- a/sys-apps/irqbalance/ChangeLog
+++ b/sys-apps/irqbalance/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/irqbalance
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/ChangeLog,v 1.38 2012/01/08 09:53:49 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/ChangeLog,v 1.39 2012/04/06 18:03:29 flameeyes Exp $
+
+*irqbalance-1.0.3 (06 Apr 2012)
+
+ 06 Apr 2012; Diego E. Pettenò <flameeyes@gentoo.org> +files/irqbalance.init.2,
+ +irqbalance-1.0.3.ebuild:
+ Version bump, reduce init script.
08 Jan 2012; Michał Górny <mgorny@gentoo.org> files/irqbalance.service:
Update .service file path as well.
diff --git a/sys-apps/irqbalance/files/irqbalance.init.2 b/sys-apps/irqbalance/files/irqbalance.init.2
new file mode 100644
index 000000000000..c27a32f27f2a
--- /dev/null
+++ b/sys-apps/irqbalance/files/irqbalance.init.2
@@ -0,0 +1,12 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/files/irqbalance.init.2,v 1.1 2012/04/06 18:03:29 flameeyes Exp $
+
+depend() {
+ need localmount
+ after bootmisc
+}
+
+command="/usr/sbin/irqbalance"
+command_args="${IRQBALANCE_OPTS}"
diff --git a/sys-apps/irqbalance/irqbalance-1.0.3.ebuild b/sys-apps/irqbalance/irqbalance-1.0.3.ebuild
new file mode 100644
index 000000000000..974f9bd6eb95
--- /dev/null
+++ b/sys-apps/irqbalance/irqbalance-1.0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/irqbalance-1.0.3.ebuild,v 1.1 2012/04/06 18:03:29 flameeyes Exp $
+
+EAPI=4
+
+inherit systemd
+
+DESCRIPTION="Distribute hardware interrupts across processors on a multiprocessor system"
+HOMEPAGE="http://irqbalance.googlecode.com/"
+SRC_URI="http://irqbalance.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="caps numa"
+
+RDEPEND="dev-libs/glib:2
+ caps? ( sys-libs/libcap-ng )
+ numa? ( sys-process/numactl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_with caps libcap-ng) \
+ $(use_enable numa)
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/irqbalance.init.2 irqbalance
+ newconfd "${FILESDIR}"/irqbalance.confd-1 irqbalance
+ systemd_dounit "${FILESDIR}"/irqbalance.service
+}