summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-12-07 00:51:51 +0000
committerMike Frysinger <vapier@gentoo.org>2006-12-07 00:51:51 +0000
commite3c678db27ac22d014d05e3d7abc5f29f5a0bfdc (patch)
treeb81591084da2c9dd31f847006f977feeef19eb71 /sys-apps
parentUpdate to Linux 2.6.18.5 (diff)
downloadgentoo-2-e3c678db27ac22d014d05e3d7abc5f29f5a0bfdc.tar.gz
gentoo-2-e3c678db27ac22d014d05e3d7abc5f29f5a0bfdc.tar.bz2
gentoo-2-e3c678db27ac22d014d05e3d7abc5f29f5a0bfdc.zip
Version bump #157352 by Benno Schulenberg.
(Portage version: 2.1.2_rc2-r4)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/findutils/ChangeLog7
-rw-r--r--sys-apps/findutils/files/digest-findutils-4.2.293
-rw-r--r--sys-apps/findutils/findutils-4.2.29.ebuild65
3 files changed, 74 insertions, 1 deletions
diff --git a/sys-apps/findutils/ChangeLog b/sys-apps/findutils/ChangeLog
index 871f4f333488..4a3094f8a97d 100644
--- a/sys-apps/findutils/ChangeLog
+++ b/sys-apps/findutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/findutils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.85 2006/12/07 00:42:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.86 2006/12/07 00:51:51 vapier Exp $
+
+*findutils-4.2.29 (07 Dec 2006)
+
+ 07 Dec 2006; Mike Frysinger <vapier@gentoo.org> +findutils-4.2.29.ebuild:
+ Version bump #157352 by Benno Schulenberg.
*findutils-4.3.2 (07 Dec 2006)
diff --git a/sys-apps/findutils/files/digest-findutils-4.2.29 b/sys-apps/findutils/files/digest-findutils-4.2.29
new file mode 100644
index 000000000000..2f6a1eff9aeb
--- /dev/null
+++ b/sys-apps/findutils/files/digest-findutils-4.2.29
@@ -0,0 +1,3 @@
+MD5 24e76434ca74ba3c2c6ad621eb64e1ff findutils-4.2.29.tar.gz 1096112
+RMD160 ff663c8ba1a1943a2b7b2da619f7896462452064 findutils-4.2.29.tar.gz 1096112
+SHA256 1a9ed8db0711f8419156e786b6aecd42dd05df29e53e380d8924e696f7071ae0 findutils-4.2.29.tar.gz 1096112
diff --git a/sys-apps/findutils/findutils-4.2.29.ebuild b/sys-apps/findutils/findutils-4.2.29.ebuild
new file mode 100644
index 000000000000..1b55b244ca90
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.2.29.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.2.29.ebuild,v 1.1 2006/12/07 00:51:51 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+SELINUX_PATCH="findutils-4.2.24-selinux.diff"
+
+DESCRIPTION="GNU utilities for finding files"
+HOMEPAGE="http://www.gnu.org/software/findutils/findutils.html"
+# SRC_URI="mirror://gnu/${PN}/${P}.tar.gz mirror://gentoo/${P}.tar.gz"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls build selinux static"
+
+RDEPEND="selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Don't build or install locate because it conflicts with slocate,
+ # which is a secure version of locate. See bug 18729
+ sed -i '/^SUBDIRS/s/locate//' Makefile.in
+
+ # Patches for selinux
+ use selinux && epatch "${FILESDIR}/${SELINUX_PATCH}"
+
+ if [[ ${ELIBC} == "glibc" || ${ELIBC} == "uclibc" ]]; then
+ # Use the system-provided regex.h, bug #114747
+ echo "#include_next <regex.h>" > gnulib/lib/regex.h
+ fi
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ local myconf
+ use userland_GNU || myconf=" --program-prefix=g"
+
+ [[ ${ELIBC} == "glibc" || ${ELIBC} == "uclibc" ]] && \
+ myconf="${myconf} --without-included-regex"
+
+ econf $(use_enable nls) ${myconf} || die "configure failed"
+ emake libexecdir=/usr/lib/find AR="$(tc-getAR)" || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" libexecdir="${D}/usr/lib/find" install || die
+
+ rm -rf "${D}"/usr/var
+ use build \
+ && rm -rf "${D}"/usr/share \
+ || dodoc NEWS README TODO ChangeLog
+}
+
+pkg_postinst() {
+ ewarn "Please note that the locate and updatedb binaries"
+ ewarn "are now provided by slocate, not findutils."
+}