summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Klimaszewski <steev@gentoo.org>2008-01-17 21:26:14 +0000
committerStephen Klimaszewski <steev@gentoo.org>2008-01-17 21:26:14 +0000
commite4b3c6e161796af7917d732cf4b4b72a9a5a34d4 (patch)
treeff2c754f14b59762f49d9c853897ee3d7f05a461 /sys-apps
parentAdd stable keywords from testing on the security bug. (diff)
downloadgentoo-2-e4b3c6e161796af7917d732cf4b4b72a9a5a34d4.tar.gz
gentoo-2-e4b3c6e161796af7917d732cf4b4b72a9a5a34d4.tar.bz2
gentoo-2-e4b3c6e161796af7917d732cf4b4b72a9a5a34d4.zip
New upstream release. This is identical to 1.1.3-r1
(Portage version: 2.1.4)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/dbus/ChangeLog10
-rw-r--r--sys-apps/dbus/dbus-1.1.4.ebuild (renamed from sys-apps/dbus/dbus-1.1.3-r1.ebuild)8
-rw-r--r--sys-apps/dbus/files/dbus-inotify-fix-thoenig-01.patch113
-rw-r--r--sys-apps/dbus/files/digest-dbus-1.1.43
4 files changed, 13 insertions, 121 deletions
diff --git a/sys-apps/dbus/ChangeLog b/sys-apps/dbus/ChangeLog
index b39237d14580..135796e5daba 100644
--- a/sys-apps/dbus/ChangeLog
+++ b/sys-apps/dbus/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/dbus
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.203 2008/01/17 19:37:38 steev Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.204 2008/01/17 21:26:13 steev Exp $
+
+*dbus-1.1.4 (17 Jan 2008)
+
+ 17 Jan 2008; Steev Klimaszewski <steev@gentoo.org>
+ -files/dbus-inotify-fix-thoenig-01.patch, -dbus-1.1.3-r1.ebuild,
+ +dbus-1.1.4.ebuild:
+ New release candidate - the same as 1.1.3-r1 but upstream felt it was better
+ to release a new tarball
*dbus-1.1.3-r1 (17 Jan 2008)
diff --git a/sys-apps/dbus/dbus-1.1.3-r1.ebuild b/sys-apps/dbus/dbus-1.1.4.ebuild
index 976ed260ca33..8630d5d3cb5b 100644
--- a/sys-apps/dbus/dbus-1.1.3-r1.ebuild
+++ b/sys-apps/dbus/dbus-1.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.1.3-r1.ebuild,v 1.1 2008/01/17 19:37:38 steev Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.1.4.ebuild,v 1.1 2008/01/17 21:26:13 steev Exp $
inherit eutils multilib autotools flag-o-matic
@@ -23,12 +23,6 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen
app-text/xmlto )"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/dbus-inotify-fix-thoenig-01.patch"
-}
-
src_compile() {
# so we can get backtraces from apps
append-flags -rdynamic
diff --git a/sys-apps/dbus/files/dbus-inotify-fix-thoenig-01.patch b/sys-apps/dbus/files/dbus-inotify-fix-thoenig-01.patch
deleted file mode 100644
index ad1acfef1bc1..000000000000
--- a/sys-apps/dbus/files/dbus-inotify-fix-thoenig-01.patch
+++ /dev/null
@@ -1,113 +0,0 @@
-diff --git a/bus/dir-watch-inotify.c b/bus/dir-watch-inotify.c
---- a/bus/dir-watch-inotify.c
-+++ b/bus/dir-watch-inotify.c
-@@ -38,6 +38,8 @@
- #include "dir-watch.h"
-
- #define MAX_DIRS_TO_WATCH 128
-+#define INOTIFY_EVENT_SIZE (sizeof(struct inotify_event))
-+#define INOTIFY_BUF_LEN (1024 * (INOTIFY_EVENT_SIZE + 16))
-
- /* use a static array to avoid handling OOM */
- static int wds[MAX_DIRS_TO_WATCH];
-@@ -55,33 +57,43 @@ _inotify_watch_callback (DBusWatch *watch, unsigned int condition, void *data)
- static dbus_bool_t
- _handle_inotify_watch (DBusWatch *watch, unsigned int flags, void *data)
- {
-- struct inotify_event ev;
-- size_t res;
-+ char buffer[INOTIFY_BUF_LEN];
-+ ssize_t ret = 0;
-+ int i = 0;
- pid_t pid;
-
-- res = read (inotify_fd, &ev, sizeof(ev));
-+ ret = read (inotify_fd, buffer, INOTIFY_BUF_LEN);
-+ if (ret < 0)
-+ _dbus_verbose ("Error reading inotify event: '%s'\n, _dbus_strerror(errno)");
-+ else if (!ret)
-+ _dbus_verbose ("Error reading inotify event: buffer too small\n");
-
-- if (res > 0)
-+ while (i < ret)
- {
-- pid = getpid ();
-+ struct inotify_event *ev;
-+ pid = _dbus_getpid ();
-+
-+ ev = (struct inotify_event *) &buffer[i];
-+ i += INOTIFY_EVENT_SIZE + ev->len;
-+#ifdef DBUS_ENABLE_VERBOSE_MODE
-+ if (ev->len)
-+ _dbus_verbose ("event name: '%s'\n", ev->name);
-+ _dbus_verbose ("inotify event: wd=%d mask=%u cookie=%u len=%u\n", ev->wd, ev->mask, ev->cookie, ev->len);
-+#endif
- _dbus_verbose ("Sending SIGHUP signal on reception of a inotify event\n");
- (void) kill (pid, SIGHUP);
- }
-- else if (res < 0 && errno == EBADF)
-+
-+ if (watch != NULL)
- {
-- if (watch != NULL)
-- {
-- _dbus_loop_remove_watch (loop, watch, _inotify_watch_callback, NULL);
-- _dbus_watch_unref (watch);
-- watch = NULL;
-- }
-- pid = getpid ();
-- _dbus_verbose ("Sending SIGHUP signal since inotify fd has been closed\n");
-- (void) kill (pid, SIGHUP);
-+ _dbus_loop_remove_watch (loop, watch, _inotify_watch_callback, NULL);
-+ _dbus_watch_unref (watch);
-+ watch = NULL;
- }
--
-+
- return TRUE;
- }
-+
- void
- bus_watch_directory (const char *dir, BusContext *context)
- {
-@@ -116,14 +128,13 @@ bus_watch_directory (const char *dir, BusContext *context)
- }
- }
-
--
- if (num_wds >= MAX_DIRS_TO_WATCH )
- {
- _dbus_warn ("Cannot watch config directory '%s'. Already watching %d directories\n", dir, MAX_DIRS_TO_WATCH);
- goto out;
- }
-
-- wd = inotify_add_watch (inotify_fd, dir, IN_MODIFY);
-+ wd = inotify_add_watch (inotify_fd, dir, IN_MODIFY | IN_CREATE | IN_DELETE);
- if (wd < 0)
- {
- _dbus_warn ("Cannot setup inotify for '%s'; error '%s'\n", dir, _dbus_strerror (errno));
-@@ -140,17 +151,13 @@ bus_watch_directory (const char *dir, BusContext *context)
- void
- bus_drop_all_directory_watches (void)
- {
-- int i;
--
-+ int ret;
-+
- _dbus_verbose ("Dropping all watches on config directories\n");
--
-- for (i = 0; i < num_wds; i++)
-- {
-- if (inotify_rm_watch(inotify_fd, wds[i]) != 0)
-- {
-- _dbus_verbose ("Error closing fd %d for config directory watch\n", wds[i]);
-- }
-- }
--
-+ ret = close (inotify_fd);
-+ if (ret)
-+ _dbus_verbose ("Error dropping watches: '%s'\n", perror(ret));
-+
- num_wds = 0;
-+ inotify_fd = -1;
- }
diff --git a/sys-apps/dbus/files/digest-dbus-1.1.4 b/sys-apps/dbus/files/digest-dbus-1.1.4
new file mode 100644
index 000000000000..c741e3a8203e
--- /dev/null
+++ b/sys-apps/dbus/files/digest-dbus-1.1.4
@@ -0,0 +1,3 @@
+MD5 e08fdf702cae648acd9780eca0ce4df6 dbus-1.1.4.tar.gz 1400585
+RMD160 22d08a6c00ac3cd0bcf97d7733f39af36bcbfb0b dbus-1.1.4.tar.gz 1400585
+SHA256 4f8ff9324a5d363833833333193a3e83c074a51ce82d8c66c2e304b0378c714d dbus-1.1.4.tar.gz 1400585