summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-11-04 05:21:19 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-11-04 05:21:19 +0000
commitf62acd6bba22c6e973f1e4da945261a75b707254 (patch)
tree132e78e052fbdb79eceaad9259adc6630f4bfc15 /sys-apps
parentInitial commit - ebuild submitted by Alexey Charkov via bug #290803 (diff)
downloadgentoo-2-f62acd6bba22c6e973f1e4da945261a75b707254.tar.gz
gentoo-2-f62acd6bba22c6e973f1e4da945261a75b707254.tar.bz2
gentoo-2-f62acd6bba22c6e973f1e4da945261a75b707254.zip
Version bump per bug #291446, also more parallel make fixes.
(Portage version: 2.2_rc48/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/x86info/ChangeLog8
-rw-r--r--sys-apps/x86info/files/x86info-1.25-parallel-make-cleanup.patch92
-rw-r--r--sys-apps/x86info/x86info-1.25.ebuild66
3 files changed, 165 insertions, 1 deletions
diff --git a/sys-apps/x86info/ChangeLog b/sys-apps/x86info/ChangeLog
index 7c12db2065ee..6cc3422162f6 100644
--- a/sys-apps/x86info/ChangeLog
+++ b/sys-apps/x86info/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/x86info
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/ChangeLog,v 1.28 2009/08/15 23:41:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/ChangeLog,v 1.29 2009/11/04 05:21:18 robbat2 Exp $
+
+*x86info-1.25 (04 Nov 2009)
+
+ 04 Nov 2009; Robin H. Johnson <robbat2@gentoo.org> +x86info-1.25.ebuild,
+ +files/x86info-1.25-parallel-make-cleanup.patch:
+ Version bump per bug #291446, also more parallel make fixes.
15 Aug 2009; Mike Frysinger <vapier@gentoo.org> x86info-1.24-r2.ebuild,
+files/x86info-1.24-pic.patch:
diff --git a/sys-apps/x86info/files/x86info-1.25-parallel-make-cleanup.patch b/sys-apps/x86info/files/x86info-1.25-parallel-make-cleanup.patch
new file mode 100644
index 000000000000..97cfccd18b33
--- /dev/null
+++ b/sys-apps/x86info/files/x86info-1.25-parallel-make-cleanup.patch
@@ -0,0 +1,92 @@
+diff -Nuar --exclude '*.rej' --exclude '*.orig' x86info-1.25.orig/Makefile x86info-1.25/Makefile
+--- x86info-1.25.orig/Makefile 2009-10-30 15:59:46.000000000 +0000
++++ x86info-1.25/Makefile 2009-11-04 05:16:10.983250367 +0000
+@@ -2,15 +2,25 @@
+ # -Wstrict-overflow=5
+ CC = gcc
+
++.PRECIOUS: %.d
++
+ SHELL = /bin/sh
+
+
+-.c.o:
+- $(CC) $(CFLAGS) -MMD -o $@ -c $<
+- @cp $*.d $*.P; \
++%.d: %.c
++ $(CC) $(CFLAGS) -E -MMD -MF $@ $< >/dev/null
++
++%.d: %.h
++ $(CC) $(CFLAGS) -E -MMD -MF $@ $< >/dev/null
++
++%.P: %.d
++ cat $< >$@.tmp ; \
+ sed -e 's/#.*//' -e 's/^[^:]*: *//' -e 's/ *\\$$//' \
+- -e '/^$$/ d' -e 's/$$/ :/' < $*.d >> $*.P; \
+- rm -f $*.d
++ -e '/^$$/ d' -e 's/$$/ :/' < $@.tmp >> $@.tmp ; \
++ mv $@.tmp $@
++
++.c.o:
++ $(CC) $(CFLAGS) -o $@ -c $<
+
+ .S.o:
+ $(CC) $(CFLAGS) -o $@ -c $<
+@@ -22,7 +32,8 @@
+ LSMSR_TMP_HEADERS=AMD/k8.h AMD/fam10h.h AMD/fam11h.h generic_msr.h
+
+ %.h: %.regs scripts/createheader.py
+- python scripts/createheader.py $< `basename $< .regs` >$@
++ python scripts/createheader.py $< `basename $< .regs` >$@.tmp ; \
++ mv $@.tmp $@
+
+ LSMSR_SRC =\
+ lsmsr.c\
+@@ -30,11 +41,12 @@
+ havecpuid.c
+
+ LSMSR_OBJS = $(LSMSR_SRC:%.c=%.o)
++LSMSR_DEPS = $(patsubst %.h,%.P,$(patsubst %.c,%.P,$(LSMSR_SRC))) $(patsubst %.h,%.P,$(LSMSR_TMP_HEADERS))
+
+-lsmsr: $(LSMSR_TMP_HEADERS) $(LSMSR_OBJS)
+- $(CC) $(CFLAGS) -o lsmsr $(LSMSR_OBJS)
++lsmsr: $(LSMSR_TMP_HEADERS) $(LSMSR_OBJS) $(LSMSR_DEPS)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o lsmsr $(LSMSR_OBJS)
+
+--include $(LSMSR_SRC:%.c=%.P)
++-include $(LSMSR_DEPS)
+
+ X86INFO_SRC =\
+ AMD/identify.c\
+@@ -89,12 +101,12 @@
+ bench/MHz.c
+
+ X86INFO_OBJS = $(X86INFO_SRC:%.c=%.o)
++X86INFO_DEPS = $(patsubst %.h,%.P,$(patsubst %.c,%.P,$(X86INFO_SRC))) $(patsubst %.h,%.P,$(LSMSR_TMP_HEADERS))
+
+-x86info: $(X86INFO_OBJS)
+- $(CC) $(CFLAGS) -o x86info $(X86INFO_OBJS)
+-
+--include $(X86INFO_SRC:%.c=%.P)
++x86info: $(X86INFO_OBJS) $(X86INFO_DEPS)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o x86info $(X86INFO_OBJS)
+
++-include $(X86INFO_DEPS)
+
+ nodes:
+ scripts/makenodes
+@@ -113,6 +125,7 @@
+ @find . -name "*.o" -exec rm {} \;
+ @find . -name "*~" -exec rm {} \;
+ @find . -name "*.P" -exec rm {} \;
++ @find . -name "*.d" -exec rm {} \;
+ @rm -f x86info x86info.exe
+ @rm -f lsmsr $(LSMSR_TMP_HEADERS)
+
+@@ -121,3 +134,6 @@
+
+ sparse:
+ sparse $(X86INFO_SRC)
++
++deps-headers: $(LSMSR_TMP_HEADERS)
++deps: deps-headers $(LSMSR_DEPS) $(X86INFO_DEPS)
diff --git a/sys-apps/x86info/x86info-1.25.ebuild b/sys-apps/x86info/x86info-1.25.ebuild
new file mode 100644
index 000000000000..70fd937ff5fd
--- /dev/null
+++ b/sys-apps/x86info/x86info-1.25.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/x86info-1.25.ebuild,v 1.1 2009/11/04 05:21:18 robbat2 Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
+HOMEPAGE="http://www.codemonkey.org.uk/projects/x86info/"
+SRC_URI="http://www.codemonkey.org.uk/projects/x86info/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="sys-apps/sed" # used in the makefile
+
+src_prepare() {
+ epatch "${FILESDIR}"/1.21-pic.patch
+ epatch "${FILESDIR}"/${PN}-1.24-pic.patch #270388
+ epatch "${FILESDIR}"/${PN}-1.25-parallel-make-cleanup.patch
+}
+
+src_compile() {
+ emake deps \
+ || die "emake deps failed"
+ emake x86info lsmsr \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dobin x86info lsmsr || die
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/x86info-modules.conf-rc x86info.conf
+
+ dodoc TODO README
+ doman x86info.1 lsmsr.8
+ insinto /usr/share/doc/${PF}
+ doins -r results
+ prepalldocs
+}
+
+pkg_preinst() {
+ if [ -a "${ROOT}"/etc/modules.d/x86info ] && [ ! -a "${ROOT}"/etc/modprobe.d/x86info ] ; then
+ elog "Moving x86info from /etc/modules.d/ to /etc/modprobe.d/"
+ mv "${ROOT}"/etc/{modules,modprobe}.d/x86info
+ fi
+ if [ -a "${ROOT}"/etc/modprobe.d/x86info ] && [ ! -a "${ROOT}"/etc/modprobe.d/x86info.conf ] ; then
+ elog "Adding .conf suffix to x86info in /etc/modprobe.d/"
+ mv "${ROOT}"/etc/modprobe.d/x86info{,.conf}
+ fi
+}
+
+pkg_postinst() {
+ ewarn "Your kernel must be built with the following options"
+ ewarn "set to Y or M"
+ ewarn " Processor type and features ->"
+ ewarn " [*] /dev/cpu/*/msr - Model-specific register support"
+ ewarn " [*] /dev/cpu/*/cpuid - CPU information support"
+}