summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-08-26 22:57:49 +0000
committerTim Harder <radhermit@gentoo.org>2011-08-26 22:57:49 +0000
commitfa691dec9ae2a77bd3d0a08e1e54b7d92273dfdd (patch)
tree0c32d2ac05a93ea8cbcf9a69267738e2b70d297c /sys-apps
parentx11-libs/gtksourceview: Fix compilation against GTK 3.1.x (bug #380387) (diff)
downloadgentoo-2-fa691dec9ae2a77bd3d0a08e1e54b7d92273dfdd.tar.gz
gentoo-2-fa691dec9ae2a77bd3d0a08e1e54b7d92273dfdd.tar.bz2
gentoo-2-fa691dec9ae2a77bd3d0a08e1e54b7d92273dfdd.zip
Version bump. Add static-libs USE flag (bug #378275) and update to EAPI 4.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/sg3_utils/ChangeLog7
-rw-r--r--sys-apps/sg3_utils/sg3_utils-1.32.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/sys-apps/sg3_utils/ChangeLog b/sys-apps/sg3_utils/ChangeLog
index 5f0e154cbd6e..9e5b3e211e20 100644
--- a/sys-apps/sg3_utils/ChangeLog
+++ b/sys-apps/sg3_utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/sg3_utils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/ChangeLog,v 1.71 2011/06/17 03:41:42 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/ChangeLog,v 1.72 2011/08/26 22:57:49 radhermit Exp $
+
+*sg3_utils-1.32 (26 Aug 2011)
+
+ 26 Aug 2011; Tim Harder <radhermit@gentoo.org> +sg3_utils-1.32.ebuild:
+ Version bump. Add static-libs USE flag (bug #378275) and update to EAPI 4.
*sg3_utils-1.31 (17 Jun 2011)
diff --git a/sys-apps/sg3_utils/sg3_utils-1.32.ebuild b/sys-apps/sg3_utils/sg3_utils-1.32.ebuild
new file mode 100644
index 000000000000..c5e066af68f4
--- /dev/null
+++ b/sys-apps/sg3_utils/sg3_utils-1.32.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/sg3_utils-1.32.ebuild,v 1.1 2011/08/26 22:57:49 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Apps for querying the sg SCSI interface"
+HOMEPAGE="http://sg.danny.cz/sg/"
+SRC_URI="http://sg.danny.cz/sg/p/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND="sys-devel/libtool"
+RDEPEND="sys-apps/sdparm"
+PDEPEND=">=sys-apps/rescan-scsi-bus-1.24"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.26-stdint.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc ChangeLog AUTHORS COVERAGE CREDITS README*
+ dodoc doc/README examples/*.txt
+ newdoc scripts/README README.scripts
+ dosbin scripts/scsi*
+
+ # Better fix for bug 231089; some packages look for sgutils2
+ local path lib
+ path="/usr/$(get_libdir)"
+ for lib in "${D}"/usr/$(get_libdir)/libsgutils2.*; do
+ lib=${lib##*/}
+ dosym "${lib}" "${path}/${lib/libsgutils2/libsgutils}"
+ done
+
+ find "${D}" -name '*.la' -exec rm -f {} +
+}