summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-18 16:14:40 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-18 16:14:40 +0000
commitae84c31a4c5fb0bdc9c0e8e8463ff872c21be18a (patch)
tree9990c0edde05be230430c488cd360f1d4e8ef88f /sys-auth/openpam/openpam-20050616.ebuild
parentAdded myself as maintainer (diff)
downloadgentoo-2-ae84c31a4c5fb0bdc9c0e8e8463ff872c21be18a.tar.gz
gentoo-2-ae84c31a4c5fb0bdc9c0e8e8463ff872c21be18a.tar.bz2
gentoo-2-ae84c31a4c5fb0bdc9c0e8e8463ff872c21be18a.zip
Bump to latest upstream version patched to compile.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'sys-auth/openpam/openpam-20050616.ebuild')
-rw-r--r--sys-auth/openpam/openpam-20050616.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-auth/openpam/openpam-20050616.ebuild b/sys-auth/openpam/openpam-20050616.ebuild
new file mode 100644
index 000000000000..0e005a68a4ad
--- /dev/null
+++ b/sys-auth/openpam/openpam-20050616.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/openpam/openpam-20050616.ebuild,v 1.1 2006/04/18 16:14:40 flameeyes Exp $
+
+inherit multilib flag-o-matic autotools
+
+DESCRIPTION="Open source PAM library."
+HOMEPAGE="http://www.openpam.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86-fbsd"
+IUSE="debug"
+
+RDEPEND="!virtual/pam"
+DEPEND="sys-devel/make
+ dev-lang/perl"
+PDEPEND="sys-freebsd/freebsd-pam-modules"
+
+PROVIDE="virtual/pam"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch "${FILESDIR}/${PN}-20050201-gentoo.patch"
+ epatch "${FILESDIR}/${PN}-20050201-nbsd.patch"
+ epatch "${FILESDIR}/${P}-redef.patch"
+
+ eautomake
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ --disable-dependency-tracking \
+ --with-modules-dir=/$(get_libdir)/security \
+ ${myconf} || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install
+
+ dodoc CREDITS HISTORY MANIFEST RELNOTES README
+}