summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-08-25 06:08:05 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-08-25 06:08:05 +0000
commitdb6263d4f8ef2054320ff46dc42bec2cac137239 (patch)
treed85dfb41b18cef6f20c1fac07e9d913b76147ddb /sys-auth/pam_ldap/pam_ldap-180.ebuild
parentNew release: 2.11.92 (diff)
downloadgentoo-2-db6263d4f8ef2054320ff46dc42bec2cac137239.tar.gz
gentoo-2-db6263d4f8ef2054320ff46dc42bec2cac137239.tar.bz2
gentoo-2-db6263d4f8ef2054320ff46dc42bec2cac137239.zip
Version bump, bug #103659, security vuln. fixed.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-auth/pam_ldap/pam_ldap-180.ebuild')
-rw-r--r--sys-auth/pam_ldap/pam_ldap-180.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-auth/pam_ldap/pam_ldap-180.ebuild b/sys-auth/pam_ldap/pam_ldap-180.ebuild
new file mode 100644
index 000000000000..f6fceb3ae13d
--- /dev/null
+++ b/sys-auth/pam_ldap/pam_ldap-180.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ldap/pam_ldap-180.ebuild,v 1.1 2005/08/25 06:08:05 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="PAM LDAP Module"
+HOMEPAGE="http://www.padl.com/OSS/pam_ldap.html"
+SRC_URI="http://www.padl.com/download/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ssl"
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/pam-0.72
+ >=net-nds/openldap-2.1.30-r5"
+
+src_unpack() {
+ unpack ${A}
+ #EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-176-fix-referral-tls.patch
+
+ cd ${S}
+ export WANT_AUTOCONF=2.5
+ aclocal || die "aclocal failed"
+ autoconf || die "autoconf failed"
+ automake --add-missing || die "automake failed"
+}
+
+src_compile() {
+ econf --with-ldap-lib=openldap `use_enable ssl` || die
+ emake || die
+}
+
+src_install() {
+ exeinto /lib/security
+ doexe pam_ldap.so
+
+ dodoc pam.conf ldap.conf ldapns.schema chsh chfn certutil
+ dodoc ChangeLog COPYING.* CVSVersionInfo.txt README AUTHORS ns-pwd-policy.schema
+ docinto pam.d
+ dodoc pam.d/*
+}