summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2010-02-08 03:03:29 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2010-02-08 03:03:29 +0000
commit11b795ab9ac1e4c9e66d1b02da614e23a4a439d7 (patch)
treecf354254686ba0f17cec8eee07cf5a8cc54745e7 /sys-auth/rtkit
parentapp-portage/layman: Add missing "inherit eutils" for epause (bug #303849) (diff)
downloadgentoo-2-11b795ab9ac1e4c9e66d1b02da614e23a4a439d7.tar.gz
gentoo-2-11b795ab9ac1e4c9e66d1b02da614e23a4a439d7.tar.bz2
gentoo-2-11b795ab9ac1e4c9e66d1b02da614e23a4a439d7.zip
Initial commit. PulseAudio should start using this soon.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/rtkit')
-rw-r--r--sys-auth/rtkit/ChangeLog10
-rw-r--r--sys-auth/rtkit/metadata.xml14
-rw-r--r--sys-auth/rtkit/rtkit-0.6.ebuild42
3 files changed, 66 insertions, 0 deletions
diff --git a/sys-auth/rtkit/ChangeLog b/sys-auth/rtkit/ChangeLog
new file mode 100644
index 000000000000..c23fea15c130
--- /dev/null
+++ b/sys-auth/rtkit/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-auth/rtkit
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/rtkit/ChangeLog,v 1.1 2010/02/08 03:03:29 ford_prefect Exp $
+
+*rtkit-0.6 (08 Feb 2010)
+
+ 08 Feb 2010; Arun Raghavan <ford_prefect@gentoo.org> +rtkit-0.6.ebuild,
+ +metadata.xml:
+ Initial commit. PulseAudio should start using this soon.
+
diff --git a/sys-auth/rtkit/metadata.xml b/sys-auth/rtkit/metadata.xml
new file mode 100644
index 000000000000..2b23994c7e32
--- /dev/null
+++ b/sys-auth/rtkit/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>ford_prefect@gentoo.org</email>
+ <name>Arun Raghavan</name>
+ </maintainer>
+ <longdescription lang="en">
+ RealtimeKit is a DBus service that provides applications with an interface
+ to escalate their priority to realtime, without any special setup in
+ rlimits, etc.
+ </longdescription>
+</pkgmetadata>
diff --git a/sys-auth/rtkit/rtkit-0.6.ebuild b/sys-auth/rtkit/rtkit-0.6.ebuild
new file mode 100644
index 000000000000..9d5422bd00d9
--- /dev/null
+++ b/sys-auth/rtkit/rtkit-0.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/rtkit/rtkit-0.6.ebuild,v 1.1 2010/02/08 03:03:29 ford_prefect Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Realtime Policy and Watchdog Daemon"
+HOMEPAGE="http://0pointer.de/blog/projects/rtkit"
+SRC_URI="http://0pointer.de/public/${P}.tar.gz"
+
+LICENSE="GPL-3 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/dbus
+ sys-auth/polkit
+ sys-libs/libcap"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup rtkit
+ enewuser rtkit -1 -1 -1 "rtkit"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install"
+
+ ./rtkit-daemon --introspection > org.freedesktop.RealtimeKit1.xml
+ insinto /usr/share/dbus-1/interfaces
+ doins org.freedesktop.RealtimeKit1.xml
+}
+
+pkg_postinst () {
+ einfo "To start using RealtimeKit, you need to ensure that the 'dbus'"
+ einfo "service is running. If it is already running, you need to reload it"
+ einfo "with the following command:"
+ einfo ""
+ einfo " /etc/init.d/dbus reload"
+}