summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-04-14 01:46:13 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-04-14 01:46:13 +0000
commit28824f3048df3a00fc3e6806b1ab5c885548b4cb (patch)
treeb8776e3d8d978dea85c0c339b0628db27ad6ccb4 /sys-auth/rtkit
parentBump for infra-kernel-source, fix hppa keyword. (diff)
downloadgentoo-2-28824f3048df3a00fc3e6806b1ab5c885548b4cb.tar.gz
gentoo-2-28824f3048df3a00fc3e6806b1ab5c885548b4cb.tar.bz2
gentoo-2-28824f3048df3a00fc3e6806b1ab5c885548b4cb.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'sys-auth/rtkit')
-rw-r--r--sys-auth/rtkit/ChangeLog10
-rw-r--r--sys-auth/rtkit/files/rtkit-0.11-gettime.patch21
-rw-r--r--sys-auth/rtkit/files/rtkit-0.11-polkit.patch36
-rw-r--r--sys-auth/rtkit/rtkit-0.11.ebuild51
4 files changed, 116 insertions, 2 deletions
diff --git a/sys-auth/rtkit/ChangeLog b/sys-auth/rtkit/ChangeLog
index 7874756831d2..7377c7c4ee32 100644
--- a/sys-auth/rtkit/ChangeLog
+++ b/sys-auth/rtkit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/rtkit
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/rtkit/ChangeLog,v 1.28 2013/12/23 16:12:58 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/rtkit/ChangeLog,v 1.29 2014/04/14 01:46:13 mrueg Exp $
+
+*rtkit-0.11 (14 Apr 2014)
+
+ 14 Apr 2014; Manuel Rüger <mrueg@gentoo.org> +files/rtkit-0.11-gettime.patch,
+ +files/rtkit-0.11-polkit.patch, +rtkit-0.11.ebuild:
+ Version bump.
23 Dec 2013; Pacho Ramos <pacho@gentoo.org> -rtkit-0.6.ebuild,
-rtkit-0.7.ebuild, -rtkit-0.9-r1.ebuild, metadata.xml:
diff --git a/sys-auth/rtkit/files/rtkit-0.11-gettime.patch b/sys-auth/rtkit/files/rtkit-0.11-gettime.patch
new file mode 100644
index 000000000000..43732081386e
--- /dev/null
+++ b/sys-auth/rtkit/files/rtkit-0.11-gettime.patch
@@ -0,0 +1,21 @@
+From: Lennart Poettering <lennart@poettering.net>
+Date: Thu, 26 Sep 2013 19:52:58 +0000 (+0200)
+Subject: build-sys: since clock_gettime() moved to libc use mq_open to check for librt
+X-Git-Url: http://git.0pointer.de/?p=rtkit.git;a=commitdiff_plain;h=d550837387e4185ebcde1023702580e35eb441e7
+
+build-sys: since clock_gettime() moved to libc use mq_open to check for librt
+---
+
+diff --git a/configure.ac b/configure.ac
+index 5a77363..62c17f5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -111,7 +111,7 @@ CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
+ CC="$PTHREAD_CC"
+
+ AC_SEARCH_LIBS([sched_setscheduler], [rt])
+-AC_SEARCH_LIBS([clock_gettime], [rt])
++AC_SEARCH_LIBS([mq_open], [rt])
+ AC_SEARCH_LIBS([cap_init], [cap])
+
+ PKG_CHECK_MODULES(DBUS, dbus-1)
diff --git a/sys-auth/rtkit/files/rtkit-0.11-polkit.patch b/sys-auth/rtkit/files/rtkit-0.11-polkit.patch
new file mode 100644
index 000000000000..ad489c466184
--- /dev/null
+++ b/sys-auth/rtkit/files/rtkit-0.11-polkit.patch
@@ -0,0 +1,36 @@
+X-Git-Url: http://git.0pointer.de/?p=rtkit.git;a=blobdiff_plain;f=rtkit-daemon.c;h=3ecc1f7840a0d9bdd3af7f08933c4a62546094eb;hp=2ebe673309315f16bc2bc2e0c51a556fb215bc51;hb=88d4082ef6caf6b071d749dca1c50e7edde914cc;hpb=e86e04865ebc1a92c8fa3007843ebcf9c8fa4c05
+
+diff --git a/rtkit-daemon.c b/rtkit-daemon.c
+index 2ebe673..3ecc1f7 100644
+--- a/rtkit-daemon.c
++++ b/rtkit-daemon.c
+@@ -1170,12 +1170,14 @@ static int verify_polkit(DBusConnection *c, struct rtkit_user *u, struct process
+ DBusMessage *m = NULL, *r = NULL;
+ const char *unix_process = "unix-process";
+ const char *pid = "pid";
++ const char *uid = "uid";
+ const char *start_time = "start-time";
+ const char *cancel_id = "";
+ uint32_t flags = 0;
+ uint32_t pid_u32 = p->pid;
+- uint64_t start_time_u64 = p->starttime;
++ uint32_t uid_u32 = (uint32_t)u->uid;
+ DBusMessageIter iter_msg, iter_struct, iter_array, iter_dict, iter_variant;
++ uint64_t start_time_u64 = p->starttime;
+ int ret;
+ dbus_bool_t authorized = FALSE;
+
+@@ -1206,6 +1208,13 @@ static int verify_polkit(DBusConnection *c, struct rtkit_user *u, struct process
+ assert_se(dbus_message_iter_close_container(&iter_dict, &iter_variant));
+ assert_se(dbus_message_iter_close_container(&iter_array, &iter_dict));
+
++ assert_se(dbus_message_iter_open_container(&iter_array, DBUS_TYPE_DICT_ENTRY, NULL, &iter_dict));
++ assert_se(dbus_message_iter_append_basic(&iter_dict, DBUS_TYPE_STRING, &uid));
++ assert_se(dbus_message_iter_open_container(&iter_dict, DBUS_TYPE_VARIANT, "u", &iter_variant));
++ assert_se(dbus_message_iter_append_basic(&iter_variant, DBUS_TYPE_UINT32, &uid_u32));
++ assert_se(dbus_message_iter_close_container(&iter_dict, &iter_variant));
++ assert_se(dbus_message_iter_close_container(&iter_array, &iter_dict));
++
+ assert_se(dbus_message_iter_close_container(&iter_struct, &iter_array));
+ assert_se(dbus_message_iter_close_container(&iter_msg, &iter_struct));
+
diff --git a/sys-auth/rtkit/rtkit-0.11.ebuild b/sys-auth/rtkit/rtkit-0.11.ebuild
new file mode 100644
index 000000000000..a1dc586d924a
--- /dev/null
+++ b/sys-auth/rtkit/rtkit-0.11.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/rtkit/rtkit-0.11.ebuild,v 1.1 2014/04/14 01:46:13 mrueg Exp $
+
+EAPI=5
+
+inherit eutils systemd user autotools
+
+DESCRIPTION="Realtime Policy and Watchdog Daemon"
+HOMEPAGE="http://0pointer.de/blog/projects/rtkit"
+SRC_URI="http://0pointer.de/public/${P}.tar.xz"
+
+LICENSE="GPL-3 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-apps/dbus
+ sys-auth/polkit
+ sys-libs/libcap"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup rtkit
+ enewuser rtkit -1 -1 -1 "rtkit"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-polkit.patch \
+ "${FILESDIR}"/${P}-gettime.patch
+ eautoreconf
+}
+src_configure() {
+ econf $(systemd_with_unitdir)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ ./rtkit-daemon --introspect > org.freedesktop.RealtimeKit1.xml
+ insinto /usr/share/dbus-1/interfaces
+ doins org.freedesktop.RealtimeKit1.xml
+}
+
+pkg_postinst () {
+ einfo "To start using RealtimeKit, you need to ensure that the 'dbus'"
+ einfo "service is running. If it is already running, you need to reload it"
+ einfo "with the following command:"
+ einfo ""
+ einfo " /etc/init.d/dbus reload"
+}