summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-01-04 23:12:01 +0000
committerUlrich Müller <ulm@gentoo.org>2012-01-04 23:12:01 +0000
commit1524c75c5815e68db59e766f8abacb70a01cbc6f (patch)
tree3cf9c3827c96f7c135d3adbd68f970c01b3a41e7 /sys-auth/skey
parentclean up (diff)
downloadgentoo-2-1524c75c5815e68db59e766f8abacb70a01cbc6f.tar.gz
gentoo-2-1524c75c5815e68db59e766f8abacb70a01cbc6f.tar.bz2
gentoo-2-1524c75c5815e68db59e766f8abacb70a01cbc6f.zip
Install static library only with USE=static-libs.
Move all patches into patchset on Gentoo mirrors. Update ebuild to EAPI 4. (Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/skey')
-rw-r--r--sys-auth/skey/ChangeLog14
-rw-r--r--sys-auth/skey/skey-1.1.5-r8.ebuild78
2 files changed, 88 insertions, 4 deletions
diff --git a/sys-auth/skey/ChangeLog b/sys-auth/skey/ChangeLog
index 1f359820f7a4..7028d6588a97 100644
--- a/sys-auth/skey/ChangeLog
+++ b/sys-auth/skey/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/skey
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/skey/ChangeLog,v 1.14 2011/01/30 18:17:44 ulm Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/skey/ChangeLog,v 1.15 2012/01/04 23:12:01 ulm Exp $
+
+*skey-1.1.5-r8 (04 Jan 2012)
+
+ 04 Jan 2012; Ulrich Mueller <ulm@gentoo.org> +skey-1.1.5-r8.ebuild:
+ Install static library only with USE=static-libs. Move all patches into
+ patchset on Gentoo mirrors. Update ebuild to EAPI 4.
30 Jan 2011; Ulrich Mueller <ulm@gentoo.org> skey-1.1.5-r7.ebuild:
Add die statements throughout.
@@ -160,7 +166,7 @@
*skey-1.1.5-r4 (23 Sep 2004)
23 Sep 2004; Tavis Ormandy <taviso@gentoo.org> +skey-1.1.5-r4.ebuild:
- do not include /etc/skey/skeykeys in the package, as quickpkg may package
+ do not include /etc/skey/skeykeys in the package, as quickpkg may package
personal files. This also fixes the etc-update issue with #64974.
18 Sep 2004; Joshua Kinard <kumba@gentoo.org> skey-1.1.5-r3.ebuild:
@@ -241,6 +247,6 @@
*skey-1.1.5 (05 Sep 2003)
05 Sep 2003; Tavis Ormandy <taviso@gentoo.org> skey-1.1.5.ebuild:
- Initial import, Thanks to Jeb Campbell <jebc@c4solutions.net> for
+ Initial import, Thanks to Jeb Campbell <jebc@c4solutions.net> for
submitting the ebuild in #11478
diff --git a/sys-auth/skey/skey-1.1.5-r8.ebuild b/sys-auth/skey/skey-1.1.5-r8.ebuild
new file mode 100644
index 000000000000..974b596dd255
--- /dev/null
+++ b/sys-auth/skey/skey-1.1.5-r8.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/skey/skey-1.1.5-r8.ebuild,v 1.1 2012/01/04 23:12:01 ulm Exp $
+
+EAPI=4
+
+inherit flag-o-matic eutils toolchain-funcs
+
+DESCRIPTION="Linux Port of OpenBSD Single-key Password System"
+HOMEPAGE="http://www.openbsd.org/faq/faq8.html#SKey"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ mirror://gentoo/skey-1.1.5-patches-1.tar.xz"
+
+LICENSE="BSD MIT RSA-MD4 RSA-MD5 BEER-WARE"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND="dev-lang/perl
+ app-arch/xz-utils"
+RDEPEND="dev-lang/perl
+ sys-libs/cracklib"
+
+src_prepare() {
+ EPATCH_SUFFIX=patch epatch
+}
+
+src_configure() {
+ tc-export CC
+ econf --sysconfdir=/etc/skey
+}
+
+src_install() {
+ dobin skey skeyinit skeyinfo
+ newbin skeyaudit.sh skeyaudit
+ newsbin skeyprune.pl skeyprune
+
+ dosym skey /usr/bin/otp-md4
+ dosym skey /usr/bin/otp-md5
+ dosym skey /usr/bin/otp-sha1
+
+ use static-libs && dolib.a libskey.a
+
+ doman skey.1 skeyaudit.1 skeyinfo.1 skeyinit.1 skey.3 skeyprune.8
+
+ into /
+ dolib.so libskey.so.1.1.5 libskey.so.1.1 libskey.so.1 libskey.so
+ gen_usr_ldscript libskey.so
+
+ insinto /usr/include
+ doins skey.h
+
+ keepdir /etc/skey
+
+ # only root needs to have access to these files.
+ fperms g-rx,o-rx /etc/skey
+
+ # skeyinit and skeyinfo must be suid root so users
+ # can generate their passwords.
+ fperms u+s,og-r /usr/bin/skeyinit /usr/bin/skeyinfo
+
+ dodoc README CHANGES
+}
+
+pkg_postinst() {
+ # do not include /etc/skey/skeykeys in the package, as quickpkg
+ # may package sensitive information.
+ # This also fixes the etc-update issue with #64974.
+
+ # skeyinit will not function if this file is not present.
+ touch /etc/skey/skeykeys
+
+ # these permissions are applied by the skey system if missing.
+ chmod 0600 /etc/skey/skeykeys
+
+ elog "For an introduction into using s/key authentication, take"
+ elog "a look at the EXAMPLES section from the skey(1) manpage."
+}