summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-10-28 13:50:08 +0000
committerRick Farina <zerochaos@gentoo.org>2013-10-28 13:50:08 +0000
commit0255dcff40f2d048e1f82c9cc52a0ff067e24121 (patch)
tree237189f2bd3ed313145b2f306e5a9668df0a4e29 /sys-auth
parentversion bump, update download location (diff)
downloadgentoo-2-0255dcff40f2d048e1f82c9cc52a0ff067e24121.tar.gz
gentoo-2-0255dcff40f2d048e1f82c9cc52a0ff067e24121.tar.bz2
gentoo-2-0255dcff40f2d048e1f82c9cc52a0ff067e24121.zip
trivial version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/ykpers/ChangeLog7
-rw-r--r--sys-auth/ykpers/ykpers-1.14.1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/sys-auth/ykpers/ChangeLog b/sys-auth/ykpers/ChangeLog
index a6ec5a856631..450b3fe1c3fa 100644
--- a/sys-auth/ykpers/ChangeLog
+++ b/sys-auth/ykpers/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/ykpers
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykpers/ChangeLog,v 1.10 2013/08/10 12:37:25 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykpers/ChangeLog,v 1.11 2013/10/28 13:50:08 zerochaos Exp $
+
+*ykpers-1.14.1 (28 Oct 2013)
+
+ 28 Oct 2013; Rick Farina <zerochaos@gentoo.org> +ykpers-1.14.1.ebuild:
+ trivial version bump
*ykpers-1.14.0 (10 Aug 2013)
diff --git a/sys-auth/ykpers/ykpers-1.14.1.ebuild b/sys-auth/ykpers/ykpers-1.14.1.ebuild
new file mode 100644
index 000000000000..ab244b85a4f8
--- /dev/null
+++ b/sys-auth/ykpers/ykpers-1.14.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykpers/ykpers-1.14.1.ebuild,v 1.1 2013/10/28 13:50:08 zerochaos Exp $
+
+EAPI=5
+
+inherit eutils udev
+
+DESCRIPTION="Library and tool for personalization of Yubico's YubiKey"
+SRC_URI="http://yubico.github.io/yubikey-personalization/releases/${P}.tar.gz"
+HOMEPAGE="https://github.com/Yubico/yubikey-personalization"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE="static-libs consolekit"
+
+RDEPEND=">=sys-auth/libyubikey-1.6
+ virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ consolekit? ( sys-auth/consolekit[acl] )"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_install() {
+ default
+ dodoc doc/*
+ prune_libtool_files
+
+ use consolekit && \
+ udev_dorules 70-yubikey.rules
+}